Windows keeps creating pagefile.sys on my SSD

Discussion in 'Windows 8' started by Meneer, May 24, 2014.

  1. Meneer

    Meneer MDL Member

    Apr 2, 2014
    186
    194
    10
    #1 Meneer, May 24, 2014
    Last edited: May 24, 2014
    Hi MDL,

    Each time when my Windows 8.1 (with Update) boots up, it will create a pagefile.sys on my SSD.
    I have disabled the page file for my SSD and enabled it to create it on my HDD.
    But, Windows does not give a s**t about that.
    As you can see in the attached images, I have selected "Geen" (None) for my C: and E:, and let the system manage it on D:.
    When checking in Tskmgr.exe it also shows that my C: is a page-file disk.
    Is there a way to fix this?
    PC Specs:
    128GB Samsung SSD 840 PRO
    1TB Hiatchi Drive
    500GB External HDD
    6GB DDR RAM @ 1333MHz
    Intel Core i5 750 Quad Core @ 2,67GHz
    Thanks!
    1.png 2.png 3.png
     
  2. endbase

    endbase MDL Guru

    Aug 12, 2012
    3,901
    1,196
    120
    You know you have to reboot once to let windows adjust the settings i guess you know :)

    Second is the D disk ntfs ?
    and you could try sfc scannow from elevated cmd to check if your system is not broken

    Greetz de andere hollander
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Meneer

    Meneer MDL Member

    Apr 2, 2014
    186
    194
    10
    I have indeed rebooted after changing the settings.
    All my disks are on the NTFS.
    This is a fresh installation of Windows 8.1, but I will run SFC anyway ;)
     
  4. Meneer

    Meneer MDL Member

    Apr 2, 2014
    186
    194
    10
    #4 Meneer, May 24, 2014
    Last edited by a moderator: Apr 20, 2017
    (OP)
    Result:
    Code:
    PS C:\Windows\system32> sfc /scannow
    
    Beginning system scan.  This process will take some time.
    
    
    Beginning verification phase of system scan.
    Verification 100% complete.
    
    
    Windows Resource Protection did not find any integrity violations.
     
  5. endbase

    endbase MDL Guru

    Aug 12, 2012
    3,901
    1,196
    120
    #5 endbase, May 24, 2014
    Last edited: May 24, 2014
    Pagefile.png pagefile1.png

    Mhh that is a realy strange problem indeed i have the same setup and it is working well over here ! maybe you could check if the pagefile is realy on drive C with showing protected system files other wise my mind is blank on this one so let the pro's get in here good luck with it :)

    Greetz Base
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. Meneer

    Meneer MDL Member

    Apr 2, 2014
    186
    194
    10
    Did that already, pagefile and swapfile are their. I really want to get rid of them since the reduce my SSD's lifetime...
    4.png
     
  7. PaulDesmond

    PaulDesmond MDL Magnet

    Aug 6, 2009
    6,993
    7,143
    240
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. cuteee

    cuteee MDL Guru

    Oct 13, 2012
    3,226
    407
    120
    I have pagefile.sys : 704MB
    But hiberfil.sys I have 3.14GB. Is it normal ?
     
  9. bchat

    bchat MDL Smart Azz

    Nov 7, 2008
    1,722
    453
    60
    How much RAM do you have in your machine?
    Did you try running without a page file?
    What model SSD?

    I have/had several SSDs and always deleted the pagefile. I have 16 GB RAM in my machine and do no heavy game playing or photo work.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. f33nix

    f33nix MDL Member

    Apr 4, 2012
    153
    84
    10
  11. f33nix

    f33nix MDL Member

    Apr 4, 2012
    153
    84
    10
    Hiberfile should match your RAM in your machine, for laptops this is useful... for a desktop PC I would disable this.
     
  12. f33nix

    f33nix MDL Member

    Apr 4, 2012
    153
    84
    10
    Look at his 3rd picture...
    6GB of RAM and he has a Samsung 840 Pro
     
  13. cuteee

    cuteee MDL Guru

    Oct 13, 2012
    3,226
    407
    120
    But if you disable the Hiberfile.sys the fast boot option will not work.
     
  14. bchat

    bchat MDL Smart Azz

    Nov 7, 2008
    1,722
    453
    60
    My bad - looked at 1st, saw it wasn't English, and closed them.
    With 6 GB RAM probably should keep pagefile.
    Samsung Pro is a good SSD, I have 3 EVOs...;)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  15. endbase

    endbase MDL Guru

    Aug 12, 2012
    3,901
    1,196
    120
    #16 endbase, May 24, 2014
    Last edited: May 24, 2014
    Nvm was too late did not see the second page !
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  16. pisthai

    pisthai Imperfect Human

    Jul 29, 2009
    6,857
    2,029
    210
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  17. f33nix

    f33nix MDL Member

    Apr 4, 2012
    153
    84
    10
    I think you missed what the issue is here.

    The OP he knows how to change the settings... it is just that when he reboots Windows ignores him and creates a pagefile on his C: drive.

    This is what he needs help with... getting Windows to save his preferences.
     
  18. pisthai

    pisthai Imperfect Human

    Jul 29, 2009
    6,857
    2,029
    210
    If you had read what I wrote, also may had tested that, you would have know that those is working just fine.

    And for sure, everything what you do to any of the Windows system files, you have to do that as Administrator and NOT as User! That should be known to any normal Windows user, except a Newbie, something the OP isn't!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  19. Meneer

    Meneer MDL Member

    Apr 2, 2014
    186
    194
    10
    #20 Meneer, May 24, 2014
    Last edited: May 24, 2014
    (OP)
    Hi, I definitely know where and how to adjust the Pagefile settings.
    To keep it short; This is my page-filing setup:
    5.png 6.png

    Even though I have this as my settings, Windows keeps creating a Pagefile on C: each time I reboot, I do not want this to happen, since that will reduce the lifetime of my Samsung 128GB 840 PRO.
    Everytime I reboot I get this error message (Googled the English version):
    7.png
    This says basically: We ignore your settings and create a Page File on all of your disks, including you SSD.
    How do I force Windows to NOT create a pagefile on my drives, except D:.
    And; To change any page-file settings, you must be an Administrator, which I indeed am...