Windows Server 2012 Essentials shared folder

Discussion in 'Windows Server' started by Lazze, Mar 8, 2013.

  1. Lazze

    Lazze MDL Novice

    Mar 2, 2013
    10
    0
    0
    Hello everyone.

    I am trying to set up a folder on my server for all my movies. The problem is that I can't figure out how to share this folder for anyone, not just users. I want guests on the network to be able to access the folder, how do I do this?
     
  2. CorporateRAT

    CorporateRAT MDL Member

    Aug 4, 2012
    235
    44
    10
    You need to grant permission to access this folder to everyone group.
     
  3. Lazze

    Lazze MDL Novice

    Mar 2, 2013
    10
    0
    0
    I tried that, but when I try to browse the server on the network, it still asks me for a username and password.
     
  4. CorporateRAT

    CorporateRAT MDL Member

    Aug 4, 2012
    235
    44
    10
    Control Panel->administrative tools->local security policy there is a stetting called: "Network Access: Shares that can be accessed anonymously". Try entering path to your share there.
     
  5. Lazze

    Lazze MDL Novice

    Mar 2, 2013
    10
    0
    0
    That did not do the trick. It still asks me for a password when I try to access the share.
     
  6. sebus

    sebus MDL Guru

    Jul 23, 2008
    5,770
    1,727
    180
    Rubbish! Did you reboot? Or at least gpupdate /force

    Seb
     
  7. Lazze

    Lazze MDL Novice

    Mar 2, 2013
    10
    0
    0
    Just tried, no luck yet. I should mention that I am not using the domain features, my setup is purely WORKGROUP based since I skipped the domain setup.
     
  8. CorporateRAT

    CorporateRAT MDL Member

    Aug 4, 2012
    235
    44
    10
    #8 CorporateRAT, Mar 9, 2013
    Last edited: Mar 9, 2013
    Ok. Try changing this one as well: "Network access: Let Everyone permissions apply to anonymous users". It has been disabled by default since srv 2008 to harden security, but i assume your server is behind firewall.
     
  9. Lazze

    Lazze MDL Novice

    Mar 2, 2013
    10
    0
    0
    That did not work either. I tried enabling the guest account, and that worked fine, but I cannot select which folders it has access to or not. There must be a way to do it without enabling that.
     
  10. CorporateRAT

    CorporateRAT MDL Member

    Aug 4, 2012
    235
    44
    10
    What types of clients do you use to connect to this share?
     
  11. Lazze

    Lazze MDL Novice

    Mar 2, 2013
    10
    0
    0
    Just my home computers. I essentially want them to be able to access the share without using a username or a password, kind of like the guest user allows me. This is possible using Windows 8, but I can't get it to work with this. I also use the client backup feature of WS2012E, so switching to Windows 8 is not an option.
     
  12. cyberbot

    cyberbot MDL Senior Member

    Jul 30, 2011
    463
    20
    10
    If it asks for username and password for the share,
    check the permission, check if both computers are on the same workgroup, otherwise create a workgroup,
     
  13. Lazze

    Lazze MDL Novice

    Mar 2, 2013
    10
    0
    0
    When I try to open the share from a client PC, I get prompted for a username and a password. I have tried sharing it with the Everyone user group, but that does not work either. They are all on the same WORKGROUP.