Windows Server 2016 Essentials server backup restore test

Discussion in 'Windows Server' started by MrG, Feb 2, 2020.

  1. MrG

    MrG MDL Expert

    May 31, 2010
    1,062
    311
    60
    I have been wanting to test my WSE2016 backups to feel they work & be assured I can recover my critical data in the advent of a outage or disaster.

    Since I have no extra server to test the Backup(s) on I tried Hyper-V... FAIL
    Next I tried VMware 11 Workstation, that worked fine on restoring the Server OS to a new virtual drive. I did have to jump through several hoops to figure out how to pull it off but late last night I had good results, the VM booted & it appears most everything is good in the OS, incl my settings & preferences.

    So if anyone here wants to test their Server backup post here & I'll try to help you.

    WSE2016 BU Test on VMware11_ 2Restore_ 4Restart.jpg WSE2016 BU Test on VMware11_ 2Restore_ 5b.jpg WSE2016 BU Test on VMware11_ 3Running_ 2bDashboard.jpg
     
  2. MrG

    MrG MDL Expert

    May 31, 2010
    1,062
    311
    60
    #2 MrG, Feb 22, 2020
    Last edited: Feb 23, 2020
    (OP)
    This AM I tested installing a WSE2016 System BU after I backed-up the WSE2016 machine by only updating the System BU instead of wiping & installing a fresh BU on the WD Passport drive.

    Then I wiped the VMware Workstation 11 drive that had the WSE2016 previous BU install (above post).
    Using the same settings as above this BU install only took 11 minutes, way faster than my above install.
    It was successful. So now I suppose I can trust my WSE2016 system updated BUs too.

    I took screenshots throughout the test.
    I suppose if anyone here wants to test their WSE or Server BU & need some tips, post here & I'll try to help you.

    Edit: Here are a couple screenshots of the disk cleanup after above install... OOps I noticed I didn't rename it to WSE2016

    WSE2016 BU Test on VMware11_ 2Running_ 4bDiskCleanup.jpg WSE2016 BU Test on VMware11_ 2Running_ 4cDiskCleanup.jpg
     
  3. MrG

    MrG MDL Expert

    May 31, 2010
    1,062
    311
    60
    I tried the Server backup cleanup, recovered 83.9 GB of space,
    let it run Saturday night @ 11:59 PM, it started & ran automatically.