Windows7 + Office 2007

Discussion in 'Windows 7' started by ante_ante, Jan 20, 2009.

  1. ante_ante

    ante_ante MDL Novice

    Jan 2, 2009
    38
    0
    0
    Has anyone manage to install Office 2007 on the latest beta build 7000 ?
    The installation starts but then stops and nothing happens.

    I have tried this, but the problem is that i dont have any " MachineThrottling " in regedit.
    So can i just put it in there or ?

    Open Registry
    Navigate to HKEY_LOCAL_MACHINE\Software\Microsoft\SQMClient\Wi ndows\Disabled Sessions
    Rename key 'MachineThrottling' to '_MachineThrottling'


    Pls help :)
     
  2. ph03n!x

    ph03n!x MDL Member

    Apr 21, 2008
    125
    0
    10
    There is a thread of software compatibility in Windows 7 - I was able to get Office 2007 to install without any problems, that was right after it was leaked around Christmas...
     
  3. Sassafras_and_Moonshines

    Dec 6, 2008
    35
    0
    0
    office 2007 is as compatible with windows 7 as in vista.i didnt have a hard time installing and using it.

    cheerio
     
  4. bchat

    bchat MDL Smart Azz

    Nov 7, 2008
    1,722
    453
    60
    I have installed it on every build that has come out, 32 as well as 64 bit. Try inserting the CD, expanding it in Windows Explorer, right clicking on setup.exe and run as administrator.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. HSChronic

    HSChronic MDL Expert

    Aug 25, 2007
    1,213
    57
    60
    same. no issues here. Sounds like bad media or something.
     
  6. cartoon_hero

    cartoon_hero MDL Junior Member

    Oct 8, 2008
    60
    1
    0
    installed office 2007 then installed SP1, after that i installed all the updates found on Windows update, all works fine on all builts with no problems ...
     
  7. ZaForD

    ZaForD MDL Expert

    Jan 26, 2008
    1,180
    178
    60
    Same here, Office 2007 Ultimate and Enterprise and Office 2003 Pro all installed fine on Windows 7 x86 and x64.

    In fact so does Works9, but its probably best not to mention that. :D
     
  8. HSChronic

    HSChronic MDL Expert

    Aug 25, 2007
    1,213
    57
    60
    I think this bug might be related to the MSI/WinUpdate bug due to the Customer Experience Improvement Program. Try using the solution posted for that and see what happens.
     
  9. win7

    win7 MDL Senior Member

    Dec 21, 2008
    254
    1
    10
    Worked fine for me using the blue edition (ther one with three themes)..