WinPE optional components 17133.1

Discussion in 'Windows 10' started by norcal650ant, Apr 19, 2018.

  1. norcal650ant

    norcal650ant MDL Novice

    Apr 11, 2017
    2
    0
    0
    Trying to update my windows PE and windows re optional components to support Powershell and HTA support OS build 17133.73 I have both ADK 1709 and The Insider build 17125.0 but have not been able to add the optional components needed to either the windows re-image or the boot image I know there's got to be a way around...
     
  2. pisthai

    pisthai Imperfect Human

    Jul 29, 2009
    6,861
    2,029
    210
    Have you check to use ToolKit v.8.2 for to add components?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. endbase

    endbase MDL Guru

    Aug 12, 2012
    3,914
    1,212
    120
    There is allready Toolkit v.8.3 just saying ;)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. norcal650ant

    norcal650ant MDL Novice

    Apr 11, 2017
    2
    0
    0
    No what us toolkit 8.3 will it allow me to update my Windows 10 1803 10.0.1733.73 WinRE.wim and boot.wim to support the missing optional component package such as winpe-Powerhell. I really want to add Powershell support to my boot image and Windows recovery tools. I haven't found a way to do it yet thank you for your response so fast
     
  5. GodHand

    GodHand MDL Senior Member

    Jul 15, 2016
    378
    410
    10
    Let me check if my New-WinPE PowerShell function script works with this latest build. It should since it works with 17133.1 just fine. If so, I will send it to you.
     
  6. pisthai

    pisthai Imperfect Human

    Jul 29, 2009
    6,861
    2,029
    210
    Thanks for that info! Will try that for the official coming Spring Upgrade to create a new User ISO for to use on my low Power Windows Tablets, special the W803T. The modified Fall Upgrades just working very well on that Tablets.

    To the OP:
    Just read the info and explanation for the ToolKit and you should be able to add to the WIM what you really want and need. Just follow the advice given in the Readme Files and you should have no problems.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. xinso

    xinso MDL Guru

    Mar 5, 2009
    4,242
    5,511
    150
  8. Flipp3r

    Flipp3r MDL Expert

    Feb 11, 2009
    1,544
    662
    60
    Just use the current 17133.1 ADK. Links are in the deployment/imaging thread.
    Also updated msdart found in toolkit 8.3...