[WIP] Sound Blaster X-Fi PCI [FULL SOFTWARE SUITE] download coming soon...

Discussion in 'Application Software' started by RanCorX2, Jun 4, 2011.

  1. RanCorX2

    RanCorX2 MDL Addicted

    Jul 19, 2009
    855
    412
    30
    #1 RanCorX2, Jun 4, 2011
    Last edited: Jun 19, 2011
    coming soon.

    Installer has been modified, installation bitmaps have been resized and edited to fit around progress bar. Autorun folder has been replaced with retail one, includes original intro, button sounds and some slightly edited bitmaps. Scripts have been modified for an extra optional install feature, media toolbox 6 trial. (it's the full version if you have a licence)
     
  2. R29k

    R29k MDL GLaDOS

    Feb 13, 2011
    4,675
    4,276
    150
    I tried this a while back the problem is that the installer might most likely view your cab as corrupt due to differing file sizes.
     
  3. RanCorX2

    RanCorX2 MDL Addicted

    Jul 19, 2009
    855
    412
    30
    I finally found a program that works and that doesn't screw up the cab file structure! it's called ACDZip, i've already tested it and updated some cabs and the installers worked perfectly :)

    The reason I ask was, I've been doing a little project for the past few days, using various custom unofficial x-fi installer iso's and official creative installers from the ccftp, i've created an updated software suite for pci x-fi owners.

    so far i've found updated versions of most of the software apps and have put together a hybrid driver set, based on SBXF_PCDRVBETA_US_2_18_0015.exe & XFRL_PCDRVBETA_US_3_00_1006.exe (a pci-e titantium driver) the included driver is 98% version v3.00.1006 / 6.0.300.1006 and includes some files from an Auzentech Forte driver. build 1402.

    Testing has proved a success and all the software & driver files install fine with no bsod's. I'm going to upload it sometime soon to share if there are any x-fi pci owners out there that want to try some new stuff.

    I've been using the PAX drivers for a while but have never liked the fact the creator plastered his logo and name over everything, not saying i'm a creative fan boy but i like the stuff I install to look legit and my re-packed suite has no custom logos or tweaks, just proper files sourced from here and there to bring the old up to date with the new. Also his releases have some bugs that haven't been ironed out for ages, like the fact you have to rename files after installing the THX console, something i've fixed now.
     
  4. R29k

    R29k MDL GLaDOS

    Feb 13, 2011
    4,675
    4,276
    150
    That would be a great release if it works, when is RTM date? :eek:
     
  5. RanCorX2

    RanCorX2 MDL Addicted

    Jul 19, 2009
    855
    412
    30
    should be in the next few days, going to do a fresh install of the suite to see if it still works, found some newer files in some more creative installers last night.
     
  6. RanCorX2

    RanCorX2 MDL Addicted

    Jul 19, 2009
    855
    412
    30
    if anyone downloaded what i uploaded, don't bother with it, I've been working on a better software suite, I only just found out how to add missing applications to the installer without trying to make a new installer, because I know b'all about installshield anyway. Was a real time saver...

    I took one of the many freely available x-fi installation iso's floating about the net and started merging all the available supported software into it, and updating other bits n bobs. Sofar it works perfectly on my pci xtrememusic oem card, I used a modified Titanium install disc this time instead of one of the old pci x-fi discs, a lot of the newer stuff screws up with the old setup.

    sofar i've merged 28 apps into the Audio folder and 11 plugins into the Mediasource 5 setup folder, the version on the disc I downloaded was the OEM version but I had another iso with the retail version so i've edited some files so it sees all the supported software. btw CMS5 is free, retail came with original install disc and oem is available to download from creative with less plugins of course, yet on their ccftp site all the plugins are there for the taking....:rolleyes:

    must of downloaded around 12 iso's and over 50 installers, taking a while but i've almost put together the ultimate install disc (queue lightning and dodgy laughter)

    now I don't know if this is frowned upon but to me it's not warez because i'm using freely available bits of software and have not used any cracks etc, just notedpad and time. So I will share it soon, unless otherwise told not too or banned from the forum.

    mods, feel free to chime in and tell me if what i've posted is fine?
     
  7. robalm

    robalm MDL Senior Member

    Oct 21, 2009
    330
    47
    10
    This driver is not working on "SB X-Fi Xtreme Audio" w7 -64?
    The installer disappear when i choose language o_O
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. RanCorX2

    RanCorX2 MDL Addicted

    Jul 19, 2009
    855
    412
    30
    sorry, xtreme audio is not supported because it's not a proper x-fi card, it has no 20k processor. I thought I mentioned that, if not opps.
     
  9. robalm

    robalm MDL Senior Member

    Oct 21, 2009
    330
    47
    10
    Ok, thanks anyway :)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. CHaynes112

    CHaynes112 MDL Novice

    Aug 30, 2009
    15
    0
    0
    Greetings,

    I had a few questions...

    1. Any updates on this (when will it be released)?
    2. Will there be a PCI-E version (please say yes... I have an X-Fi Titanium)?
    3. I noticed Creative ALchemy 1.43.09 is out, but you included .08?
    4. Is the newer AutoMode Switcher 1.01.05 broken as well?
    5. What was the deal with the file that you had to replace (I saw you talking to Robert from PAX about it)?

    -Thanks
     
  11. RanCorX2

    RanCorX2 MDL Addicted

    Jul 19, 2009
    855
    412
    30
    hi, yea sorry but I've given up, realised I was wasting too much time on it and had to get back to other stuff. I also removed the x-fi card from my pc and switched to the onboard audio which I've never used for 3 years and discovered it's bass came through my 5.1 speakers better than through the x-fi, werid huh? the speakers are creative ones btw.

    Also the mcp temp dropped from 65*c to 45-46*c idle which I thought was odd, but welcome. I've kept all the files so I might still upload the iso sometime.

    And no, it's PCI only, also really a new alchemy is out? oh well.