Xbox One Controller Not Working On Windows 10

Discussion in 'Windows 10' started by TranzTeKk, Sep 3, 2015.

  1. TranzTeKk

    TranzTeKk MDL Novice

    Jul 17, 2015
    #1 TranzTeKk, Sep 3, 2015
    Last edited: Sep 3, 2015
    Hey so I am having a bit of a problem here. I got a new Xbox One over the weekend and decided to use it on my PC for some of my PC games as well.

    However, it simply does not work. It was listed in Device Manager, so I decided to right click and uninstall all the controller drivers from the Device Manager hoping it would reinstall them and work properly. This was not the case however, they are gone for good.

    So in short, nothing relating to any controller is showing up in the Device Manager. It is not even showing up on the "Devices and Printers" portion of the control panel either.

    I have downloaded and installed the Xbox One Controller drivers from Xbox themselves (for Windows 7/8.1 apparently since it's preinstalled on Windows 10.. however I uninstalled them and now they're gone, so I went with these) and it installed fine. However, same thing.. not showing up anywhere. It's as if they aren't even installed. I even tried reinstalling and nothing. My PC acts as if nothing is plugged in.

    I have tried different Micro USB cables and all my USB ports as well and same thing, nothing.

    When plugging the controller in, it just rumbles for a split second and that's it.

    Does anyone know how I can resolve this? It's driving me bonkers at this point.

    EDIT: Also I apologize if I am asking this in the wrong section I figured this was a driver issue relating to windows 10, so I posted it here. Please move it appropriately if I have done so.