Xbox One wireless receiver Model 1790 drivers for LTSB 2015 v1507

Discussion in 'Windows 10' started by mehargags, Aug 5, 2018.

  1. mehargags

    mehargags MDL Junior Member

    Dec 1, 2008
    91
    5
    0
    Hi Everyone,
    I'm running an old (but perfectly running) LTSB 1507 and since my old xbox 360 wirefless controller died, I got a new one with Xbox One wireless receiver Model 1790 which is only allegedly compatible with windows 10.

    It keeps showing unknown "xbox acc" in device manager. I refered a few topics and tried to install a few .cab INFs from MS Update catalog but it still doesn't work.

    The controller worked flawlessly on the current 1607 LTSB... so I think I will either have to clean install to 1607 ? or does anyone have a definite driver that worked for this receiver ? I'm refraining from installing 1607 siting LTSC 2018 releasing in a few months... pls advise
     
  2. iFlaX

    iFlaX MDL Member

    Apr 10, 2015
    204
    136
    10
    I don't have an solution to get your controller to work wireless, but if you plan on installing LTSC 2018, maybe you can just use a Micro USB cable for your controller untill the release of LTSC 2018.
     
  3. RanCorX2

    RanCorX2 MDL Addicted

    Jul 19, 2009
    869
    429
    30
    you need to take ownership of the folders, right click folder and go to properties and change the permissions for Administrators.

    1. Administrator > edit > tick all boxes under the Allow column. you might have to click advanced and change the owner first.

    2 .advanced > "change" > advanced > find now

    3. then clicked Administrators > ok > replace owner on subcontainers and objects > apply > ok
    then do 1. again if you had to do 2 & 3.
     
  4. ftlnparis

    ftlnparis MDL Novice

    Sep 4, 2016
    23
    17
    0
    #6 ftlnparis, Aug 8, 2018
    Last edited: Aug 8, 2018
    Attached is the newer smaller xbox one controller dongle driver extracted from WIN Pro :

    Driver : oem12.inf
    OriginalFileName : C:\Windows\System32\DriverStore\FileRepository\mt7612us_rl.inf_amd64_75ab4556628c9849\mt7612us_rl.inf
    Inbox : False
    ClassName : Net
    BootCritical : False
    ProviderName : Xbox
    Date : 11/07/2017 00:00:00
    Version : 1.0.46.1

    Maybe you can install it via device mananger, and let us know if it works ?
     

    Attached Files:

  5. ftlnparis

    ftlnparis MDL Novice

    Sep 4, 2016
    23
    17
    0
    Anybody know how I can get non trial version of ltsb without a microsoft account ?
     
  6. kgtuning

    kgtuning MDL Junior Member

    Aug 26, 2015
    59
    46
    0
    User "God666" has a download in her signature or search for online for "the-eye"
     
  7. the_soft45

    the_soft45 MDL Junior Member

    Mar 28, 2016
    80
    28
    0
    Anybody test these drivers yet? Could be a great thing to get them working on 8.1 or 7 aswell (assuming they even work on 1507 LTSB as OP needed)...
     
  8. ftlnparis

    ftlnparis MDL Novice

    Sep 4, 2016
    23
    17
    0
    #12 ftlnparis, Aug 9, 2018
    Last edited: Aug 9, 2018
    NO it doesnt, it showed up as "xbox acc" with no driver, right clicking also failed to pick up a driver from windows update, only manualy right clicking the device in device manager and updating the driver to the drivers attached previusoly gets this dongle to work. Also, point me to a v1511 iso and I can make the test.
     
  9. s1ave77

    s1ave77 MDL Guide Dog/Dev

    Aug 15, 2012
    15,151
    20,584
    340
    LTSB 2015 is build 1507 :cool2:.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. the_soft45

    the_soft45 MDL Junior Member

    Mar 28, 2016
    80
    28
    0
    I know, but it does have the build ready for testing... I guess in this case all it matters is the build version for testing and not the edition.
     
  11. Enthousiast

    Enthousiast MDL Tester

    Oct 30, 2009
    16,162
    19,836
    340
  12. ftlnparis

    ftlnparis MDL Novice

    Sep 4, 2016
    23
    17
    0
    So the dongle fails to install on 1507 LTSB, only seems to be compatible with LTSB 1607