XFX 780i P09 SLIC 2.1 (HP) + MEDIA SHIELD v9.87

Discussion in 'BIOS Mods' started by chinobino, Dec 12, 2009.

Tags:
  1. chinobino

    chinobino MDL Member

    Jul 28, 2009
    160
    56
    10
    #1 chinobino, Dec 12, 2009
    Last edited by a moderator: May 23, 2017
    I have modded the XFX P09 BIOS for the 780i myself, tested and confirmed working on my own motherboard :).

    I used the Award Tool found here, using the 0+2=0+2 method to add the HP SLIC v2.1.

    I have also updated Mediashield (nvraid.rom from ASUS Striker II Extreme, 790i Ultra SLI BIOS 0603) to v9.87 using CBROM32 v1.95.

    DOWNLOAD
     
  2. chinobino

    chinobino MDL Member

    Jul 28, 2009
    160
    56
    10
    Lots of views but not even one comment?

    I am currently running four Intel x25-m 80 GB SSD's in RAID0 on this motherboard using the updated Mediashield v9.87 without issues.

    [​IMG]

    I also have a 1TB SATA storage drive and an Asus SATA DVD-ROM on the same 780i SATA contoller, all working fine.
     
  3. v_source18

    v_source18 MDL Novice

    Feb 7, 2010
    1
    0
    0
    Thanks. This Bios works well..

    well maybe someone can make bios for crossfireX hack for xfx 780i? :D

    if anyone does, just send me a private message, thanks!
     
  4. flipicaneze

    flipicaneze MDL Junior Member

    Dec 18, 2009
    58
    2
    0
    I viewed only because I am shopping for motherboards and wanna make sure that there is a Windows 7 slic available. Sorry not to make much of a comment.
     
  5. acidrock

    acidrock MDL Junior Member

    Mar 4, 2008
    59
    0
    0
    #5 acidrock, Mar 18, 2010
    Last edited by a moderator: May 23, 2017
    Thanks

    Thanks for the link your work, it work for me awesome!!!
     
  6. chinobino

    chinobino MDL Member

    Jul 28, 2009
    160
    56
    10
    #6 chinobino, Apr 9, 2010
    Last edited: Apr 9, 2010
    (OP)
    Thanks!

    Thanks for posting your feedback.

    I have a BIOS for the 780i (EVGA, XFX & HP) that allows crossfire using 3x00 series and 4x00 series cards (NOT 4870 X2's though) with a special ATi driver - it's old though - Catalyst 8.7.

    I haven't had a chance to test it yet.

    I need to borrow some ATi cards from my friends to test it out...

    Hey, no problem. Others have tested this and it works.

    You're welcome :).

    I have a special XFX P10 custom bios out now!

    GET XFX 780i P10 HERE!
     
  7. bingorimer

    bingorimer MDL Novice

    Oct 3, 2010
    1
    0
    0
    Hi!

    I'm trying to get this working but it just won't work for some reason. I should mentioned I've tried the Slic DUMP Toolkit and when I run this i receive an error message and then the program terminates. This used to work before I flashed my BIOS with the XFX official P09 rom.
    I've flashed my mb using your custom bios using nvidia control panel in windows 7x64Ultimate. I received a message saying it flashed successfully.

    I rebooted and this morning i installed the HP-Compaq certificate from the windows repository in this forum. I then proceeded to install the HP serial number for Ultimate. The oem code is identical to this one here. Yet it says i still need to activate my windows after I've rebooted. When i try to click activate it says my key is invalid.
    what am I doing wrong please? I've jsut reinstalled the OS so there's no old stuff interfering.

    Can someone that got this working please explain exactly how you guys did to get this working?

    Thanks!
     
  8. chinobino

    chinobino MDL Member

    Jul 28, 2009
    160
    56
    10
    #8 chinobino, Dec 24, 2010
    Last edited: Feb 3, 2011
    (OP)
    Please note that my XFX 780i P10 BIOS uses Dell SLIC and not HP-Compaq as on P09, I changed to Dell to allow for Windows Server 2008 activation (32-bit OS with support for more than 4GB RAM).
     
  9. p4spooky

    p4spooky MDL Addicted

    Mar 9, 2008
    928
    3
    30
    Great work, any chance to you can make this bios for a Zotac 780i board? I am interested in P09 with updated ROMs if possible.

    You can find the P08 Zotac Bios HERE

    Thanks for your help
     
  10. Luisile

    Luisile MDL Novice

    Nov 19, 2010
    47
    1
    0
    Hi any chance for that latest nvraid.rom working on asus m2n sli deluxe? its a nforce570sli chpset. i have some issues with ssd drives in raid mode . thanks for answer
     
  11. chinobino

    chinobino MDL Member

    Jul 28, 2009
    160
    56
    10
    Hey p4spooky - Unfortunately I don't have access to a Zotac 780i board and I can't modify some strings in the bootblock bin's without actually having the board (and if the bootblock mod fails your mobo becomes a brick...).

    Because you have a Nvidia 780i reference board you can just force flash the EVGA P10 BIOS (or my custom XFX P10 BIOS) as it has the same hardware, using Awardflash v8.65

    You will need to use the following 3 switches when flashing from DOS;

    awdflash 7B1N2P10.BIN /py /wb /cd

    Make a backup of your current BIOS before you do it, so you can flash back if you have any issues.

    I had a look at the latest BIOS (1804) which contains Media Shield v6.73 (NVRAID.ROM) but that BIOS is packed so damn tight with only 2.7 KB space remaining...

    I put Media Shield v9.87 into the BIOS but there is simply not enough room (need 17 Bytes after compression), I suppose I could remove the LOGO (or black it out) but there's no guarantee that v9.87 would even work it's such a large version jump...

    This is probably best left to Yen or someone that actually has the board to test with - I really don't want to brick your motherboard.
     
  12. Luisile

    Luisile MDL Novice

    Nov 19, 2010
    47
    1
    0
    thank for answer but instead of bios 1804 look at 1701. the 1804 is a beta bios that dont work for me. The system do not run on it i am happy that i have recovered it back to 1701...