XP Desktop Icons !!!!!!!

Discussion in 'Windows XP / Older OS' started by Focusman, Oct 11, 2010.

  1. Focusman

    Focusman MDL Novice

    Oct 11, 2010
    7
    0
    0
    Does anyone know how to stop the desktop icons changing positions when changing users in XP. This has just started to happen and all settings are identical i.e align to grid, display properties etc:
     
  2. Focusman

    Focusman MDL Novice

    Oct 11, 2010
    7
    0
    0
    XP Desktop Icons

    Thanks for the tip and download link, unfortuneately my icons still move after switching identities after downloading the fix
     
  3. venu

    venu MDL Addicted

    Oct 16, 2009
    894
    99
    30
    Thats happening cos each account has a separate desktop folder. if you login as administrator you should be able to look at the folders in Documents and Settings. Each of those folders has a hidden file called 'desktop.ini' that contains info about where and howthe icons are arranged etc. Unhide hidden files and file extensions in Folder Options in Control panel, then copy one ini to the other desktop folder.
     
  4. urie

    urie Moderator
    Staff Member

    May 21, 2007
    8,714
    3,077
    300
    Nice reply venu, I remember a member good few months back that made a script to delete desktop.ini files. :D for the life of me I couldn't understand why I knew what desktop.ini files do and for all the space they take up :)
     
  5. Focusman

    Focusman MDL Novice

    Oct 11, 2010
    7
    0
    0
    Thanks for that but after revealing files I cannot find the "desktop.ini" extension in any user a/c desktop settings........could that be the problem and if so where do I get it
    Cheeers for the advice
     
  6. venu

    venu MDL Addicted

    Oct 16, 2009
    894
    99
    30
    Logon into your account.

    1.In any Windows Explorer window, click Tools → Folder Options…
    2.Click on the View tab.
    3.Uncheck radio button next to “Do not show hidden files and folders”.
    4.Uncheck box next to “Hide protected operating system files (recommended)”.
    5.Click OK

    That'll show up the desktop.ini for that user, copy and paste into other users desktop.
     
  7. Focusman

    Focusman MDL Novice

    Oct 11, 2010
    7
    0
    0
    Thanks, done that and hidden files are shown ie NATUSER Dat File and ntuser.dat but definitely no "destop.ini". Any more suggestions......Cheers
     
  8. urie

    urie Moderator
    Staff Member

    May 21, 2007
    8,714
    3,077
    300
    Are you looking on C:\ you should be looking at desktop. for desktop.ini
     
  9. Focusman

    Focusman MDL Novice

    Oct 11, 2010
    7
    0
    0
    Both desktop and C cant find it anywhere even tried using search option
     
  10. venu

    venu MDL Addicted

    Oct 16, 2009
    894
    99
    30
    Try shutting down and restarting.
     
  11. Focusman

    Focusman MDL Novice

    Oct 11, 2010
    7
    0
    0
    Tried shutting down system restore and hard boot but still can't find desktop.ini file anywhere
     
  12. venu

    venu MDL Addicted

    Oct 16, 2009
    894
    99
    30
    Give this a shot. In regedit, go to this key:

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

    Right-click on ShowSuperHidden and select Modify.

    Change the value to 1 and click OK to save your changes.

    Also SuperHidden:REG_DWORD:1-enable

    Then, take a look in your user folder or check desktop.
     
  13. pepe80

    pepe80 MDL Novice

    Oct 24, 2010
    12
    1
    0
    Thanks for the tip
     
  14. Focusman

    Focusman MDL Novice

    Oct 11, 2010
    7
    0
    0
    #15 Focusman, Oct 25, 2010
    Last edited: Oct 25, 2010
    (OP)
    Found out that this is a glitch in XP which Microsoft have rectified in Windows 7..........but there is a solution............if anyone else has this trouble download a freeware program call ICONOID. Instal and set it up to save the desktop, hide when running and everything is hunky dory (has to be set up on each user)........and then the best thing to do is create a short cut in every users start up file so it works automatically. I have been running it for a week now and it definitely works

    THANKS to everyone who tried to sort it for me