Zip drive issue

Discussion in 'Windows 7' started by spacednow, Nov 20, 2009.

  1. spacednow

    spacednow MDL Member

    Aug 26, 2009
    229
    3
    10
    Running win 7ultimate x64 installed from MS disc, slic bios activated. Problem I have is every time I put a zip drive in with files on it I get a message saying there is a problem with the drive and wanting to know if I want to attempt to fix it or attempt to use it as is. Does anyone else have this issue? I have several zip drives and it always asks. Yes my pute is USB 2.0. I can read and write files to the drives fine after selecting use as is. BTW some are formated FAT32 and others NTFS. I am also using a zip drive for readyboost.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. genuine555

    genuine555 MDL Expert

    Oct 3, 2009
    1,639
    56
    60
    I'd say it's a compatibility issue. Got the latest drivers for the devices ?
    Also check the properties in device manager.
     
  3. HSChronic

    HSChronic MDL Expert

    Aug 25, 2007
    1,213
    56
    60
    you mean zip drive like IOmega zip drives? People still use those?

    You might need to use a VM the hardware might be too old.
     
  4. spacednow

    spacednow MDL Member

    Aug 26, 2009
    229
    3
    10
    Only problem in the device manager was a printer issue, I reinstalled driver in XPsp3 mode and that was resolved. Prolly should of used the term thumb drive instead of Zip drive, LOL. I am still clueless as to why this is happening, its just an aggravation, not a real problem. Just a thought.... I dual boot with XP and it recognizes them when I plug them in AND I think I have write cache enabled on them in XP, would that cause this issue??
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. genuine555

    genuine555 MDL Expert

    Oct 3, 2009
    1,639
    56
    60
    Like I said earlier : check the device properties in device manager. Not sure if it'll solve your issue, but you definitely should have write cache enabled.