3830TG Bios Modding (1.08 Bios)

Discussion in 'BIOS Mods' started by Nedemai, Apr 8, 2012.

  1. Nedemai

    Nedemai MDL Novice

    Apr 8, 2012
    #1 Nedemai, Apr 8, 2012
    Last edited by a moderator: Apr 20, 2017
    Now before I begin I would like to quickly explain there is a lot I don't understand and my approach was that of deduction and hoping my best guess would be right. My terminology sucks as well, so please bear with me.

    I managed to unlock the menus in the 1.08 bios for the 3830TG TimelineX using the following method.

    The Insyde BIOS's all have a "SetupUtility PE" file which is approximately 670Kb. This file
    contains the required information to unlock the advanced menus in the Insyde BIOS. You can obtain
    a raw dump of these files with either the python tools referenced on this page

    or with the Pheonix_Mod_Tool_1.42.

    The tool used to compile the firmware is EzH20 This is the only EzH20 tool which will
    read a InsydeH20 bios that is > 1 MB as far as I know.

    Unfortunately the EzH20 tool WILL NOT accept the "SetupUtility PE" file as a stand alone file.

    To Quote;

    So one has to use winhex or another type of RAM memory editor to insert the proper values into
    EzH20. This is picky and requires patience. EzH20 is unlikely to save these changed values
    without changing some value in the Firmware itself. I changed the boot logo personally.

    Now what is going on is the UEFI bytecode is being edited to pretty much not check a variable
    anymore ( a list)

    Explains it far better.

    The data set.

    14 11 80 00 01 05 00 00 00 01 00 02 00 03 00

    Changes to

    14 11 80 00 01 05 00 10 00 11 00 12 00 13 00

    for the first and third occurance ONLY


    The data

    00 85 C0 0F 85 E1 00

    Changes too

    00 85 C0 90 E9 E1 00

    There is only one instance of this data. It starts at 13A6h for the 1.04 Bios and at 13B6h for the
    1.08 Bios as located in the "SetupUtility PE". I am uncertain as to what is going on with this at
    the moment as far as function. (x86 assembly)


    Now to get this to work I took a pretty ballsy approach and decided that the same modification on
    the 1.04 bios might work on the 1.08. I was very happy to find that this did infact work. What I
    did was compare the "SetupUtility PE" file of the 1.04 modded firmware with that of the stock
    firmware to see the difference. the only notible differences I saw was what is listed above.

    I figured if the 1.08 "SetupUtility PE" file was similar, I might be able to apply the same
    method of unlocking the menus. there was a slight offset of the data, but in the end it did work.

    This approach is pretty much exactly like that listed on the page I've referenced twice. I pretty much took that information and worked it to my own means.
  2. willdieh

    willdieh MDL Novice

    Jul 19, 2017
    Just wanted to say thanks for this... worked on my 1.12 4830T / 4830TD bios as well. Really great, since modified bioses for the 3830/4830/5830 have all dried up and can no longer be downloaded. Thanks very much!