8.1 Laptop Stuck on "Checking for updates..."

Discussion in 'Windows 8' started by Espionage724, Nov 15, 2013.

  1. Espionage724

    Espionage724 MDL Addicted

    Nov 7, 2009
    901
    256
    30
    Turned on my laptop earlier, and tried checking for updates. Saw around 250MB worth of updates, clicked install, and Windows Update locked up shortly afterwards. Restarted Explorer, and Windows Update still wasn't working, so I rebooted.

    Tried checking for updates again, and now I'm stuck on that screen (the progress bar moves, but it's seemingly not finding updates).

    No idea what caused WU to freeze. My desktop (set up in basically the same exact way) handled it fine.

    Any ideas how to fix it? I tried a Disk Cleanup (to cleanup WU files) and a reboot to no avail.
     
  2. pun

    pun MDL Senior Member

    Oct 19, 2013
    465
    188
    10
    I would try restarting the Windows Update service.
    If that doesn't help... Maybe a sfc -scannow?
     
  3. Puremin0rez

    Puremin0rez MDL Member

    Nov 24, 2010
    235
    81
    10
    I had the same issue except a reboot fixed it.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. tonto11

    tonto11 MDL Addicted

    Jun 18, 2012
    535
    224
    30
    Doing that right now.
    make sure you're getting internet access before you start.
    I used to have a firewall I had to turn off before it would work
    WU has two parts downloading, which shows percent
    and installation which lists like 29 of 60 (my status at the moment)

    Has this update process worked correctly on this computer before?

    ...T
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. Snuffy

    Snuffy MDL Expert

    Jan 7, 2008
    1,184
    592
    60
    Win 8.0 and 8.1 have a nasty issue with...
    sfc /scannow untill the errors are gone.
    delete Software Distribution folder... reboot.
    then try again...
    works for me when customers have issues...
     
  6. elzna

    elzna MDL Senior Member

    Aug 28, 2013
    393
    46
    10
    #6 elzna, Nov 16, 2013
    Last edited: Nov 16, 2013
    All my windows 8.1 installs are "preparing updates" and keeps rebooting in a loop. what the f is going on? happening now since a week ago. It's on its 15th reboot now.
    preparing updates: 30 %... 100 %... rebooting system... prepearing updates: 30 %...100 %.. rebooting system... cant get into my pc
    Did M$ found a way to screw with systems? it looks like they did.
     
  7. murphy78

    murphy78 MDL DISM Enthusiast

    Nov 18, 2012
    6,787
    10,357
    210
    Run admin prompt command:
    net stop wuauserv

    Then delete the c:\windows\softwaredistrubution folder.

    After that you can re-try running wuapp.exe check, but I actually recommend rebooting first since it likes to cache the softwaredistribution file links into memory and will error out or crash your system.

    If you are still having problems I would suspect that some of your services are not functioning correctly. I know Windows Updates uses wuauserv and background intelligent transfer services, as well as some registry settings at the very least. If you have used some program that modifies your services, you might try to undo those things so that the services are running as they are supposed to. System tuning programs are notorious for fiddling with services.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. geporto

    geporto MDL Novice

    Jul 11, 2015
    1
    1
    0
    A year and a half after your answer, I got the same issue with WU. And I couldn't stop the service:eek:. Thanks to your advice, :worthy:I disabled the start of the service, reboot, deleted the c:\windows\softwaredistrubution folder, returned start to Manual, rebooted, and Voilá! FIXED!!:clap:

    Thanks a lot!!
     
  9. LatinMcG

    LatinMcG Bios Borker

    Feb 27, 2011
    5,266
    1,422
    180
    ive had similar.. i found .net 4.5 was partially broken and update would not finish.
    but not always the case
     
  10. crashnburn

    crashnburn MDL Senior Member

    Mar 18, 2010
    484
    19
    10
    Saving and making a note of this.. In case this ever comes up again :) Thanks for posting back :) I face this sometime last year.