About Dell BIOS recovery

Discussion in 'BIOS Mods' started by redalerthan, Dec 5, 2009.

  1. Y&S

    Y&S MDL Novice

    Dec 1, 2009
    6
    0
    0
    I had bricked Latitude E6220 by flashing Broadcom USH firmware from E6230. Process hanged at 60% and after reboot it's brick. I guess BIOS was damaged due to wrong offset.
    I remove CMOS battery and after that laptop is switching on by itself during connecting charger and try to read flash drive. Could you please advise what is correct hdr file name for BIOS recovery?
     
  2. nospa1

    nospa1 MDL Novice

    Dec 18, 2019
    1
    0
    0
    did you manage to solve the problem? I have the same on the e6420
     
  3. AnarethoS

    AnarethoS MDL Expert

    Jul 31, 2009
    1,214
    1,447
    60
    #323 AnarethoS, Dec 30, 2019
    Last edited: Dec 31, 2019
    Content removed. I started a direct thread. Thanks.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. vandalay2013

    vandalay2013 MDL Novice

    Nov 5, 2020
    4
    0
    0
    Would appreciate some help, I have a Dell XPS 12 9Q33 bricked during bios update from A08 to A10. I have used the Phoenix tool to extract the 9Q33_A08.HDR and 9Q33_A08.ROM files necessary for the emergency bios recovery procedure, but I need to find out what the files should be renamed to.
    I have tried many combinations without success. While pressing the end key I insert the AC cable and the machine powers on and is searching the usb but its not finding the necessary filename its looking for.
    Does the USB need UEFI files as well?
    Thank you
     
  5. billaras

    billaras MDL Novice

    Nov 26, 2010
    1
    0
    0
    No joy for my E6500.
    Tried everything to recover BIOS.
    Anyone knows where the Bios Chips are located on the Systemboard so I can reprogram ?
    Thx in advance.