ACER 5830T InsydeH20 Rev3.5 V1.12 - UEFI enable

Discussion in 'BIOS Mods' started by Properjob70, Feb 18, 2023.

  1. Properjob70

    Properjob70 MDL Novice

    Sep 16, 2015
    The BIOS V1.12 last released in 2012 was locked down to Legacy only with limited menu options.

    I found the same BIOS on another forum for the families of ACER notebook in existence at the time - but with unlocked Advanced menus. It seems however that not all the advanced features in the menu actually work, so despite setting UEFI to Enable and EFI boot to priority, those features don't actually work. Someone tried opening the UEFI shell and it only opened to a black screen, therefore reason why the UEFI options don't work.

    The conclusion is that the BIOS's were built from an SDK and then heavily feature locked accordingly.

    There seem to be ways of actually enabling UEFI by inserting the relevant bits of code into the BIOS but this is way beyond my skillset.

    UEFI wouldn't bother me except for the fact I want to dual-boot W10 and a Linux based system called Vortexbox. Vortexbox wipes the hard drive of everything and sets the cleaned disk as GPT, so Legacy Windows won't install on the unallocated HDD space left behind. I tried converting the Vortexbox-created GPT disk to MBR, but then it immediately threw up Grub errors and wouldn't boot.

    I'm going to try cloning the VortexBox partitions and then clean installing W10 in Legacy. That way I can create a number of logical partitions and clone the Linux partitions back to the laptop HDD. Then use something like FixBoot to solve the ensuing dual boot issues.... If that works, job done!

    TL DR - is it possible someone could get a version of the BIOS working with Advanced menus AND the relevant UEFI switch inserted please?

    h t t p s ://