Acer Aspire Revo RL70 "Do not check ROM ID" to flash with SLIC version?

Discussion in 'BIOS Mods' started by MrT0ad, May 31, 2012.

  1. MrT0ad

    MrT0ad MDL Novice

    Mar 3, 2011
    Hi beautiful people:

    I've just got myself an Acer Aspire Revo RL70 (basic model, shipped with Linux and with no ODD) to use as media centre and (dangerously enough) I am curious...

    Apparently Acer releases two versions of the BIOS, one for units shipped with Linpus (with no SLIC) and another one for machines shipped with Windows (with SLIC).

    There could be also other differences between both but the hardware platform is exactly the same.

    If I try the "normal" flashing procedure it aborts due to ROM ID mismatch.

    There is a command line parameter than excludes the ROM ID check, but in the manual it shows it in combination with "update whole BIOS" modifiers:

    AFUDOS <BIOS ROM File Name> /P /B /N /C /E /K /X

    It looks straightforward but when things look straightforward to the non-initiated (moi) alarm bells start ringing...

    If catastrophe strikes the BIOS chip is socketed, so it might be possible to use flashrom and an external programmer to bring it back to life, but before going in head first shouting "Leeroy Jenkins" I thought I'd ask:

    Do you foresee any obvious complications with this procedure?

    If you made it this far, thanks for reading :)
  2. MrT0ad

    MrT0ad MDL Novice

    Mar 3, 2011
    #2 MrT0ad, Jun 1, 2012
    Last edited: Jun 1, 2012
    OK, I took all reasonable precautions and proceeded to flash the BIOS of the RL70 (on DOS using AFUDOS).

    Syntax I used was AFUDOS <BIOSNAME>.ROM /P /B /N /X /r

    Bios flash completed without errors although the flasher "hanged" after finish.

    Power off, power on, load BIOS defaults, reboot, set BIOS settings (don't need CIR, which has no IR received attached anyway, neither onboard audio, I use HDMI to passthrough) and is all peachy.

    Now onto checking if SLIC is there :)

    EDIT: Checked integrated NIC, no funny 00:00:00... or FF:FF:FF... stuff, still retains a coherent MAC address.

    I've also checked with RW - Everything and SLIC info is now present on BIOS.

    So far so good.

    EDIT 2:

    Success :)

    Was going to add a pic of the output on SLIC & Cert validation using the SLIC dumped from BIOS (thanks for SLIC Toolkit, very useful) and the ACER cert kindly shared in the forum but can't post images (post count too low...).

    Now off to make a custom install disk ;)

    I have a legitimate Windows 7 Ultimate key for the Revo, but this is much more fun! :D
  3. MrT0ad

    MrT0ad MDL Novice

    Mar 3, 2011
    Summarising, downloading the Revo RL70 BIOS in the Acer support website (which is the "Windows" version containing SLIC) and forcing flash on a unit that shipped with the "Linux" version of the BIOS is reasonably safe.

    Currently the BIOS listed there is version P01.A2 with date (on website) 13/02/2012. Actual build date I believe it was Jan 2012.

    This is the version I used in this little experiment.
  4. Excalibran

    Excalibran MDL Novice

    Jun 6, 2012

    I have been trying to install Windows XP on an Acer Revo RL70 PC. I used an external USB CD drive to install Windows XP (on to the internal harddrive) from a CD and I was able to manually locate all the necessary drivers for XP (since the Acer website only has drivers for Vista/Windows 7).

    The problem is that the PC will not boot from the internal hard drive and I get the following message:
    This happens regardless of the boot order in the BIOS. The only workarounds I have found to get the PC to boot into Windows XP are:

    1. Press F12 when the PC starts, to show the ‘Boot Menu’.
    2. Make sure the internal hard drive is selected.
    3. Press Enter.


    1. Connect an external CD drive with a bootable CD inside.
    2. Ignore the ‘Press any key to boot from CD’ prompt.

    This would indicate that the actual Windows XP install and partition are working correctly and that the problem lies with the BIOS.

    I upgraded the BIOS version to P01.A2_A_A (from the Acer website) but the problem persists.

    I thought this might be some weird EFI limitation thing so I reduced the Windows partition size to 32GB and changed it from NTFS to FAT32 but that didn't resolve the issue.

    Any suggestions on how to solve the 'no boot disk' problem? Thanks in advance...
  5. twotanks

    twotanks MDL Novice

    Jun 9, 2012
    I too got an RL70 wth Linpus and have upgraded the memory to 4gb in preparation for Windows 7 64 ultimate. I've been through the procedure above but I can't get it to work. I'm trying to install from a bootable USB stick and can get to AFUDOS but using the syntax above I'm getting nowhere. Any suggestions?
  6. MrT0ad

    MrT0ad MDL Novice

    Mar 3, 2011
    What error does AFUDOS output?

    Are you using the version of AFUDOS bundled with the ROM file?

    Have you replaced <BIOSNAME> for the appropriate file name?
  7. craigyp

    craigyp MDL Novice

    Jul 28, 2012
    Can you give me a little help MrT0ad

    I found your tutorial through Google and I've only just become a member but I'm hoping you won't judge me for that! :)

    I have flashed my BIOS with the one provided from the ACER website and I'm ready to install Windows 7 (from USB as my Revo doesn't have a CD drive.

    The issue I'm stuck on is that during install windows states that it cannot find any installation media. This is I presume an issue with the SATA drivers. The installer prompts me to find the drivers for the device however after downloading the AHCI/SATA drivers from the Acer website and pointing the Windows 7 installer to those drivers (I've tried several both signed and unsigned) the installer throws back the message "No new devices found, windows could not find any installation media"

    I have tried switching the SATA mode from AHCI to Native IDE however the windows installer still has the same problem in not being able to detect my SATA channel.

    Did you experience this issue? Or would you be able to provide any help on how to over come it? Would this indicate that my BIOS isn't flashed to accept windows? I'm a little stuck and this is a little weird... Takes me back to the days where you needed to make a custom Win XP cd with SATA drivers included however with Windows 7 you can load these adhoc only that seems to be failing

    Your help will be MASSIVELY appreciated and I'd kiss you
  8. nekotik

    nekotik MDL Novice

    Sep 9, 2012
    1. Boot From the Windows 7 Install Disc
    2. The first thing you’ll need to do is boot off the install disc, and then click through until you see the “Repair your computer” link in the lower left-hand corner.

    3. You’ll need to choose the correct installation of Windows and then click the Next button.

    4. And then you’ll get to the System Recovery Options screen, where you can get to the Command Prompt.

    5. Replacing the Windows XP Bootloader with Windows 7 (use command: bootsect /nt60 all)
  9. .dissent

    .dissent MDL Novice

    Oct 24, 2012
    new bios

    There's a new bios on the acer website p11.a1 telling it's uefi for windows8. When trying to flash it says that the rom file doesn't match the existing bios size.
    Wonder if it's just the revision limitation considering that bios flash chip shouldn't be less than 4mb.
    Any way (or sense) to flash it?