1. blade666

    blade666 MDL Novice

    Oct 12, 2010
    sorry for disturbing you by this, I've searched over the internet for several days but didn't found a solution.
    I have an Acer TravelMate 3220, when I was doing a bios flash electricity's gone and the flash was failed. I tried to power on the computer and I've found a black screen only fan and led are working. I read in the internet that after a bios crash there's a bootblock which can be used for recover, in Acer PDF ther say I have a a phoenix Bios, I tried to recover with the crisis disk of phoenix but nothing, I opened the motherboard in order to put off the bios and flash it electronically but it seems that it's wleded in the motherboard but I discovered that over the bios chip it's written EFL-5O 2.90P that mean that I have an INSYDE Bios.
    when I downloaded the orginally bios from Acer I found the bios file which is
    FL50290.BIN, I tried to make a recovery disk dos bootable with the insyde dos flash utility FLAs**t but it dosen't work.
    remark : I have an external floppy disk, and when I power on the computer maintaning Fn+ESC keys the Floppy disk begin reading but stop after 4 or 5 seconds which mean that it did not read anything, I think that the bootblock didn't found what it's searching about.

    I attached a pic that shows the content of the boot loader of my Bios you can see in the 0A adress there's DIAG_CRISIS_BOOT which is a Proceed with Crisis Boot, first initial super I/O and boot device.

    I need some help to recover the Bios, thanks for your attention :)

    Attached Files: