AMI bios problem, MSI G31TM-P21 mainboard

Discussion in 'BIOS Mods' started by dt1375, Dec 22, 2010.

  1. dt1375

    dt1375 MDL Novice

    Mar 7, 2010
    8
    0
    0
    #1 dt1375, Dec 22, 2010
    Last edited: Dec 22, 2010
    Anyone with help to get the thingy sorted out;
    - AMI bios, using AFUD4310 to flash (reports all ok, except "system data protected")
    - Modded the orginal bios with Amitool 1.61, everything ok
    O7A 1.2.7 reports no slic present at all...

    MSI G31TM-P21 mainboard.

    Can't seem to figure out how to get it to work out ok. Even tried the crash-boot with ctrl-home option, and flashed the bios trough the built in recovery.
    Also tried flash options /N /C /P /B with afud4310

    Is this happening because of the "system data protected" ?
     
  2. NoJuan999

    NoJuan999 Experienced SLIC Tool Operator

    Jul 31, 2009
    9,919
    1,930
    300
    It sounds like you have a Bios Protection setting in your BIOS and that doesn't allow the BIOS to be updated.
    Check your BIOS for a BIOS Protection Setting or look on your MB for a Bios Protect Jumper,
    if either is present disable it then Flas, then re-enable it.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. dt1375

    dt1375 MDL Novice

    Mar 7, 2010
    8
    0
    0
    It's soft setting, and is off(disabled)
    All is running fine with writing (main, nvram etc etc) except "system data", whatever it is... it sure wont let me write the edited SLIC 2.1 implemented BIOS version. Main BIOS is written, and confirmed updated to newer version, but SLIC table is not found when trying to activate the WIN7 installation.