Any way to fully disable UAC and use Store Apps?

Discussion in 'Windows 10' started by MonarchX, Sep 27, 2015.

  1. MonarchX

    MonarchX MDL Expert

    May 5, 2007
    1,287
    214
    60
    I recall in Windows 8.1, the only way to disable UAC entirely was to use pure administrator mode, which also prevented the use of MS Store and Store Apps. Is it the same way with Windows 10? I hate having to deal with "Do you want to Open this file?" Security Warning by un-ticking that box for every new file I download and this drives me to want to switch to pure Administrator mode, BUT at the same time I use MS Store Netflix app, which I also want preserved.

    Is there some awesome script that would prevent "Do you want to open this file" message without forcing me to use Administrator mode that would block Netflix app? Or maybe one that simply makes MS Store Apps work in Administrator mode?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. mubaidr

    mubaidr MDL Junior Member

    Dec 8, 2010
    52
    3
    0
    Startmenu and other apps works fine in safe mode, which made me think disabling UaC might work. But i did not tried yet.
     
  3. uffbros

    uffbros MDL Senior Member

    Aug 9, 2010
    331
    25
    10
    Very easy to do....Go to Control Panel...User Accounts.....Click on the very last blue colored link that says Change User Account Control Settings...Move the slider all the way to the bottom. Done.
     
  4. MonarchX

    MonarchX MDL Expert

    May 5, 2007
    1,287
    214
    60
    What you advised I have been doing since Windows Vista or 7, but it does not get rid of the "Do you want to Open this file?" Security Warning message for newly downloaded files...
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. odiebugs1

    odiebugs1 MDL Expert

    Jul 30, 2015
    1,390
    457
    60
    Have you tried to disable smart screen.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. MonarchX

    MonarchX MDL Expert

    May 5, 2007
    1,287
    214
    60
    It is disabled.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. odiebugs1

    odiebugs1 MDL Expert

    Jul 30, 2015
    1,390
    457
    60
    #7 odiebugs1, Sep 30, 2015
    Last edited: Sep 30, 2015
    Well then you broke windows, :p because if you have smart disabled in group policy and have UAC set to not notify, I don't see how you can get that warning, all I can think if is to disable all notifications.

    Go to Control Panel\All Control Panel Items\Security and Maintenance\Change Security and Maintenance settings, and uncheck all. I don't even have UAC slider at bottom and don't get them with smart disabled.

    One last thing- open internet options, go to security, Internet, click on custom level, and go to Launching applications and unsafe files- check enabled (not secure)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. TairikuOkami

    TairikuOkami MDL Addicted

    Mar 15, 2014
    667
    520
    30
    Run CMD as admin and enter:

    reg add "HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Associations" /v "DefaultFileTypeRisk" /t REG_DWORD /d 1808 /f
    reg add "HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Attachments" /v "SaveZoneInformation" /t REG_DWORD /d 1 /f
     
  9. odiebugs1

    odiebugs1 MDL Expert

    Jul 30, 2015
    1,390
    457
    60
    DefaultFileTypeRisk - Disables - The Publisher could not be verified

    SaveZoneInformation -Disables - warning to unblock the downloaded file
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. MonarchX

    MonarchX MDL Expert

    May 5, 2007
    1,287
    214
    60
    No way - I did not break anything. I had this in Windows 7, Windows 8.1, and Windows 10 and even on my stepdad's HP PC with pre-installed Windows 7. It is NORMAL behavior for it to be that way even when UAC is set to Lowest. This behavior GOES away if I DISABLE UAC completely, but doing so prevents me from using MS Store.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  11. odiebugs1

    odiebugs1 MDL Expert

    Jul 30, 2015
    1,390
    457
    60
    #11 odiebugs1, Sep 30, 2015
    Last edited: Sep 30, 2015
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  12. MonarchX

    MonarchX MDL Expert

    May 5, 2007
    1,287
    214
    60
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  13. odiebugs1

    odiebugs1 MDL Expert

    Jul 30, 2015
    1,390
    457
    60
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  14. MonarchX

    MonarchX MDL Expert

    May 5, 2007
    1,287
    214
    60
    I use regular user-as-admin account. If you go with PURE Admin account and/or disable UAC entirely, then ME Store will not work. Go ahead and try to disable UAC with WOLF like I told you and you will see for yourself.

    One way or another, the problem was solved for me when TairikuOkami posted:

    It is ALL good now!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  15. Mr.X

    Mr.X MDL Guru

    Jul 14, 2013
    5,853
    13,387
    180
    Is this enough to fully disable UAC? I mean to say if I have a clean Windows 10 installation and decide to fully disable UAC without losing Store Apps, is that reg tweak suffice? No other setting to be adjusted?