Apple TV 4k shows in Airplay, but NOT in Xcode :(

Discussion in 'macOS' started by itsmemario1, Jun 16, 2019.

  1. itsmemario1

    itsmemario1 MDL Senior Member

    Sep 10, 2012
    445
    53
    10
    #1 itsmemario1, Jun 16, 2019
    Last edited: Aug 2, 2019
  2. itsmemario1

    itsmemario1 MDL Senior Member

    Sep 10, 2012
    445
    53
    10
  3. itsmemario1

    itsmemario1 MDL Senior Member

    Sep 10, 2012
    445
    53
    10
  4. itsmemario1

    itsmemario1 MDL Senior Member

    Sep 10, 2012
    445
    53
    10
    Thanks to a friendly human beeing I got the device files for :

    11.4, 12.0, 12.1 and 12.2

    Of course Xcode 9.2 is still complaining, that the device files for 12.3 are missing.

    Mission Impossible ?
     
  5. itsmemario1

    itsmemario1 MDL Senior Member

    Sep 10, 2012
    445
    53
    10
    #6 itsmemario1, Jul 30, 2019
    Last edited: Jul 31, 2019
    (OP)
    I tested another solution and it works.

    Rightclick Xcode -> Show Paket Content -> Contents -> Developer -> Platforms -> AppleTVOS.platform -> DeviceSupport


    At that location simply create the folder 12.3 and copy the content from 12.2 to it.
    Done.

    You Mac will keep saying "Apple TV is busy, Xcode will continue when AppleTV is ready", but you can read the logs, take screenshots and most important enable the HUD.

    p.s.

    The Developer Mode stays activated, even if you close Xcode and turn of your Mac and your Apple TV.
    afaik DevMode should only stay active when connected to Xcode ?