Aspire BIOS fail after switching option in BIOS setup

Discussion in 'BIOS Mods' started by Cccristian, Jan 21, 2013.

  1. Cccristian

    Cccristian MDL Novice

    Jan 21, 2013
    The unimaginable struck. I have an acer aspire 5741g laptop with the unlocked bios. Because it usually overheats, I went to the bios setup and I disabled multicore computing (or something like that). Hit Save and exit and the screen went blank. When powering on there is no image, it justs restarts continuously after 20 seconds.

    I tried the crisis disk (with many bios fd files), it seems to flash a new bios from the usb stick for like 10 seconds (there is only a tiny blink of the usb stick in the first second) , than it shuts down and neeeds to be unplugged and replugged to start when pressing the power button. But it's the same situation: with a normal start it just restarts on blank screen.

    I even tried touching the CMOS reset jumpers (noticed the laptop does not start if the jumpers are being touched and the power button is pressed). Also, this laptop has no cmos battery.

    What should I do? Please, any support?
  2. Recursion

    Recursion MDL Junior Member

    Dec 26, 2012
    You can erase nvram and cmos with special programs but you already tried to flash the bios. maybe you need a new flash chip? or a flash programmer.