ASUS 5PQ Pro Hot Plug Problems

Discussion in 'Windows XP / Older OS' started by phantom2k, Jan 26, 2010.

  1. phantom2k

    phantom2k MDL Novice

    Dec 3, 2009
    Currently running XP Pro SP3 x86

    I have enabled ACHI in Bios and installed Windows with the ACHI drivers sometime ago.
    Recently purchased an Antec SATA hot plug caddie. I know ACHI is installed as any hard drive that is plugged in or out when Windows has loaded is recognised and this would not happen is ACHI was not enabled.

    When I plug any hard drive into the caddie everything is fine until I remove the hard drive and then I get Write Delay error.
    In Device Manager under IDE ATA section the ACHI driver is installed and functioning properly and when I click on the driver the version number for iaStor.sys is:

    What I don't get is when I examine any hard drive in the Disk Drives section the driver always states a Microsoft dated 2001 which I know is the windows XP driver should this show the Intel driver instead..!

    I tried to install the Intel Matrix software application but this failed to make any difference to the write delay problem. I also tried to enable the optimise for quick removal option in the disk drive section but that option is not available.

    I've herd that I should disable the cache on the hard drive although not sure if or how this can be done and surely if I did this the drive would become really slow since four out of my nine hot plug hard drives have 64MB cache.!

    Since there is no remove icon that shows up does anyone what I am doing wrong.

    Thanks in advance
  2. burfadel

    burfadel MDL EXE>MSP/CAB

    Aug 19, 2009
    Sata was one of many, many add-ins to XP during its lifespan. Its quite possible hotplugging isn't supported or fully supported (ie it is on paper but only works in certain scenarios) by XP...
  3. urie

    urie Moderator
    Staff Member

    May 21, 2007
  4. phantom2k

    phantom2k MDL Novice

    Dec 3, 2009
    Have tried installing Matrix Storage Manager but that did not help at all. The version I installed was 8.9 but have read somewhere earlier that anything above version 8.2 does not function correctly with hot swapping although I cannot confirm this or find anywhere to download v8.2 as Intel no longer offer that download version and AUS no longer offer v8.2.!

    I also have a 2 port SATAII Sil3132 PCIe card plugged in but have similar problems with that as well.!

    I have also heard that the same problems are on Windows 7 x64 with the Matrix Storage Manager with version above 8.2 but again can't test as I currently only running Windows 7 in VMware for testing and can't find v8.2 of the Matrix Storage Manager anywhere. Would be nice if anyone can shed some light on different versions of Matrix Storage Manager and hot swap both under Windows XP and Windows 7.

    I would have thought that in this modern age where SATA is just about everywhere that they would have worked out the hot plugging thing as some people have many drives and most motherboards only have around six SATA connections and for some people this is just not enough as most CD and DVD drives are also now SATA.
  5. 2centsworth

    2centsworth MDL Senior Member

    Feb 12, 2008
    that program works for many. Use ICH10R to use hot-swap under XP natively, when properly working you will see the drive listed in "safely remove hardware".
  6. Hotrod74

    Hotrod74 MDL Novice

    Feb 12, 2010
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...