Asus X555LA BIOS questions

Discussion in 'BIOS Mods' started by shotgun25, Jul 31, 2017.

  1. shotgun25

    shotgun25 MDL Novice

    Oct 18, 2009
    30
    2
    0
    #1 shotgun25, Jul 31, 2017
    Last edited: Jul 31, 2017
    Hi all,

    I have a X555LA which needs SLIC 2.1 enabling.

    I load the BIOS into AndyP's PhoenixTool and it notes that there are 2 PubKeys present.

    I select Asus from the manufacturer and then I select a valid SLIC 2.1 ASUS.bin and then select a certificate to verify against the BIOS file and the SLIC ASUS.bin and I get the following result (attached).
    X555LA pubkey list.jpg

    My questions are:-
    1. What tool (if any) can I use to enable the already existant SLIC
    2. If 1 not possible, what flash tool do I need to be able to flash my modified bios file? And should I have made the modification with or without an RW report?
    3.For a previous Gigabyte board I believe it was Serg008 and another person who provided a mod that was flashed to Intel ME regions or something along those lines. I believe that might have been AWARD based though so that worked from taking a backup of the machine.

    I have also searched google for some of these things but nothing is apparent for 1.
    I think for 2. that it is BUpdater that I require, but finding a link with the new search functionality in the forums is not proving fruitful. And some links in posts have either been deleted or don't translate to the forum URL system used now.

    Oh and if I modify the BIOS file myself (2.) do I need to make a backup of the embedded Win8.0 key to put back into the BIOS file, or is that only done if replacing the motherboard/transferring the key from one machine to the next?

    Help please :)
     
  2. Serg008

    Serg008 MDL BIOS/EFI Guru

    Feb 23, 2010
    17,868
    7,985
    340
    run Backup_tools utility https://www.sendspace.com/file/vvbk9s as Administrator (right mouse click - as Administrator) and upload results.rar
     
  3. shotgun25

    shotgun25 MDL Novice

    Oct 18, 2009
    30
    2
    0
    Thanks Serg008 for confirming that I need to do the same as the Gigabyte board.

    Problem is the machine locks up when I run the program as admin, and I've tried extracting and running Start.bat as admin and the same issue.

    Ideas?
     
  4. Serg008

    Serg008 MDL BIOS/EFI Guru

    Feb 23, 2010
    17,868
    7,985
    340
    Win10 ?
    make bios dump
    afuVw.exe AFUBAK5.ROM /O
    and upload AFUBAK5.ROM
     
  5. shotgun25

    shotgun25 MDL Novice

    Oct 18, 2009
    30
    2
    0
    #5 shotgun25, Aug 1, 2017
    Last edited: Aug 1, 2017
    (OP)
    Windows 7 x64. All drivers are installed, running as Administrator as the Administrator user.

    Freezes when I get the following.

    BIOS backup tools: Testing the Read/Write operations for the BIOS
    Please wait...
    press "Enter" to continue...​

    No hard drive activity once the trackpad and keyboard are disabled, have to hard power off.

    The same happens running the command you prescribed
    afuVw.exe AFUBAK5.ROM /O​
    Also just tried the x64 version with same freeze
    AFUVW64.EXE AFUBAK5.ROM /O​

    I think I'll put the original hard drive in which has windows 10 installed and give it a try...or maybe even try it in mini Windows XP on Hirens CD.

    Edit - Hirens wouldn't boot, bluescreened which is to be expected...windows XP on a machine this new is unlikely to work. Windows 10 drive re-inserted and it seemed to get further but still froze.

    Does this method require secure boot to be active in BIOS as I currently have it on Legacy (or equivalent) boot.

    On a side note, are you aware that Avast flags this as Win32/Malware (generic)??
    I submitted it and said it's a bios backup tool used in preparation for modifications for educational purposes.
     
  6. shotgun25

    shotgun25 MDL Novice

    Oct 18, 2009
    30
    2
    0
    Further information

    I have tried running the backup on the Windows 10 drive with secure boot enabled and disabled same freeze.

    I have tried running the command afuvw64.exe /? and it froze then too.

    I'm thinking there is either a fault with the software provided, there is a protection in the EFI/BIOS/Intel ME restricting me from using the software or I'm doing something wrong/hardware issue as it's happening on 2 distinct drives, one a brand new SSD, the other the known working 1TB HDD that the machine shipped with and two distinct versions of Windows, one a fresh install of Windows 7 x64, the other Windows 10 x64.

    Any ideas?
     
  7. shotgun25

    shotgun25 MDL Novice

    Oct 18, 2009
    30
    2
    0
    I decided to update the bios to the latest version and it resolved the issue.

    "The Intel Flash Programming Tool has stopped working" popped up a few times so if the rar file is incomplete, I'll just provide the rom file.

    Here is the results.rar
     
  8. Serg008

    Serg008 MDL BIOS/EFI Guru

    Feb 23, 2010
    17,868
    7,985
    340
    Asus X555LAB_dump_Asus21_shotgun25.rar
    https://www.sendspace.com/file/m1kv4g

    Unpack and run MOD.exe as Administrator (right mouse click - as Administrator).
    Reboot and check SLIC.
    Post results.

    This mod - for this PC only !
     
  9. shotgun25

    shotgun25 MDL Novice

    Oct 18, 2009
    30
    2
    0
    Hi Serg008,

    Sorry for delay. Many thanks for the BIOS mod, worked perfectly. I'd love to learn the method one day, but for now with my lack of hex knowledge, I'll rely on your superior knowledge and skills like the rest.

    Thanks again sir!