Audio Driver Installation Broken in Windows 8.1 Preview?

Discussion in 'Windows 8' started by Espionage724, Jun 27, 2013.

  1. Espionage724

    Espionage724 MDL Addicted

    Nov 7, 2009
    903
    256
    30
    I have an ASUS Xonar DG sound card. I installed UniXonar drivers without any problem after Win8.1 preview install, and I thought everything was well, but a game I play (osu!) had some noticeable audio latency going on.

    I then took out my sound card and enabled my Realtek onboard audio. Windows didn't auto-install the HDA driver, and Realtek's installer was unable to do so as well (some error 0x0000000D code). Manual installation from Device Manager gave the error "Data is invalid" or something like that.

    Decided to disable onboard audio and go back to my Xonar DG. I then noticed that UniXonar was unable to detect the sound card (I see it in Device Manager with the yellow !).

    So pretty much, I'm stuck without audio currently, and even when it did work, it had issues (that weren't present in Win7 or 8). Has anyone else had such an experience?
     
  2. ByrdieMan

    ByrdieMan MDL Novice

    Feb 21, 2009
    10
    1
    0
    I had the exact same problem on a clean install to a new partition. The Audio Endpoint Builder service crashed when started which precludes the Audio service starting. Never got it to work. My solution was to upgrade my current 8 install (after imaging the drive of course). Now my audio works fine.

    The upgrade from ISO worked perfectly. I did have to reinstall my Intel RST drivers (drives worked fine but the application was busted) and Asmedia USB 3.0 drivers. Now everything is peachy keen.
     
  3. Bytebuster

    Bytebuster MDL Addicted

    Apr 30, 2013
    551
    203
    30
    #3 Bytebuster, Jun 27, 2013
    Last edited: Jun 29, 2013
    I installed 8.1 x86 Preview on an older desktop which has int. sound (C-Media High Definition Audio)

    Previously I ran 8 x64 and x86 - without any hard- or software issues.
    For some reason 8 x64 recognized the C-Media High Definition audio device out of the box and 8 x86 did not.
    Solved by using an XP driver (no newer available).

    I'm unable to run 8.1 x64 Preview on this machine because the processor doesn't support LAHF/SAHF and PrefetchW so I was more-or-less forced to install 8.1 x86 Preview. (...real bummer as 8 x64 works fine)

    Did a clean install (ISO), no issues except for audio... so my first thought was the XP driver.
    However - Windows reports: This device is working properly.

    ...took a quick peek at services;

    Windows could not start the Windows Audio service on Local Computer.
    Error 1068; The dependency service or group failed to start.


    and;

    Windows could not start the Windows Audio End Point service on Local Computer.
    Error 1067; The process terminated unexpectedly.


    ...going to install 8 x86 then upgrade to 8.1 x86 Preview next; hope it makes a difference as I tried everything else I could think of.

    /edit/

    Update;

    Installed 8 x86 Pro retail, installed driver, tested, audio ok - upgraded to 8.1 x86 Preview, tested, no audio - same problem.

    Stuck without audio for the time being.
    :(