Bios Recovery Procedures

Discussion in 'BIOS Mods' started by petar, May 9, 2008.

  1. Anonymousse

    Anonymousse MDL Novice

    Sep 19, 2014
    1
    0
    0
    Hello the team, and sorry for my english.
    I m tested to upgrade my bios on MSI H87I, I had v2.2 BIOS and Tested V2.7, but i did upgrade on Win7 x64 and the comp shutdown at 99 %.
    Now i have only fan on when i put on my comp. Black screen and reboot himself after 1min, the 2nd boot don't make reboot.
    Hox fix that?
    Thk you for your help.
     
  2. Pockets69

    Pockets69 MDL Novice

    Feb 24, 2014
    8
    0
    0
    Hey guys new post new problem...

    My bios got corrupted after modifying a setting (related to bios admin password) i removed the password saved and exit, and after that the laptop rebooted black screen no backlight, fans spining, i opened it removed the battery, removed the power cord, and the cmos battery, i let it rest for 10 mins, i pressed the power button to drain the rest of the board energy, then i put the cmos battery back and connected the power cord again, booted it same situation fans spin, black screen no backlight, i also tried to connect to the hdmi output to the tv see if it was some other problem, no signal.

    I then went to download the bios from asus support, to try and recovery it, it was a .cap file, i named it AMIBIOS.ROM and went for the CTRL+HOME to my amazement my laptop keyboard does not have a Home button. so right now i have no way of doing the procedure, here is what i have done / tried so far:
    - cmos reset by removing the cmos battery (as described above)

    i am trying to do a crisis recovery boot, but i don't have the home button (i know that the ctrl+home button works because i have other laptops here at home with ami aptio bios and the procedure works on them).

    - the laptop is an asus vivobook s200e (x202 in the us) with an AMI APTIO UEFI bios, i am at a loss here, i don't know what else to do.

    EDIT: Actually i lie... it does have an home button its on the left arrow as an fn key to activate it, i tried ctrl+that left arrow, and fn+that arrow it didn't work either.
     
  3. maozarob

    maozarob MDL Novice

    Nov 26, 2014
    3
    0
    0
    Hi (sorry for bad english),

    how can I recover my moded BIOS to original ASRock BIOS?
    I already tried instant flash utility in BIOS but it said "No image file detected" (USB stick)
    I already tried copy to usb stick (amiboot.rom, AMIBOOT.ROM, AMIBIOS.ROM, amibios.rom, Z97AVR_1.10, Z97AVR_110.exe) with no success.. :(

    Moded BIOS doesnt work correctly (every time I power off computer and plug 230V cabel off and another day I power on computer there is bad TIME in BIOS. 2025 year.. OR computer didnt start (no power led, no fan working..) - than I must put battery off and put in another battery.

    Could you help me, pls?

    -------------------------------
    Originally Posted by maozarob

    Hi there! Can I kindly ask for modded bios for this board.
    -Manufacturer: ASRock
    -Motherboard Model: Z97 Anniversary
    -Bios revision: P1.10
    -Bios Type: AMI BIOS /ACPI 2.0
    -Bios Download Link:
    -RW Everything Report Download Link:

    This is for Windows 7 Home Premium (x64). Could you please include Certificate.
    Thanks.



    ----------------------------
    Originally Posted by akcent:
    ASUS 2.1
     
  4. hell1134

    hell1134 MDL Novice

    May 18, 2017
    8
    0
    0
  5. frog_tech

    frog_tech MDL Novice

    Nov 22, 2012
    7
    1
    0
    Hello I have a Toshiba Satellite C660D-16F PSC1YE that the update of the bios from ver. 1.4 to 1.6 went wrong! To be honest the whole procedure completed succesfully but after the laptop rebooted, ended with a black screen. The caps and num lock leds works normally and also seems to work the ctrl alt del for restart. I can succesfully enter to recovery mode with the Fn + B keys combination but no luck in recovery. I think is something wrong with the 1.6 version of the bios but no luck of finding the 1.4 again.

    I also checked if the afuwingui utility that did the update kept some bios backup, but no luck. The only way I get close to revovery is by using a 1GB usb flash formated in FAT32 with the two files I have extracted from 1.6 bios (bios.rom 2048KB, ec.rom 128KB) in its root and entering the laptop in recovery mode by leaving the battery removed and pressing the Fn +B keys combination before plug in the charger and press the power button. All this procedure leave all laptops's lights off and the cpu fan spinning at full speed, then I get two long readings from the usb flash as indicating by its led (about 23 seconds totally) and when the reading ends just stays in this state, no lights, fan spinning at full speed, no matter how long I'll leave it.

    I noticed that afuwingui utility after succesfully programmed the main bios blocks did the same procedure for the EC also.

    Any ideas how can I recover from that or at least someone with a compatible 1.4 bios version?

    Thanks in advance.
     
  6. frog_tech

    frog_tech MDL Novice

    Nov 22, 2012
    7
    1
    0
    Can at least someone help me recognize what kind of bios do I have? The flash utility that came with the bios update directly from toshiba's site for my laptop was the afuwingui utility. Nevertheless the computer seems to enter in recovery mode with a key combination that is known to be for phoenix bios. How can I be sure in order to know which recovery procedure to choose?

    Thanks again.
     
  7. Kevin1991

    Kevin1991 MDL Novice

    Oct 7, 2015
    3
    1
    0
    Hi all,

    I'm new to the forum. I have one question.

    I have a Toshiba Satellite L675-119.
    I've downloaded the BIOS from Toshiba website.
    Extracted files are:
    • bios.ROM
    • BiosCheck.ini
    • ec.rom
    • Setup.exe
    When I load the bios.ROM file on Andy's Tool I receive the following message:

    After extracting I get the following information:
    I don't know what to name the .ROM file.
    Where can I find that bit of information?

    Thanks in advance :)
     
  8. Lauriz

    Lauriz MDL Novice

    Oct 25, 2009
    29
    4
    0
    #1451 Lauriz, Dec 28, 2018
    Last edited: Jan 14, 2019
    I have come accross a horizon table pc 27 10109 that was incorrectly flashed with Horizon 2 27 bios O02KT22A rendering it unbootable. Is there a rescue boot procedure for these all in ones as the former lenovo wincris? Please advise on how to ressurect this pc. I could try to flash bios chip directly but can't find a bios file for it. Or flashing procedures for this nonbootable bricked board in particular.


    Ok so i have tried to recover hold windows + B keys and turning power on with a u22.bin (Horizon 27 10109 bios) that was renamed to IMGEED.ROM on a fat32 blank nonbootable Usb. Flash drive begins to flash and I release keys usb just flashes and stops then flashes again without stopping left it running overnight and the cycle never stops. I am thinking it is searching for a specific name but I dont know where to start.
     
  9. Lauriz

    Lauriz MDL Novice

    Oct 25, 2009
    29
    4
    0
    #1452 Lauriz, Jan 14, 2019
    Last edited: Jan 17, 2019
    Ok so i have tried to recover hold windows + B keys and turning power on with a u22.bin (Horizon 27 10109 bios) that was renamed to IMGEED.ROM on a fat32 blank nonbootable Usb. Flash drive begins to flash and I release keys usb just flashes and stops then flashes again without stopping left it running overnight and the cycle never stops. I am thinking it is searching for a specific name but I dont know where to start.

    Solved.........programmed bios chip in circuit with AR-32A Programmer from arlabs.com/bios_kits
     
  10. Fned

    Fned MDL Novice

    Jan 26, 2019
    5
    2
    0
    Hello,

    I have a semi-bricked toshiba Satellite pro U400 - 122 ( part number: PSU41E) , after a failed flash. The corrupt BIOS in the machine is version 4.70, as can be found at support.toshiba.com/support/viewContentDetail?contentId=2848987

    I have spent about 20hours trying the phoenix crisis recovery described here. I have tried a 256MB usb stick and a 4GB one. I tried FAT16, FAT32, and also FAT12 (I dumped the crisis floppy image using "dd" directly to the usb stick block device under linux). I have tried both the HP USB format and the phoenix wincris FAT format, which I ran under a Windows XP SP3 vmware machine. I tried both the minidos from the "Phoenix Recovery" rar, and the one from phoenix crisis floppy/usb stick.

    I could not really, using the SLIC phoenixtool 273 or 266 find a name that made sense. The tool gave me this:
    SLIC header found in BIOSCOD01.ROM at CEB7
    Pubkey found in MOD_4A00.ROM at 0
    Marker found in HOLE3.ROM at 0
    'SLIC' string found in BIOSCOD01.ROM at CF10
    'SLIC' string found in ROMEXEC00.ROM at 2ED0
    OEM/Table IDs identified are:
    1. OEMID_OEMTABLE
    2. TOSQCITOSQCI00
    3. TOSQCIN.Jersey
    Header (OEMID_OEMTABLE LTP) in BIOSCOD01.ROM (x1)
    Pubkey in MOD_4A00.ROM (x1)
    Marker (2.1) (TOSQCITOSQCI00) in HOLE3.ROM (x1)
    Compressing all SLIC elements in SLIC directory....
    Please specify a SLIC file

    I also noticed that the BB.BIN module contains the string C:\PTL\CHIPSET\INTEL\CRESTLNE\MEMORY\OUT32\MINITDLLBB.pdb which is a visual studio debug file name, inside what seems to be a PE format DLL.

    So I grepped and searched all the strings inside the 'DUMP' directory, and then tried these names on the USB stick : "tosqcin" "tosqci" "tosqc" "te1s470" "te1s" "su40" "su41" "psu41u" "psu40u" "psu4" "i3a63" "i3a6" "bios" " " " " " " " " " " " " " " " "
    And I tried all the extensions "wph" "rom" "bin" "fd" and "" (empty). This filled quite a bit of the 256MB USB stick. On the FAT12 floppy-syle USB, because there was only1.44MB, I tried just a few of these.

    The Satellite pro U400-122 seams to enter the crisis recovery fine, using the Fn+esc key combination. The power on led starts blinking, the USB stick lights up, then after ~3 seconds, loud and high pitch beeps in groups of 3 repeat ..._..._..._ This is really quite loud (the neighbours wondered if it was a fire alarm) and it does not stop. I have let this run for 20 minutes, but obviously the USB is not read and the BIOS is not flashed.

    I wonder if the boot block recovery has been corrupted somehow, because this laptop had the windows 7 loader crack installed, to make it appear as a valid OEM bulk licences win7 ultimate machine. I can retrieve and share the corrupt flash file from its harddrive if someone is interested.

    Could you gurus give me a hand ? For example tell me exactly which name I should give to the bios.wph ?

    I have ordered a cheap USB floppy drive, and if necessary I can order also a USB SPI programmer with cables, but I am not sure my soldering abilities are good enough. I know it is a cheap laptop, but I have decided that I am not going to let it go out of order without a fight.
     
  11. Fned

    Fned MDL Novice

    Jan 26, 2019
    5
    2
    0
    I have retrieved from the SSD the flashable.bak and the bad BIOS WPH files, and compared the DUMP directories with windiff.

    The only file that was affected by the winloader crack is ESCD.BIN

    OTOH, lots of files are different in the corrupt WPH compared to the original TE1S470.WPH, but BB.BIN are identical, and also :
    ACPI00.AML
    ACPI01.BIN
    ACPI02.BIN
    ACPI03.ROM
    ACPI04.ROM
    BB.BIN
    BIOSCOD01.ROM
    BIOSCOD02.ROM
    BIOSCOD04.ROM
    BIOSCOD05.ROM
    BIOSCOD07.ROM
    BIOSENTRY00.ROM
    DECOMPC00.PEI
    DISPLAY00.ROM
    ESCD.BIN
    HOLE0.ROM
    HOLE1.ROM
    HOLE2.ROM
    HOLE3.ROM
    MISER00.ROM
    MOD_4600.ROM
    MOD_4800.ROM
    MOD_4A00.ROM
    MOD_4B00.ROM
    MOD_5100.ROM
    OPROM00.ROM
    OPROM04.ROM
    ROMEXEC01.ROM
    SETUP00.ROM
    TEMPLAT00.ROM
    USER00.ROM
    _C00.PEI

    So the corrupt flash has undone the ESCD.BIN modification.

    It is good news that the BB.BIN is sane, but I still have no idea how to get the phoenix crisis flash to work... please help if you know what filename to use for bios.wph on this machine.
     
  12. Fned

    Fned MDL Novice

    Jan 26, 2019
    5
    2
    0
  13. Fned

    Fned MDL Novice

    Jan 26, 2019
    5
    2
    0
    While I wait for my usb floppy drive and ch341a , I made a few more attempts and searches.

    On the toshiba european forums, I find advice to not use any crisis disk found online and rely only on their certified techs who charge 100 bucks for the service. But I found a message from "IgorE" that states that the toshiba crisis recovery works because he added a phlash.ini file to the drive.

    On other messages, I read that crisis recovery was successful with only the WPH file on a FAT16 stick.

    So I wonder, does the toshiba variant of the phoenix boot block recovery actually run the minidos boot, does it actually boot into DOS and run phlash16.exe ? Or does it maybe parse the phlash.ini file even if it does not run the dos flasher ?

    I tried adding an ini file to my crisis stick, but no dice. I also tried putting the WPH on a CDrom, and also a bootable CDrom with the minidos disk. Still the same result, flashes of the power LED, then beeps*3 repeat, and no flashing of the USB stick LED, nor CDrom.
     
  14. Krager

    Krager MDL Senior Member

    Jan 9, 2017
    374
    211
    10
    I have an Acer Aspire laptop (A717-72G) with Insyde BIOS and would like to have what I need in place for a boot block BIOS recovery if I need it. Don't have a problem or anything, want the stuff on-hand just in case. I can get the .fd file no problem by extracting the contents of the Acer BIOS package, but I can't find the filename I need to use. Is there a way I can get that info?