Bricked Dell XPS One A2010

Discussion in 'BIOS Mods' started by pswii, Jun 13, 2020.

  1. pswii

    pswii MDL Novice

    Jul 16, 2015
    Hello All, I had originally posted this on BIOSMods a few days ago and have gotten no response so I am going to try my luck here.

    I've bricked my Dell XPS One A2010 as a result of a BSOD during a BIOS update. When I power it on, first the Play/Pause, Eject, and LCD Backlight buttons turn on and the system beeps. Then all fans start spinning and the system steadily beeps. It runs an AMI BIOS so I tried booting into FreeDOS with a flash drive to use AFUDOS ("afudos /im-010008 /jm-020006 /pb") to flash the two bios files, but I don't think the system is booting it on account of the beeping. I also attempted this with a FAT32 240GB SSD and I still got nowhere. Additionally, in one of the threads it appeared that the second file was the one causing me grief so I tried naming that AMIBOOT.rom but it appeared that the system wasn't even reading USB or the SSD.

    I can tell no power is going to any USB ports because my USB keyboard remains dark when I power on the system. As such I cannot press the home key. Additionally, I have no idea if the wireless keyboard the computer came with can be trusted as I can't tell if it is still synced. It doesn't seem to wake up when I power on the system, so that's a nogo.

    As I type this, I've just found a ROM Recovery Jumper, and when I remove it and turn on the system, the fans spin for a few moments and it shuts off, the system turns itself back on, rinse and repeat. Nothing USB related turns on so it definitely isn't finding an AMIBOOT.rom on the flash drive. It also definitely isn't reading it from the SSD. If the USB ports don't work and the SATA ports don't work, there still has to be a way to recover this thing given that there is a labeled jumper for it. This is an AIO computer so it MUST be intentional. The two methods of entry I haven't tried yet are the SD card slot and the CD Drive. There is no floppy drive, and no PS/2 port. There is a LPC Debug thing, but I have no idea how useful it would be.

    I have a feeling that the name might be wrong or I might be using the wrong file. The BIOS is flashed using two files, and I don't know which one is relevant. Additionally, I don't have any clue how to use Andy P’s SLIC tool to find the right BIOS recovery file name, so I have absolutely no clue if AMIBOOT.rom is the right name to use.

    The BIOS is located on Dell's Website, but I cannot post the link because I haven't ever posted here.

    If you can help, that would be magnificent! Thanks!