Cannot start Software Protection (sppsvc)

Discussion in 'Windows 7' started by yohu123, Jan 23, 2010.

  1. yohu123

    yohu123 MDL Novice

    Jan 22, 2010
    11
    0
    0
    hi, i have posted in the following thread: http://forums.mydigitallife.net/thr...safer-activation-solution?p=224313#post224313
    but since it is 126 pages long, no one wud read my post (atleast not the admins or who can help me)
    so im creating a new thread, here goes...
    i installed windows 7 ultimate (v6.1 build 7600) using 'Windows_7_Ultimate_Activated_AIO.iso'.
    so i think it came with its own slic v2.1 loader and the installation went perfectly smooth.
    at 1st nothing was wrong and i cud check/install win updates just fine.
    but then i came across update kb974431
    it installed fine too but during reboot it failed at 80% in applying the update, reverted the changes and then rebooted again.
    after this, i cud neither install manually this update nor cud i check anymore for windows updates.
    for both, i get the c0000022 error.
    after this i also started getting the 'this copy of windows is not genuine' and popups to install a licensed copy.
    so i tried removewat 2.1 and chew-wga 0.9
    after installing each of them successfully, i tried to manually install the update and check for new win updates.
    both the cracks/activators couldnt allow me this.
    then i tried a 'sfc /scannow' to revert all the modded system files to original state so that i cud install the update.
    sfc did find a few modded files and repaired all of them, except for 'sppcomapi.dll'
    now i cant seem to find the original non-modded version of this file anywhere on the net.
    i even moved that file elsewhere and replaced it with a blank txt file in its name, still nothing.
    i finally tried to start Software Protection via services.msc and tried the same with cmd (as admin) using 'net 'start sppsvc'.
    in both the cases, it gave the 'Access denied' error.
    i tried to start this service from safe mode too and same prob.
    plz help me as i just need to repair 'sppcomapi.dll' and install the update kb974431 after which i guess i shud be fine.
    thanx, in advance.
     
  2. secr9tos

    secr9tos MDL Addicted

    Jul 28, 2009
    999
    133
    30
    x86 or x64 install?

    A loader should not be affected by this update..

    don't tell me that u use Chew and RemoveWAT at the same time..

    Try System Restore if sfc /scannow does not work.
     
  3. david toska

    david toska MDL Member

    Nov 30, 2009
    156
    7
    10
    What is kb974431 for??? I dont have it. And it dosnt show up at wu for me....
     
  4. yohu123

    yohu123 MDL Novice

    Jan 22, 2010
    11
    0
    0
    @secr9tos: thanx for replying

    x86 = 32bit

    maybe not but its only after this update failed, things started to go south.
    i was able to install 10 other updates before this one and two more after this one.
    oh yeah, although the update kb974431 failed, i think that wasnt the cause of the checking of new updates to fail
    i read in some thread on this forum:
    1) stop windows update service via services.msc
    2) delete the softwaredistribution folder (i renamed it to -old)
    3) start windows update again via services.msc
    4) reboot the machine and try to manually install the update again.

    i did all of the above but the update still failed to install but by then i had lost the history (not the updates themselves) of update installations.
    and then i tried checking for new updates and got the c0000022 error
    so i again did all of the above steps except this time i deleted the newly created softwaredistribution folder and renamed the -old one back to the original name
    but that didnt help to restore the updates installation history nor get rid of the c0000022 error while checking for newer updates and the manual installation continued to fail at reboot like before.

    good question....i remember installing removewat and rebooting to see if it fixed the prob (which it didnt)
    then i tried chew. but i dont remember if i restored wat before using chew. so i cant recall that

    i wud love to but cant, surprisingly system restore shows that there r no restore points when i specifically remember turn on system protection for all my partitions (windows drive protection was already on) and manually creating restore points for each of these partitions.
    infact, i recall creating restore points right before i tried removewat (incase anything wud go wrong)
    and i also remember that i never turned off system protection at all


    right now, i just need an original sppcomapi.dll and/or a way to turn on Software Protection service.
    i think the service 'sppsvc' and the dll 'sppcomapi.dll' r dependent on each other and r one and the same thing
    so if u or anyone here can plz help me with this specific prob, that wud be gr8
    thanx
     
  5. rolmos

    rolmos MDL Novice

    Oct 13, 2009
    19
    0
    0
    Like secr9tos said, try running sfc /scannow. Use an untouched DVD this time.
     
  6. secr9tos

    secr9tos MDL Addicted

    Jul 28, 2009
    999
    133
    30
    Or open Chew-WGA and do a "Restore" followed by a sfc /scannow.
     
  7. yohu123

    yohu123 MDL Novice

    Jan 22, 2010
    11
    0
    0
    ive already undone removewat and chew
    i confirmed by running them again and they both give me an option to install them so i now they have been uninstalled.
    sfc /scannow was ran after uninstalling both and it worked for many of the modded files it found, except for 'sppcomapi.dll'
    so i kept running it specifically for this dll from cmd (as admin), like so: sfc /scanfile=c:\windows\System32\sppcomapi.dll
    but it keeps failing, even from safe mode.
    i need to original unmodded version of this dll
    so can anyone plz provide me that or a link to download it?

    @rolmos: what do u mean by "Use an untouched DVD this time" ?
    do i need to have the dvd inserted in the dvd drive before i run sfc /scannow?
    i have manually searched for the file 'sppcomapi.dll' in the dvd but cudnt find it.
     
  8. Hazar

    Hazar MDL Guru

    Jul 29, 2009
    2,523
    452
    90
    takeown /f %windir%\System32\sppcomapi.dll
    icacls %windir%\System32\sppcomapi.dll /reset
    sfc /scanfile=c:\windows\System32\sppcomapi.dll

    should fix it
     
  9. yohu123

    yohu123 MDL Novice

    Jan 22, 2010
    11
    0
    0
    #11 yohu123, Jan 23, 2010
    Last edited: Jan 24, 2010
    (OP)
    thanx for reply hazar
    the takeown and icalcs commands did the trick coz when i ran the sfc /scanfile command, it said there were no integrity probs.
    but i still cant start the Software Protection service (sppsvc) via services.msc
    it says 'Access denied'.
    i even tried to start the service from cmd (as admin), as follows:
    takeown /f %windir%\System32\sppcomapi.dll
    net start sppsvc

    but i got the following msgs:
    The Software Protection service is starting.
    The Software Protection service could not be started.

    A system error has occurred.

    System error 5 has occurred.

    Access is denied.


    once i get Software Protection running again, im sure i wont have probs installing the update kb974431 and also successfully checking for new win updates.
    we r almost there guys!
    thanx for ur quick responses and all ur help so far


    EDIT: i tried to take ownership of sppsvc.exe too as i did for sppcomapi.dll like so:
    takeown /f %windir%\System32\sppsvc.exe
    icacls %windir%\System32\sppsvc.exe /reset
    sfc /scanfile=c:\windows\System32\sppsvc.exe

    but still it gives me access denied when i try to start the service.
    plz help.
     
  10. yohu123

    yohu123 MDL Novice

    Jan 22, 2010
    11
    0
    0
  11. John Peterson

    John Peterson MDL Novice

    Dec 26, 2009
    41
    16
    0
    This might help someone:

    I also got this problem. Which stopped med from installing the certificate with daz. In my case the problem was simply that permissions for sppsvc.exe had been modified to deny access from NT AUTHORITY\NETWORK SERVICE. This service is by default run with NETWORK SERVICE and it can't be run with for example Local System account. So I restored permissions for the file and ran the service with NETWORK SERVICE.
     
  12. DARKOR04

    DARKOR04 MDL Tester/Developer

    Jul 5, 2010
    495
    887
    10
    @John Peterson

    WoW you are awesome, giving life to a dead thread almost 1 year later... impressive LOL
     
  13. kpcart

    kpcart MDL Novice

    Jan 25, 2012
    3
    0
    0
    what process did you use to restore teh permissions. i need to do the same thing on mine, but havent been able to, i just fiddled arround by right clicking, going to properties and clicking a few things in the security tab. no success, can you give me the correct steps to change the permission?