Can't boot from USB STICK on new I7-860/ASUS Build

Discussion in 'Windows 7' started by MisterEd, Dec 8, 2009.

Thread Status:
Not open for further replies.
  1. MisterEd

    MisterEd MDL Novice

    Aug 9, 2009
    22
    0
    0
    I have created bootable 2GB Corsair memory stick. I can boot off of it on my 1yr old Dell E4300 laptop under Win7 Ultimate.

    I just built a new desktop computer around the Asus P7P55D Deluxe motherboard / Win7 Ultimate and am unable to boot off this memory stick which boots fine in my laptop.

    I used the HP utility per the steps on this forum which loaded Win98 files.

    Yes, the "USB DEVICE" is first in the BOOT PRIORITY screen of the computer BIOS then comes my DVD drive then my Raid array.

    Will this stick only boot from a specific USB slot or should it boot from ANY USB slot? What am I missing here? I have the latest BIOS installed (1102) on the Asus motherboard.

    Thanks for your assistance. Ed
     
  2. bambara

    bambara MDL Junior Member

    Oct 18, 2009
    92
    1
    0
    I also can boot from USB memory in my laptop (new one, bought it less than a year ago), but I can't boot from my old desktop even though I get the option to boot from it through BIOS setup.

    I assume that certain motherboards are incapable of booting from USB? But I could be wrong...
     
  3. MisterEd

    MisterEd MDL Novice

    Aug 9, 2009
    22
    0
    0
    This is a NEW desktop. This motherboard has no floppy connector so there isn't much choice. :) I would think (hope) all new motherboards would have this capability.
     
  4. SoLoR

    SoLoR MDL Expert

    Jul 30, 2008
    1,341
    1,212
    60
    try some other stick, might be just some wierd compatibility issue.
     
  5. willko

    willko MDL Member

    May 14, 2008
    129
    13
    10
    Might as well ask an obvious question,...
    but when you say,
    Have you looked through ALL the alternatives (in the BIOS boot Priority screen)..? Its just that I seem to remember a counter-intuitive choice under HDDs and not "USB DEVICES" ( listing the USB stick as a bootable drive that is)... I'm sure you've checked but I just thought I'd mention it because its happened to me. :D

    Also, sometimes there is a separate HDD priority section in the BIOS which determines which HDDs will be available under the BOOT PRIORITY screen,.. might be hidden there? - the USB stick is usually listed as a specific item that resembles an HDDs listing and not as a generic "USB DEVICE"...

    I'd be REALLY surprised to find out there's a mobo that WON'T boot off a USB stick!!!:eek:
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. HSChronic

    HSChronic MDL Expert

    Aug 25, 2007
    1,213
    55
    60
    like others have said it is a BIOS setting, you need to tell the computer to boot off USB hard drives and list USB higher in the list of hard drive's being booted from. Some USB sticks are detected as hard drives not removable devices so you might need to adjust the BIOS to read USB hard drives on boot.
     
  7. genuine555

    genuine555 MDL Expert

    Oct 3, 2009
    1,639
    56
    60
    Why don't you just turn off all other boot options ?

    Leave only USB on as boot option.
    That way you'll know if it is or isn't due to bios setting.
     
  8. MisterEd

    MisterEd MDL Novice

    Aug 9, 2009
    22
    0
    0
    Tried that earlier and it didn't work until I tried item #2 below. But I did figure out the problem.

    #1) Bios settings were correct. The only option was "Removable Device" in BOOT order.

    #2) There is a "POST" message that says "HIT F8 FOR BBS POPUP." No idea what that was until I RTFM and hit "F8" :). After hitting F8 a BIOS menu comes up with all the boot options INCLUDING CORSAIR USB. I was then able to boot off the USB.

    #3) Once it booted once off the USB from that menu for some reason I was now able to boot off the USB through a normal bootup.

    #4) Powered off the computer and it "lost" that boot (see #3) and I had to go back to step #2 and it started working again.

    #5) What really made it difficult to troubleshoot is I have a 3.5" "USB card reader" which sits in the case where the floppy drive would go and includes a USB 2.0 port. No matter what I do it won't boot from that USB port which really threw me off because I use that front panel USB most of the time. Between that and the other idiosyncrasies of this board I've been going crazy for 3 days.

    Thanks for all your responses.
     
  9. urie

    urie Moderator
    Staff Member

    May 21, 2007
    8,646
    3,003
    300
    Closing thread, problem solved :)