Convert Windows Home Server PP3 Trial to OEM?

Discussion in 'Windows Server' started by ZaForD, Jan 19, 2010.

  1. metalman77

    metalman77 MDL Novice

    Jun 20, 2010
    10
    0
    0
    i've never installed WHS so have patience. My motherboard has onboard raid that during a normal windows XP installl I have to press F6 to install aditioinal drivers... this *used* to happen over the A: drive (Floppy).

    I haven't had to use a floppy in ages so that drive is no longer around. will I be able to slip drivers into the WHS install? Or am I going to need to get a floppy in here somehow?
     
  2. sebus

    sebus MDL Guru

    Jul 23, 2008
    6,147
    1,922
    210
    Yes, need to get floppy (sadly)

    sebus
     
  3. metalman77

    metalman77 MDL Novice

    Jun 20, 2010
    10
    0
    0
    thanks sebus.

    As I am starting to do this - a light went off in my head... I'm guessing this is how the VMware P2V converter works? The VM's bios shows the manufacturer of the original physical machine.

    thanks again. going to start tonight and hopefully get it done!
     
  4. metalman77

    metalman77 MDL Novice

    Jun 20, 2010
    10
    0
    0
    will cdimage 2.52 work? or do i have to find the 2.54? I can't seem to find any legit looking copies. Someone posted it here and it looked like a low post count guy and only had like 3 replies.

    a search for 2.54 on google actually had a link to this thread - imagine that!
     
  5. sebus

    sebus MDL Guru

    Jul 23, 2008
    6,147
    1,922
    210
    Google CDIMAGE_2.54, first two hits give you RS link, that easy!

    sebus
     
  6. metalman77

    metalman77 MDL Novice

    Jun 20, 2010
    10
    0
    0
    that's what i first tried but the result here didn't seem to be too popular and the 2nd one actually refers back to the same thread, also on here.

    Hoever, if that's where ppl are getting it then i'll just us a bastard system to try it on so i dont' hose my better machine.

    thanks.
     
  7. metalman77

    metalman77 MDL Novice

    Jun 20, 2010
    10
    0
    0
    i found those sebus - and thanks freestyler too. I just didn't know if they were the real deal or trustworthy. after Sebus' post, I grabbed it, and built the ISO per Freestyler's steps post on page 4 right before I left for work in the morning. Tonight when I get home will be the real test to see if this actually all worked.

    thanks to both of you - i'll make sure I rep and thank each of your replies.
     
  8. metalman77

    metalman77 MDL Novice

    Jun 20, 2010
    10
    0
    0
    #50 metalman77, Jun 26, 2010
    Last edited: Jun 26, 2010
    okay - so i installed, w.o. the key and went all the way thru to the end after several hours. WHS loads up and asks for key or activate in 30 days. I put in one of the OEM keys that I found. then it said lets go ahead and activate.

    i'm missing the part where I need to put in the key that has ####-OEM-4211965-.... in it...

    EDIT:
    rebooted and clicked on start - windows activation. I get the screen showing "windows is already activated". Still don't see were that OEM key is supposed to be entered. that's the product ID, right? should that go in C:\windows\system32\pid.inf?
     
  9. sebus

    sebus MDL Guru

    Jul 23, 2008
    6,147
    1,922
    210
    And what key did you actually use? (just give the first 5 characters...)


    sebus
     
  10. FreeStyler

    FreeStyler MDL Guru

    Jun 23, 2007
    3,520
    3,723
    120
    #52 FreeStyler, Jun 26, 2010
    Last edited: Jun 27, 2010
    Dude, you do not have to activate... this whole mechansm is made to bypass online activation...
    After inserting OEM:SLP key just reboot and you should be activated (that is, if you have the correct oembios files & SLP strings in place)
    pid.inf can be edited on the DISC, not on the windows install itself, but like you did it, eg: entering the key afterwards should work as well

    So basicly...i do not see you problem? you are activated, right?
     
  11. metalman77

    metalman77 MDL Novice

    Jun 20, 2010
    10
    0
    0
    sebus i used K3TQ3

    Freestyler - yeah that's what I thought. that I don't need to activate so thought i did something wrong. this took at least 2 hours to install with the mulitple reboots. Anyhow, i edited that post. All i did was put in that key that starts with k3... rebooted and it said activated. So I assume it is OK.
     
  12. FreeStyler

    FreeStyler MDL Guru

    Jun 23, 2007
    3,520
    3,723
    120
    Exactly, you are all good

    Now you could replace the key on the installation media (inside pid.inf) with the K3TQ3 key to automaticly activate and not having to insert the key manually after installation
     
  13. bumhead

    bumhead MDL Novice

    Aug 26, 2010
    7
    0
    0
    I have been having a lot of trouble. I have attempted to install WHS several times following Freestyler's instructions on p4.

    I have created three different OEM install discs (old dell, new dell, hp) along with inserting the relevant SLP string into my bios (Asus P5B Deluxe).

    Each time WHS installs most of the way through, however as WHS attempts to login for the first time as administrator, this error invariably presents:

    "A problem is preventing Windows from accurately checking the license for this computer. Error Code: 0x80004005"

    Below is the current state of my bios:

    Windows XP OEMBIOS Test v1.1/269/106 (C) 2007-2010 severach @ msfn forums
    F:Asus OEMBIOS.CAT CRC=2411858C
    F:Genuine OEMBIOS.CAT CRC=8B2EBECB
    F:Hewlett-Packard OEMBIOS.CAT CRC=00A1EECB
    F:Hewlett-Packard OEMBIOS.CAT CRC=3BA155E1
    F:HP & Compaq OEMBIOS.CAT CRC=CD4E1902

    Not sure what I am doing wrong. Any ideas?
     
  14. FreeStyler

    FreeStyler MDL Guru

    Jun 23, 2007
    3,520
    3,723
    120
    #56 FreeStyler, Aug 26, 2010
    Last edited by a moderator: Apr 20, 2017
  15. bumhead

    bumhead MDL Novice

    Aug 26, 2010
    7
    0
    0
    OK. That makes things a bit clearer. I have downloaded the DMI Tattoo CD which appears to automatically tattoo the bios to HP. This seems to be for XP also as it still came up with error.

    How do I tattoo the HP / COMPAQ (OEMBIOS CRC=D107C3EA), which appears have many strings into my bios with this tool?
     
  16. bumhead

    bumhead MDL Novice

    Aug 26, 2010
    7
    0
    0
    #58 bumhead, Aug 27, 2010
    Last edited: Aug 27, 2010
    It seems that the usb DMI Tatoo only does the HP string (i.e. XP activation). Whereas the CD is a lot more comprehensive containing the correct SLP for WHS. Unfortunately this does not work as I have SATA.

    I have attempted to create the SLP using AMITOOL adding

    F000,FFEA,6,COMPAQ
    F000,0000,FFFF,Hewlett-Packard

    into the rom file itself. DMITOOL shows the SLP string to be F000,0000,FFFF,Hewlett-Packard.


    I have also used the DMI /SM F000,0000,FFFF,Hewlett-Packard to insert the string. Is this the correct way to add the string?


    So I have tried multiple ways to insert the slp string, all apparently failing. Any ideas?
     
  17. FreeStyler

    FreeStyler MDL Guru

    Jun 23, 2007
    3,520
    3,723
    120
    That depends on your definition of hard, with the correct SLP string in place, it always activates in combination with proper OEMBIOS files and OEM:SLP key.
    Might just be you missed another step, maybe in the WHS Trial -> OEM conversion guide
     
  18. FreeStyler

    FreeStyler MDL Guru

    Jun 23, 2007
    3,520
    3,723
    120