Crazy mouse pointer glitch on windows 7 HP computer

Discussion in 'Windows 7' started by HavenFyre, Feb 17, 2013.

  1. HavenFyre

    HavenFyre MDL Novice

    Feb 17, 2013
    1
    0
    0
    This has happened to me several times already so here goes.
    Recently for about the past month and a half my mouse cursor has been acting up. It will freeze in one spot on my computer screen and when I try to move it it will flicker. It may move just a little bit in the direction I want it to move before it jumps back to that one spot. I will restart my computer and it will still be stuck in that one spot.

    The first time this happened I thought it was the actual mouse that was the problem. So i went to get a new mouse. It helped for a little while but then the problem happened again. I tried using my computer in safe mode. Guess what? The mouse cursor worked! But sadly when I went back to regular mode it froze up again. So I went back to safe mode and decided to do system restore. That, amazingly enough worked. But then the glitch happened again. I tried doing the system restore this time and it didn't work. I decided to do a scan for viruses. Nothing shows up. I did the scan while in safe mode cause that's the only place the mouse worked.

    I restarted my computer and when it started up again it said something about a disk check thing. after It did that it said something about deleting a "corrupted attribute" after it did all that and it started up normally AGAIN i logged on. my mouse worked fine.

    Any ideas what's up with my mouse?

    it's on my HP computer as well an HP Pavillion
     
  2. AlexAlba

    AlexAlba MDL Addicted

    Nov 27, 2012
    603
    1,094
    30
    #2 AlexAlba, Feb 17, 2013
    Last edited by a moderator: Feb 17, 2013
    If you already tried system restore and it didn't work then your operating system is ------ up
    Repair your windows installation
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Kouryu

    Kouryu MDL Senior Member

    Jan 19, 2011
    408
    111
    10
    update display drivers and mouse drivers... could fix it!