Creative sound blaster x-fi issue and windows 10 1903 build

Discussion in 'Windows 10' started by dzem, Apr 29, 2019.

  1. dzem

    dzem MDL Member

    Oct 15, 2015
    153
    23
    10
    You have a beer if that become a true :D
     
  2. erpsterm35

    erpsterm35 MDL Senior Member

    May 27, 2013
    473
    178
    10
  3. xXHelperXx

    xXHelperXx MDL Novice

    Mar 17, 2014
    15
    5
    0
    Hi,
    I own Sound Blaster Recon3Di with Win 10 1903 Os and no problem at all.
    Try to reinstall the driver.
    Best wishes
     
  4. red_cup

    red_cup MDL Novice

    Aug 1, 2015
    10
    1
    0
    There's a beta out for the Titanium HD. Only for this card (titanium HD SB1270), not other x-fi's, those are coming at a later date.
    www .reddit .com/r/SoundBlasterOfficial/comments/blf2z1/titanium_hd_driver_fix_for_windows_rs6_1903/ (remove spaces at the beginning)
    I haven't tested it, I'm waiting for the official 19H1 ESD's.
     
  5. cyberloner

    cyberloner MDL Member

    Sep 19, 2009
    205
    31
    10
    1903 bring new problem again? crap microsoft actually...
     
  6. SPDIF

    SPDIF MDL Junior Member

    Mar 30, 2014
    69
    34
    0
    I have Soundblaster Z for some time now installed, and it survive al versions from windows 10 until now. Keep fingers crossed...
    But besides that it al works as it should, and had just updated my drivers.
    Even sound blaster pro studio, everything is fine.

    I would never wanna witch it for an ASUS card! Had before with asus nothing then problems, now no problems with sound blaster anymore.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. thanh2412

    thanh2412 MDL Novice

    Sep 22, 2017
    13
    0
    0
    I'm running audigy 2 zs, and now the audigy support pack didn't work with 1903, so i think i will stay with 1809 until my sound card broken :)

    Does anyone here got the same trouble like me ?
     
  8. dzem

    dzem MDL Member

    Oct 15, 2015
    153
    23
    10
    Microsoft it seems has made a lot of mess in audio architecture. Best things that they can do is to revert it to previous state. No reason for experiments which goes nowhere.
     
  9. stefan7

    stefan7 MDL Novice

    Mar 30, 2009
    42
    1
    0
    who was busted? daniel_k ?

    i have an audigy se with daniel_k drivers which makes it an xtreme music and works perfectly on 1809, havent updated to 1903 yet.
     
  10. thanh2412

    thanh2412 MDL Novice

    Sep 22, 2017
    13
    0
    0
    audigy support pack didn't work in build 1903, now we can do nothing but wait daniel_K or someone else to fix this :(
     
  11. siouxcrstn

    siouxcrstn MDL Novice

    Nov 7, 2011
    1
    1
    0

    Hi, Just download Rx driver from Creative (file name : SBA5_PCDRV_L11_3_01_0056B.exe ) extract it with winrar or something like that, then install the driver using device manager.
     
  12. thanh2412

    thanh2412 MDL Novice

    Sep 22, 2017
    13
    0
    0
    thank you so much, it's work :)
     
  13. gyousana

    gyousana MDL Novice

    Mar 28, 2019
    2
    1
    0
    www reddit com/r/SoundBlasterOfficial/comments/bs4lh2/xfi_20k1_drivers_for_windows_1903_beta/
    They made it! They really made it! Long-live my XtremeGamer!
     
  14. dzem

    dzem MDL Member

    Oct 15, 2015
    153
    23
    10