d link adapter

Discussion in 'Windows 7' started by cooljay_4, Jan 30, 2010.

  1. cooljay_4

    cooljay_4 MDL Member

    Oct 10, 2009
    246
    1
    10
    #1 cooljay_4, Jan 30, 2010
    Last edited: Jan 30, 2010
    hey guys need some real help here

    i had my pc working upstairs fine for ages on internet i took that pc off for most of day because i have needed to sort my sisters out and i just used the dongle out of my pc in hers right now for the problem.
    it not work in my pc now just says cannot find network adapter i run the diagnosits thing and it says no drivers are installed or network cable is unplugged.

    what i have tried
    checked all cables all ok.
    registers the network adapter in device manager and says device is working properly.
    come downstairs on this PC downloaded the drivers for it and installed them upstairs stiill no joy
    last resort come on here ask for help.


    UPDATE:

    I think when i plugged my network adapter back in my USB slot i did not put it back in the same slot when i turned it back on therefore got all this trouble i will do a system restore and update on the situation tomorrow

    please3 can some one help oo if it does help its a GWL G122 revision C1
     
  2. greyaburton

    greyaburton MDL Addicted

    Mar 8, 2009
    553
    46
    30
    when you install a device have to keep track of which usb port you plug it in to cause if you plug it into a different one,the device has to be installed again.
     
  3. cooljay_4

    cooljay_4 MDL Member

    Oct 10, 2009
    246
    1
    10
    thnx for the reply guys

    ok for the first comment windows 7 automatically installes the driver when you plug it in. i didnt try the drivers as it already had the drivers installed and it was supposed to be running fine according to device manager when i run the network diagnosits it says its a driver issue but when i run the device manager says driver is working properly.

    for second issue i did install the device again actually what i did was plug it in all four of my usb ports unistalled the network adapeter then plugged it back in the first one again installed it still no joy

    i did a system restore no joy there too.

    last resort i formatted reinstall on windows 7 i think this is a bug in windows 7 for the d link adapter or any adapter were if u unplug ur adapter then plug it back into a diffrent port it messes up