Disable Office 2010 Splash Screens?

Discussion in 'Microsoft Office' started by DragonQ, Mar 13, 2011.

  1. DragonQ

    DragonQ MDL Novice

    Apr 19, 2010
    6
    0
    0
    Does anyone know how to do this for files opened directly? There's a few sites with details about the /q and /e switches etc. for shortcuts but this isn't useful when you usually open files from Explorer.

    I'm guessing there's a registry setting for it but I can't find any information through Google. :(
     
  2. menes

    menes MDL Novice

    Oct 21, 2007
    12
    12
    0
    #2 menes, Mar 13, 2011
    Last edited by a moderator: Apr 20, 2017
    Open regedit,

    For Word 2003 files, go to:
    Code:
    [HKEY_CLASSES_ROOT\Word.Document.8\shell\Open\command]
    change both to:
    C:\\Program Files\\Microsoft Office\\Office14\\WINWORD.EXE\" /q /n \"%1\"
    For Word 2007 and 2010 files, go to:
    Code:
    [HKEY_CLASSES_ROOT\Word.Document.12\shell\Open\command]
    change both to:
    C:\\Program Files\\Microsoft Office\\Office14\\WINWORD.EXE\" /q /n \"%1\"
    For Excel 2003 files, go to:
    Code:
    [HKEY_CLASSES_ROOT\Excel.Sheet.8\shell\Open\command]
    change both to:
    C:\\Program Files\\Microsoft Office\\Office14\\EXCEL.EXE\" /e /dde
    For Excel 2007 and 2010 files, go to:
    Code:
    [HKEY_CLASSES_ROOT\Excel.Sheet.12\shell\Open\command]
    change both to:
    C:\\Program Files\\Microsoft Office\\Office14\\EXCEL.EXE\" /e /dde
    For Powerpoint 2003 files, go to:
    Code:
    [HKEY_CLASSES_ROOT\PowerPoint.Slide.8\shell\Open\command]
    change to:
    C:\\PROGRA~1\\MICROS~2\\Office14\\POWERPNT.EXE /s \"%1\"
    For Powerpoint 2007 and 2010 files, go to:
    Code:
    [HKEY_CLASSES_ROOT\PowerPoint.Slide.12\shell\Open\command]
    change to:
    C:\\PROGRA~1\\MICROS~2\\Office14\\POWERPNT.EXE /s \"%1\"
     
  3. DragonQ

    DragonQ MDL Novice

    Apr 19, 2010
    6
    0
    0
    Thanks, that seems to work perfectly!
     
  4. Tigramber

    Tigramber MDL Novice

    Aug 27, 2011
    5
    0
    0
    #4 Tigramber, Aug 27, 2011
    Last edited by a moderator: Apr 20, 2017
    Definitely didn't work!

    Ack! I have Word 2010 installed. I changed both the registry values (Default and command) to the above strings, and now Word documents don't open. "The parameter is incorrect." How do I get the values back? I can still open winword.exe and then open documents.

    Of course, my file is in "Program Files (x86)" instead of" Program Files," so that might have something to do with it?

    Thanks!

    AJ
     
  5. tomah

    tomah MDL Senior Member

    Sep 25, 2010
    408
    354
    10
    You answered your own question. Change "Program Files" to "Program Files (x86)" and that should do it.
     
  6. akf

    akf MDL Senior Member

    Aug 17, 2010
    331
    144
    10
    Does disabling Office 2010 Splash Screens speed up the loading of Office 2010? Or, with splash screens enabled or not, Office 2010 will open in same amount of time upon left clicking the program?
     
  7. Tigramber

    Tigramber MDL Novice

    Aug 27, 2011
    5
    0
    0
    Nope.

    That didn't work. I repaired Office and it changed these registry values back to their original crazy values:
    (Default) REG_SZ "C:\Program Files (x86)\Microsoft Office\Office14\WINWORD.EXE" /n "%1"
    command REG_MULTI_SZ ykG^V5!!!!!!!!!MKKSkWORDFiles>bi$T!V!0Z={Pk0vm~AZu /n "%1" C:\\Program Files (x86)\\Microsoft Office\\Office14\\WINWORD.EXE" /q /n \"%1\"

    Since the "command" value is such a crazy thing, I bet I have to only modify the filepath and switches in that one instead of replacing the whole thing. What do you think? I'm scared to try!

    Thanks for your help,

    AJ
     

    Attached Files:

  8. Tigramber

    Tigramber MDL Novice

    Aug 27, 2011
    5
    0
    0
    Definitely faster without the splash screens. :) I couldn't modify the Windows 7 pinned taskbar shortcuts that are put there automatically during the Office installation, so I created shortcuts to the same programs on the desktop, modified them with the switches (/q, /e, /s, etc.), dragged those to the taskbar and unpinned the default ones. Works great!
     
  9. tomah

    tomah MDL Senior Member

    Sep 25, 2010
    408
    354
    10
    #9 tomah, Aug 29, 2011
    Last edited: Aug 29, 2011
    Was there a reason why you did a repair on Office?

    Anyways, try modifying your Default to "C:\Program Files (x86)\Microsoft Office\Office14\WINWORD.EXE" /q /n "%1"

    I'm not sure what to make of your Command line, as the default would not have included the extra "C:\\Program Files (x86)\\Microsoft Office\\Office14\\WINWORD.EXE" /q /n \"%1\" at the end. Try deleting the " C:\\Program Files (x86)\\Microsoft Office\\Office14\\WINWORD.EXE" /q /n \"%1\" from the end, and then add in as mentioned in Default above (/q) and see what happens.

    So, change command from: REG_MULTI_SZ ykG^V5!!!!!!!!!MKKSkWORDFiles>bi$T!V!0Z={Pk0vm~AZu /n "%1" C:\\Program Files (x86)\\Microsoft Office\\Office14\\WINWORD.EXE" /q /n \"%1\"

    to: REG_MULTI_SZ ykG^V5!!!!!!!!!MKKSkWORDFiles>bi$T!V!0Z={Pk0vm~AZu /n /q "%1"

    Also, I noticed that menes has an uneven amount of quotes in all of his change(s).
     
  10. Tigramber

    Tigramber MDL Novice

    Aug 27, 2011
    5
    0
    0
    I repaired Office because after changing the values on 8/26, I couldn't open any saved Word documents. I could open the program and then navigate via the File Open menu, but any saved documents couldn't be opened by double-clicking their icon. So, repairing Office rewrote the original registry values back again, which I posted on 8/28.

    Changing the registry values to the ones you have suggested doesn't seem to help. I still get the splash screen of "Starting" when loading Winword... what a waste of time these screens are...

    Anyways, thanks for your help.

    As a workaround, I replaced the default shortcut on the taskbar with a shortcut of my own, pointing to: "C:\Program Files (x86)\Microsoft Office\Office14\WINWORD.EXE" /q


    And this disables the splash screen for new documents, at least.
     
  11. Tigramber

    Tigramber MDL Novice

    Aug 27, 2011
    5
    0
    0
    Ha! Totally works!

    So I tried one more time and realized that I was editing the registry value in the Word.Document.8 folder instead of the Word.Document.12 folder. Stupid me! These registry values work like a charm to disable the splash screen when opening Word 2010 documents:

    In the Registry Editor directory: [HKEY_CLASSES_ROOT\Word.Document.12\shell\Open\command]

    (Default) = "C:\Program Files (x86)\Microsoft Office\Office14\WINWORD.EXE" /q /n "%1"
    command = ykG^V5!!!!!!!!!MKKSkWORDFiles>bi$T!V!0Z={Pk0vm~AZu /n /q "%1"

    Side note to tomah: Repairing Office did actually change the command value to include the extra filepath. It doesn't make sense to me, but who knows what Microsoft is doing sometimes? Taking out the filepath seems to work just fine for me, so no worries.

    Thanks to all for their help!
     
  12. sirkuzx

    sirkuzx MDL Novice

    Jan 16, 2012
    1
    0
    0
    #12 sirkuzx, Jan 16, 2012
    Last edited by a moderator: Apr 20, 2017
    just to add some experience

    Hi all, I have made some research and try an error test to tutorial on the forum and comes to this solution... enjoy everyone... SALAM..

    navigate to;

    [HKEY_CLASSES_ROOT\Word.Document.12\shell\Open\command]
    change both to:


    modified:

    for msword2010

    "C:\Program Files\Microsoft Office\Office14\WINWORD.EXE" /p /n \"%1\"
    xb'BV5!!!!!!!!!MKKSkWORDFiles>bi$T!V!0Z={Pk0vm~AZu/q /n "%1"

    for msexcel2010

    "C:\Program Files\Microsoft Office\Office14\EXCEL.EXE" /e /dde
    xb'BV5!!!!!!!!!MKKSkEXCELFiles>VijqBof(Y8'w!FId1gLQ /e /dde

    for ppoint2010

    "C:\Program Files\Microsoft Office\Office14\POWERPNT.EXE" "%1" /s
    xb'BV5!!!!!!!!!MKKSkPPTFiles>l5YAshJ5e9?Q10`FFc2C "%1" /s





    default value:


    "C:\Program Files\Microsoft Office\Office14\WINWORD.EXE" /n "%1"
    xb'BV5!!!!!!!!!MKKSkWORDFiles>bi$T!V!0Z={Pk0vm~AZu /n "%1"


    "C:\Program Files\Microsoft Office\Office14\EXCEL.EXE" /dde
    xb'BV5!!!!!!!!!MKKSkEXCELFiles>VijqBof(Y8'w!FId1gLQ /dde


    "C:\Program Files\Microsoft Office\Office14\POWERPNT.EXE" "%1"
    xb'BV5!!!!!!!!!MKKSkPPTFiles>l5YAshJ5e9?Q10`FFc2C "%1"
     
  13. AmigaUser

    AmigaUser MDL Novice

    Oct 30, 2012
    37
    7
    0
    #13 AmigaUser, Nov 11, 2012
    Last edited: Nov 11, 2012
    Can't make this work on Windows 8 x64 (x86 Office). Also tried with "Program Files (x86)". Anyone tried it on 8?
     
  14. sludge705x

    sludge705x MDL Novice

    Apr 27, 2013
    1
    0
    0
    #14 sludge705x, Apr 27, 2013
    Last edited: Jun 15, 2013
    04/27/13 . . . The above registry switches don't seem to work in Win 8, any idea why? . . . Also, what would it be for Publisher 2010?

    06/15/13 . . . I got them to work for Excel, Word, and Power Point

    06/15/13 . . . I still haven't figured out, or found out, what the switch is for Publisher 2010
     
  15. neosea

    neosea MDL Novice

    May 22, 2013
    1
    0
    0
    Is there a way to disable splash for outlook 2010, having it run minimized in the tray from the beginning?
     
  16. tomson

    tomson MDL Novice

    Apr 7, 2013
    47
    4
    0
    #16 tomson, May 25, 2013
    Last edited: May 25, 2013
    I have Office 2013 x64 (Volume License) and Windows 8 x64 Pro
    I just tried for Word and it's really, really, really, really very fast to open an DOCX.... The NEW command are:

    for .DOCX
    JUST in [HKEY_CLASSES_ROOT\Word.Document.12\shell\Open\command]
    add /q before /n (maybe you have other characters - I use Office PT-BR)
    yh1BV5!!!!4!!!!MKKSkWORDFiles>Y=)}K~~b,A1,ZS2CFe9Y /q /n "%1" /o "%u"

    You DO NOT need change the Defaut Value ("C:\Program Files\Microsoft Office 2013\Office15\WINWORD.EXE" /n "%1" /o "%u")
    Just COMMAND, as I mentioned above

    to Open .DOC without Splash Screen I used:
    add /q before /n in:
    [HKEY_CLASSES_ROOT\Word.Document.8\shell\Open\command]
    yh1BV5!!!!4!!!!MKKSkWORDFiles>Y=)}K~~b,A1,ZS2CFe9Y /q /n "%1" /o "%u" (maybe you have other characters - I use Office PT-BR)

    My wife has Office 2013 x86 Retail and Windows 8 Pro
    and in her computer the [HKEY_CLASSES_ROOT\Word.Document.8\shell\Open\command]
    is different of mine...... But just put the /q before the /n thats
    works
     
  17. AmigaUser

    AmigaUser MDL Novice

    Oct 30, 2012
    37
    7
    0
    #17 AmigaUser, May 25, 2013
    Last edited: May 25, 2013
    Thanks a lot tomson, your tip works for Office 2010, too! I hate 2013, the font display quality is unacceptable (new Win 8/IE 10 rendering).

    It shouldn't be hard to find the values for Excel etc. extensions.
     
  18. Goldalex2010

    Goldalex2010 MDL Novice

    Sep 23, 2018
    1
    0
    0
    please how to do that I don't know about registry editor
    I have win 7 64 and office in program files (86x)
    thanx in advance
     
  19. dzem

    dzem MDL Junior Member

    Oct 15, 2015
    85
    11
    0
    What commands would be for word 2016? and place for changing it?