[DISCUSSION] Patch WMC to run on Windows 10 final & possible alternatives

Discussion in 'Windows 10' started by ricktendo64, May 8, 2015.

  1. T-S

    T-S MDL Guru

    Dec 14, 2012
    3,988
    1,323
    120
    Just read few messages back we discussed the most common ways to fix this kind of problems.

    Would be pointless to start over.

    Anyway in your case could be just some leftover from win8. so I would install the v8 and uninstall it to cleanup the leftovers.
     
  2. crash2009

    crash2009 MDL Expert

    Dec 8, 2015
    1,368
    198
    60
    I could be wrong about this, but I thought it was written here somewhere that WMC needs to be un-installed/removed from Win8.1 prior to upgrading to Win10.
     
  3. phrunt

    phrunt MDL Addicted

    May 1, 2007
    898
    90
    30
    I installed V12 over an 8.1 inplace upgrade and it failed the first attempt, I just rebooted and tried again and it worked. I didn't do any uninstalls or anything, just installed it.
     
  4. T-S

    T-S MDL Guru

    Dec 14, 2012
    3,988
    1,323
    120

    Normally it needs just to reset the config data IF wmc won't start because the settings weren't migrated correctly.

    The installation of the program itself usually is not a problem
     
  5. originalsnuffy

    originalsnuffy MDL Novice

    Sep 21, 2009
    1
    0
    0
    The link for Digital Cable Advisor does not work.
     
  6. Fudsey

    Fudsey MDL Novice

    Dec 12, 2015
    41
    0
    0
    I have tried everything short of a fresh install to get this working again. What I don't understand is why v.11 will install without a hitch, but v.12 will not. I can't get 11 working as it will not download TV Setup which is what I believe 12 would do as well.

    I think I am done trying to get this to install and I will use my laptop to record the shows and then migrate them to main computer for conversion to watch.

    A fresh install would take me days to complete and I don't have the time to mess with that right now.

    Thanks to everyone that tried to help with suggestions and tips ! !
     
  7. Fudsey

    Fudsey MDL Novice

    Dec 12, 2015
    41
    0
    0
    Alright I am just going to post this....

    I figured I would try v.11 one last time for S&G, and low and behold it installed and downloaded TV Setup and is now working...

    I am going to leave it as is for now and see if any updates may or may not affect it. This computer is seriously F-ed up and needs work...

    Thanks again everyone who helped.
     
  8. Dragonwyntir

    Dragonwyntir MDL Novice

    Apr 24, 2016
    10
    0
    0
    Hello all,

    I nuked my Win10 PC and started over with a clean v12 install. DRM works great! But no EPG (same issue covered elsewhere in this thread). I uninstalled, put on v11, no good, went back to v12, no good, uninstalled, put on v8, and still no good. Hosts file changes didnt help.

    I'm happy to nuke the PC again, buy I can't scientifically figure out if that would help. Any thoughts anyone?
     
  9. Dragonwyntir

    Dragonwyntir MDL Novice

    Apr 24, 2016
    10
    0
    0
    #4711 Dragonwyntir, May 25, 2016
    Last edited: May 25, 2016
    (Sorry, last one was v10, not v8 - I can't actually find a valid link for v8).
     
  10. Fudsey

    Fudsey MDL Novice

    Dec 12, 2015
    41
    0
    0
    Go back a page or 2 and look for user crash2009, he has a link for 8 in his sig.
     
  11. phrunt

    phrunt MDL Addicted

    May 1, 2007
    898
    90
    30
    has anyone encountered a problem when you go to my videos and it comes up blank even though you've got stored folder locations on a network share in there, once it even said a file/service isn't available to perform this function, it keeps happening to me randomly, then i reboot and they come back.
     
  12. Dragonwyntir

    Dragonwyntir MDL Novice

    Apr 24, 2016
    10
    0
    0
    Hi Fudsey, that link doesn't seem to yield the v8 build. Does anyone have a mega link?
     
  13. T-S

    T-S MDL Guru

    Dec 14, 2012
    3,988
    1,323
    120

    Unchheck the "use our download manager"
     
  14. Fudsey

    Fudsey MDL Novice

    Dec 12, 2015
    41
    0
    0
    That sounds like a network issue and I have had similar in the past but don't think I ever solved it. I have network issues all the time with sharing and then not being able to connect to the shared folder "You don't have permission to access this folder".
     
  15. phrunt

    phrunt MDL Addicted

    May 1, 2007
    898
    90
    30
    nah, its a mce problem for sure, outside of mce the shares work perfectly. mce did pop up with an error once about a service not working, now it just regularly doesnt show the shares until i reboot
     
  16. soitam

    soitam MDL Novice

    May 24, 2016
    2
    0
    0
    Error: 267 The directory name is invalid - solution

    Just a quick note for anyone reading this thread who has the "Error: 267 The directory name is invalid" issue.

    While it is possible that MWC needs to be removed prior to updating from Win8.1 to Win10, I had not done that and in hindsight would not follow that path.
    I followed all the advice and tried all the workarounds that I could find with no luck when I decided to hit the problem with a bigger hammer.

    My steps were;
    1. Create a Win10 recovery USB including the windows files, using the problematic machine.
    2. Reboot the machine off the newly created memory stick and select, reset the computer using the keep my files option.
    3. After the Win10 installation has completed, make sure all windows updates have applied and boot the machine.
    4. Run Version 12 using the instructions supplied.

    Installation was successful 1st time through with no issues, happy days.
    I was also glad to find that all my WMC content, libraries, playlists and configuration from my Win8.1 installation was still intact, even happier days.

    So if anyone has spent a week or two wrestling with Windows and workarounds without success, then this solution might help you through.

    Thanks everyone
    SOITAM
     
  17. FooBerry

    FooBerry MDL Novice

    Aug 17, 2009
    4
    0
    0
    I have seen this problem with windows 7 MCE. It is not a problem that is unique to to these versions for windows 10.
     
  18. T-S

    T-S MDL Guru

    Dec 14, 2012
    3,988
    1,323
    120

    There is a storage recovery task. I never used it but I think is there for cases like yours.