[DISCUSSION] Patch WMC to run on Windows 10 final & possible alternatives

Discussion in 'Windows 10' started by ricktendo64, May 8, 2015.

  1. Paul1965

    Paul1965 MDL Member

    Dec 3, 2013
    101
    6
    10

    Actually I didn't even have to reboot. Just ran the uninstaller first, then re-ran the installer and now it works! :clap:
     
  2. throbber

    throbber MDL Addicted

    Mar 13, 2008
    585
    32
    30
    will this work on Build 10532...or just the rtm 10240??
     
  3. Paul1965

    Paul1965 MDL Member

    Dec 3, 2013
    101
    6
    10
    An interesting note on the EPG: when I enter my zip and click next, I get an error saying the EPG can't be downloaded now due to previous download failures and to check the log. How can there have been previous download failures when MC was never run on W10?
     
  4. DavidinCT

    DavidinCT MDL Senior Member

    May 9, 2015
    488
    77
    10
    Yep, I had run the registry command before and manually copied files over for testing, I ran into the same error as Paul1965 did. I ran the Uninstall, Rebooted (services were marked to be deleted) and ran Install again, and Windows Media Center is running on Windows 10 !

    Thanks to all who helped make this happen !

    This is AWESOME ! Now to test with some tuners and we'll see where we go from here...
     
  5. mondajas

    mondajas MDL Novice

    May 4, 2008
    5
    1
    0
    Any build for spanish users... the languaje of UI is english, or how we can change the language?
     
  6. abbodi1406

    abbodi1406 MDL KB0000001

    Feb 19, 2011
    10,046
    38,848
    340
    Actually, it's better not to use inner .bat files directly, always use the outer .cmd scripts to grant the proper rights :)
     
  7. craftbrewer

    craftbrewer MDL Senior Member

    Jul 30, 2009
    274
    142
    10
  8. T-S

    T-S MDL Guru

    Dec 14, 2012
    3,988
    1,321
    120
    read few messages starting from #438
     
  9. dejong12

    dejong12 MDL Member

    Jan 4, 2009
    170
    100
    10
    I meant the .cmd one, my fault.
     
  10. T-S

    T-S MDL Guru

    Dec 14, 2012
    3,988
    1,321
    120
    #511 T-S, Sep 5, 2015
    Last edited: Sep 5, 2015

    had that behavior on some machines in the past days, noticed that the faster way to fix it was to open manually an administrator prompt and launch the script there, instead of just clicking on the cmd

    Not sure why that behavior varies on different machines.
     
  11. abbodi1406

    abbodi1406 MDL KB0000001

    Feb 19, 2011
    10,046
    38,848
    340
  12. Paul1965

    Paul1965 MDL Member

    Dec 3, 2013
    101
    6
    10
    Ran the MC Recovery Task and rebooted, still won't download the guide due to previous downloading failures. Has anyone else seen this issue?
     
  13. T-S

    T-S MDL Guru

    Dec 14, 2012
    3,988
    1,321
    120

    IT DOESN'T WORK ! EVEN ON A REAL WMC INSTALLATION, I wrote it maybe ten times since yesterday.
     
  14. phrunt

    phrunt MDL Addicted

    May 1, 2007
    898
    90
    30
    well I thought I'd test out that new installer, I removed my existing working MCE install using the uninstaller.cmd an then rebooted, then I tried to reinstall... It said it installed fine but now I've got the problem so many people get where MCE just won't run, you execute it and nothing happens.
     
  15. Paul1965

    Paul1965 MDL Member

    Dec 3, 2013
    101
    6
    10
    Let's clarify that statement before you keep yelling. Lots of what I saw said it would attempt to download the guide but never actually did. What I AM saying is that I don't even get to that point. Besides, I have 8.1 and MC on my HTPC and it works fine there because I used the fix found elsewhere, so don't tell me it doesn't work.
     
  16. dejong12

    dejong12 MDL Member

    Jan 4, 2009
    170
    100
    10
    Downlading guide doesn't work.
     
  17. T-S

    T-S MDL Guru

    Dec 14, 2012
    3,988
    1,321
    120
    #518 T-S, Sep 5, 2015
    Last edited: Sep 6, 2015
    Speaking about the TV Setup data I did some further investigation

    I installed the files from the build 10051 (which was fully working, TV setup data included), and like on the 10036 the initial wizard waits for the tv data forever.

    I noticed that the problem is mcupdate.exe (it crashes).

    Replacing only that file with the the one from 100134 "fixes" the problem. But that file crashes as well.

    So, to summarize:

    mcupdate.exe from any version capable of getting the tv setup data (and listings) on native installation crashes and hangs the initial wizard, 10036,10061,10051, 9600 <--win 8.1

    mcupdate.exe from any non working version like 10134 or 10135, crashes as well, but doesn't hang the initial wizard. TV setup data aren't received, but an error message is shown, then the tuning starts.

    So, my idea that the culprit was the MS server is likely wrong.

    We have "just" to understand why mcupdate.exe crashes and then use one from an older version.

    I'm, curious to hear the opinion of the .net gurus...
     
  18. T-S

    T-S MDL Guru

    Dec 14, 2012
    3,988
    1,321
    120

    You still missed the point, I tried to clarify further on the previous message.
     
  19. Paul1965

    Paul1965 MDL Member

    Dec 3, 2013
    101
    6
    10
    Thanks for clarifying that I missed your clarification o_O