[DISCUSSION] Patch WMC to run on Windows 10 final & possible alternatives

Discussion in 'Windows 10' started by ricktendo64, May 8, 2015.

  1. Darkhorseman

    Darkhorseman MDL Novice

    Oct 20, 2018
    2
    0
    0
    Hey Guys,
    Long time user righ now I am running a linux backend with myth tv as the server and i have two silicone dust tuners they are the 3 tuner primes To make a long story short I have no problems with this setup but I really miss windows media center as when it was up it worked awesome Now i have the latest windows 10 sitting on my machine here is the problem i am having trying to get it to work with my tuners. I have followed the instructions wmc comes up no problem but when i go to set up livetv it cannot findthe tuners... Thenetwork is right and I can use the homerunapp to work on the machineand stream tv no issues its just i get this no turner available and kicks meback to the main ui thread.. If there is anyone that could help me with this issue it would be greatly appreciated i would love to get mce working again. I have tried the work arounds and i set up my uners as bda and windows media center so i am just not understand why it will not find the tuners any help would be appreciated
     
  2. ktide1

    ktide1 MDL Novice

    Jan 18, 2016
    34
    12
    0
    Long story short: you can't do cablecard on the latest Windows 10 version. Anniversary update and forward breaks WMC for cablecard users IIRC. I believe 1511 is the last version where you could get everything to work on cablecard - it's the one I'm currently using. And you'll have to lock it down - no updates or anything, or else it won't stay working for very long.
     
  3. ktide1

    ktide1 MDL Novice

    Jan 18, 2016
    34
    12
    0
    So far, no.
     
  4. Darkhorseman

    Darkhorseman MDL Novice

    Oct 20, 2018
    2
    0
    0
    Thank you I appreciate the answer.. What a shame Microsoft always seems to take something good and just either screw it up royally or just remove the feature alltogether i rememeber when they removed xbmc from the xbox 360 sickening.. just sickening.. Thank you again for the answers i appreciate it
     
  5. Deihmos

    Deihmos MDL Novice

    Jun 19, 2015
    17
    1
    0
    You guys are crazy. The HDhomerun has an app that works with Windows 10. WMC is dead.
     
  6. Aly

    Aly MDL Member

    Feb 27, 2008
    135
    56
    10
    HD Homerun app has choppy video. Dropped frames.
    WMC TV video is 100% smooth. Perfect framerate.
     
  7. ManS-H

    ManS-H MDL Novice

    Dec 9, 2007
    43
    0
    0
    Thanks, I try it again after a long time.
     
  8. ktide1

    ktide1 MDL Novice

    Jan 18, 2016
    34
    12
    0
    Get back to me when the HDhomerun app will record DRM-protected channels and when it comes with a grid guide instead of that stupid slice guide crap and then we'll talk. WMC may be 'officially' dead, but it's still the only solution that will truly do it all for cablecard and do it well.
     
  9. ricktendo64

    ricktendo64 MDL Expert

    Apr 20, 2008
    1,351
    1,946
    60
    1st post updated with alternative branch installer
     
  10. tannerjim

    tannerjim MDL Novice

    Dec 26, 2015
    5
    1
    0
    I was able to download and install. However, when I attempt to play a recorded TV show, the screen simply goes blank. No video...no audio. Any advise??
     
  11. lachape_one

    lachape_one MDL Novice

    May 17, 2016
    35
    28
    0
    It depends if you uninstall any previous WMC and codecs, and upon Windows version?
     
  12. tannerjim

    tannerjim MDL Novice

    Dec 26, 2015
    5
    1
    0
    Windows is 1803

    I used the uninstalled script. Then the InstallerGREEN.cmd

    Media Center starts up fine...everything works (video's and movie)...except Recorded TV (that I record on an older Win 7 system in garage)
     
  13. lachape_one

    lachape_one MDL Novice

    May 17, 2016
    35
    28
    0
    In C:\Windows\System32 folder, which file version has MSVIdCtl.dll properties?
     
  14. tannerjim

    tannerjim MDL Novice

    Dec 26, 2015
    5
    1
    0
    lachape_one.....

    That did it!! I removed the existing MSVIdCtl.dll and put the one from your install package to C:\Windows\System32

    It now works!! You are the BEST!!! Thank you!!!!!!
     
  15. 019

    019 MDL Novice

    Mar 5, 2016
    4
    2
    0
    This thread helped me a ton so here's some info that maybe will help somebody else.
    This is mostly for google, so here's the...
    TL;DR
    1. if you get the error "Ignoring unknown device" when running "ehprivjob.exe /OCURDiscovery"
    2. Make sure the tuners current IP address matches the ones in the registry key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Media Center\Service\ehPrivJob\LocalPbdaSWTunerDevices]

    More Info:

    I got some Ubiquiti network hardware (Unifi USG, Unifi 8-port switch, Unifi WAP) to upgrade my dying Buffalo wifi router.
    Also have SiliconDust HDHR3-cc tuner with cablecard pulling DRM channels on win10 1511. Everything worked fine with the Buffalo.
    Got everything up and running on the Unifi network but WMC can't see the tuners. "Viewing or Listening Conflict. No tuner available to satisfy the current request"

    1st problem: switched from 192.168.100.xxx to 192.168.1.xxx and windows thought it was a new public network and disabled network sharing, discovery, etc.
    - Fix
    - go to network and sharing center
    - switch network to private
    - go to advanced sharing, turn on network discovery and automatic setup of devices
    - restart computer

    2nd problem:
    - WMC still couldn't see the tuners
    - Fix
    - In Unifi Controller > Settings > Services > enable UPNP

    3rd problem
    - WMC still couldn't see the tuners, sort of.
    - At this point I was fiddling with:
    - c:\windows\ehome\ehprivjob.exe /OCURDiscovery
    - it returned all three tuners but listed each as "Ignoring unknown device 'HDhomeRun Prime Tuner xxxxxxx-0'"
    - Fix
    - Plugged my WMC and SiliconDust tuner into my old router and plugged the router into the Unifi switch and had it double-NAT'd so the main network was in the 1.x subnet and WMC/SD was back in its 100.x subnet
    - Ran OCURDiscovery again... and everything worked..
    - Discovered known device 'HDHomeRun ...
    - But that was lame and that router was dying

    4th problem.. get all the devices on the same network and ditch the old router
    - Fix
    - Plugged WMC/SD back into the network, they got their new IPs
    - Fire up regedit, go to this key:
    - [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Media Center\Service\ehPrivJob\LocalPbdaSWTunerDevices]
    - It was a list of my HDHomerun Prime Tuners
    - Each had a "Host" key with an IP, on the OLD NETWORK.
    - Changed the IP of each tuner to their new IP, and ding!
    - running ehprivjob.exe /OCURDiscovery then returned "Discovered known device 'HDHomeRun ...
     
  16. Bigal

    Bigal MDL Junior Member

    Mar 4, 2011
    79
    8
    0
    Bump

    Anyone??
     
  17. digikeys61trab

    digikeys61trab MDL Novice

    Nov 10, 2018
    3
    0
    0
    Where can I find office 2013 Visio, project, access, outlook (...) all languages in VL Version for MAK Keys?
    Thanks very much.
     
  18. dbDesign

    dbDesign MDL Junior Member

    Oct 8, 2015
    99
    5
    0
    #8979 dbDesign, Nov 18, 2018
    Last edited: Nov 18, 2018
    after updated to 1809 and setup WMC with Live-TV it worked for one evening.
    But after starting up this morning, Life-TV was broken because of issue with codec.
    I tried things like K-Lite Mega CodecPack, Win7DSFilterTweaker, setting codec to MS-Media but nothing works.
    Still notification about video fault
    I had the same going to 1803 but could make it work. Now I'm losing my mind...…….

    ps: off course Microsoft stock DvD-player is installed and I have installed the latest WMC-V8.8.2 version (out off France)
     
  19. Bigal

    Bigal MDL Junior Member

    Mar 4, 2011
    79
    8
    0
    what version, LTSC, home....?