[DISCUSSION] Patch WMC to run on Windows 10 final & possible alternatives

Discussion in 'Windows 10' started by ricktendo64, May 8, 2015.

  1. ktide1

    ktide1 MDL Novice

    Jan 18, 2016
    39
    14
    0
  2. paulsk58

    paulsk58 MDL Novice

    Jan 25, 2009
    30
    4
    0
    #9083 paulsk58, Feb 20, 2019
    Last edited: Feb 20, 2019
    Started to answer but realized you are probably using released version of 1809.

    I have always had better luck with WMC v11 and I have WMC running on 1809 build 17763.316.
     
  3. mmortal03

    mmortal03 MDL Novice

    Feb 4, 2017
    18
    3
    0
    No, he mentioned that, but his issue was that it wasn't working on his machine, even though we know the guide information is still *currently* available.
     
  4. mmortal03

    mmortal03 MDL Novice

    Feb 4, 2017
    18
    3
    0
    Me. I'm on 1803.
     
  5. Bigal

    Bigal MDL Member

    Mar 4, 2011
    138
    9
    10
    Hi pmikep, have you tried redoing "setup tv signal"?
    I am running LTSC, upgraded from LTSB running WMC-V8.8.2 and all was working as it should.
    I was unable to "clear recording schedule" so i uninstalled WMC and then was unable to download the guide.
    After lots of re trying i found doing the following worked.

    when you are doing the configure tuners,tv signal and guide
    after you agree to program guide terms of service you get;
    download failure,
    the new tv setup data could not be downloaded.
    click ok, back and in a command prompt with admin rights run;
    c:\windows\ehome\mcupdate.exe -uf
    and try again
     
  6. Fudsey

    Fudsey MDL Novice

    Dec 12, 2015
    41
    0
    0
    Got a question about a new router and WMC no longer finding HDHomeRun. I installed a new router and my WMC cannot find the HDHomeRun at all. I installed NextPVR and it works and finds the tuner no problem. I am running winver 1511 build 10586.104 and I am unsure where to go from here to get WMC back. I am not a big fan of NextPVR and the way it handles guide and live tv. What am I missing? Or where should I go from here?

    I have run the HDHomeRun software multiple times to no avail.
     
  7. Fudsey

    Fudsey MDL Novice

    Dec 12, 2015
    41
    0
    0
    I guess I need to add that this was working fine with a Buffalo router. Now with this Linksys one, WMC will not find it.

    I spent 2 hours on the phone with Linksys and the tech had no ideas about how to get it to work(just about useless tech)...

    I port forwarded 65001 UDP/TCP, 1900 UDP, 80 TCP and 5000-5005 UDP/TCP with none doing anything.
     
  8. pmikep

    pmikep MDL Novice

    Nov 2, 2018
    4
    0
    0
    #9089 pmikep, Mar 4, 2019
    Last edited: Mar 4, 2019
    I fixed the WMC EPG problem in one of my Win8.1 instances. Turns out it was the nut behind the wheel.

    I had another partition with another Win8.1 and ran that today. The EPG updated fine. (And thanks to @mmortal03 for confirming that it worked on his Win10.)

    Turns out that WMC EPG needs the Windows DHCP Client Service. (Or maybe is dependent on Network Location Awareness, one of the components dependent on the DHCP Client.) I had disabled the Service a while ago, since I don't use DHCP and since I use BIND for a caching DNS resolver.

    But apparently WMC needs DHCP Client Service.

    Sorry for the false alarm.
     
  9. kensiko36

    kensiko36 MDL Novice

    Jul 22, 2017
    8
    1
    0
    Hi all,

    I still use WMC because it feels much more solid and stable and smooth than anything else.

    I didn't use it for a while because of my kids. Now I wanted to make it work again with HDHomeRUN.

    I successfully installed it on 2 of my 3 PC with EPG (using WebGrabPlus and XMLTV2MXF program), everything is almost perfect but I can't go full screen or WMC will freeze. That is one issue.

    The other issue is my 3rd PC. I installed WMC like I did for the other 2 PC on Windows 10 64 bits but in WMC menu, there was only Movies and Tasks. I successfully completed TV setup with the tuner detected, but nothing in menu. After that I messed-up by uninstalling WMC but I did not reboot. I tried to reinstall it, it installs but eshell.exe will start then stop a few seconds later without showing any window or message. I tried several version of the installer. I also had Windows Search service issue that I resolved by changing the SetupCompleted parameter in the registry to 0.

    How can I revert the mess I've done by not rebooting ? I've uninstalled and reinstalled many times with reboot each time, no good.
     
  10. kensiko36

    kensiko36 MDL Novice

    Jul 22, 2017
    8
    1
    0
    Ok here it goes.

    After some more troubleshooting and google search, I stumbled into a guy reporting a crash similar to mine (discovered the crash error in Event Viewer - Related to KernelBase.dll) for Reset Registry Permission program. I decide to give it a go.

    I installed Windows Repair that included this program from MajorGeeks. I ran the scans suggested by the program and ran the repair, but I only selected the Reset Registry Permission. I rebooted, Media Center would not start. I uninstalled WMC with the included Uninstaller for WMC, rebooted, and installed WMC. After that, WMC starts and I have all the menus !!!

    Hopefully it could help someone else. Windows Repair program is pretty amazing!
     
  11. kensiko36

    kensiko36 MDL Novice

    Jul 22, 2017
    8
    1
    0
    Ok so what about the full scree freeze ? It does that on my 3 PCs, running on Windows 10 of course.
     
  12. kensiko36

    kensiko36 MDL Novice

    Jul 22, 2017
    8
    1
    0
    Ok found the solution:
    * Crudely copy the entire "C:\Windows\ehome" folder to "C:\Program Files\ehome", enable the "Disable full screen optimization" flag on "C:\Program Files\ehome\ehshell.exe", and finally make sure that the desktop start shortcut points to "C:\Program Files\ehome\ehshell.exe".

    Now if I run Media center, even from the Windows\eHome folder, the program works well in full screen, but I don't get it.
     
  13. kensiko36

    kensiko36 MDL Novice

    Jul 22, 2017
    8
    1
    0
    Thanks, I'll look into that, but I like the solution in the previous post.

    I've got one last issue, after that I'm good to go. Shows will not record unless I'm in Windows media center and click Record. Everything that is scheduled is not recording. Any idea ? I saw that the Windows Media Center Scheduler Service was set at manual, I've put it to automatic and started it, but it's still not working.
     
  14. jeff2012

    jeff2012 MDL Member

    Mar 31, 2010
    152
    5
    10
    #9096 jeff2012, Mar 8, 2019
    Last edited: Mar 9, 2019
    Hey everyone,

    I have installed WMC on a Win 10 LTSB many times with no errors at all

    This time with a new build and same hardware using v11_7 and then 12_7 version of the installer I am having these issues:

    Digital cable advisor/ Activate digital Cable WILL not launch either from the installer or the gallery, gives an error message saying it cannot be launched it's an invalid application. I even downloaded DCA and ran it then setup again..SAME ERROR

    My system is definitely digital ready since it is identical with hardware to another built unit

    MY cablecard is already binded to my Ceton Host card and diagnostics show nothing wrong ,so that is not an issue

    Never had an issue like this and I am stymied.

    Could MS have done something?

    What gives, what am I doing wrong and what might I try?


    ***EDIT***** Took a ceton with its cable card in an identical unit, put it into the troubled unit, reformatted HD, set up WMC..SAME error

    **EDIT 2*****

    Went back to functioning HTPC CableCard DRM working box..Put in a NEW SSD, ran LTSB 2015, ran WMC 11_7..Same error with DCA.

    Conclusion : On new installs, WMC, once it connects to the net, something is sent which kills Digital cable within WMC.

    Unless someone else using a ceton and Cable card with WMC is able to run DCA, I stand by my claim


    **EDIT 3 SUCCESS*** Downloaded and ran digitalcableadvisoroverride" and it worked....

    What gets me is I never had to do this before and I don't know why now I had to use it now for the first time after scores of WMC installs without it
     
  15. Fudsey

    Fudsey MDL Novice

    Dec 12, 2015
    41
    0
    0
    I have also tried using an older version of HDHomeRUn V. 20150826 and this does the same thing although "Setup TV Signal" now isn't instant like it was with the new ver.

    I could really use some help
     
  16. Fudsey

    Fudsey MDL Novice

    Dec 12, 2015
    41
    0
    0
    Update: Tried installing HDHomeRun ver. 20170815 and this somehow fixed the issue. I thought I had tried this version but obviously I must not have.
     
  17. Quainy

    Quainy MDL Novice

    Mar 12, 2019
    1
    0
    0
    Tuner scan for channels and windows crashes!!!!

    I have just installed windows 10 and tried 8.8.2, my tuner is a kworld usb duel tuner.

    I have gone through the workaround file and a few fix's from this thread, searched but don't seem to find any fix's for crashing when scanning.

    Any ideas guys?
     
  18. ScottinOz

    ScottinOz MDL Novice

    Oct 26, 2016
    2
    0
    0
    Hi guys,
    I've been clinging onto WMC on W10 for a few years now. Recently I was struck by that spinning dots windows upgrade issue where it can't start up. Somehow I got through that but when I got in and tried WMC I got codec errors on everything recorded. New recordings will play correctly but not old ones. In live tv sometimes a codec error appears then the program plays. The thing is I can play these old .wtv files in media player, just not in WMC.

    It is also failing to fast forward recorded tv sometimes and then not playing after skipping forward. Have to stop then resume.

    I've tried multiple codec packs (shark, klite, ffdshow), I've reinstalled WMC but nothing fixes the codec issue. Is there an old codec app that specifically targets WMC codecs maybe?

    Thanks for any suggestions.

    Scott.