[DISCUSSION] Patch WMC to run on Windows 10 final & possible alternatives

Discussion in 'Windows 10' started by ricktendo64, May 8, 2015.

  1. j.c.f.

    j.c.f. MDL Member

    Mar 1, 2016
    102
    9
    10
    I investigated using WMC on the win7 Virtual Box VM I use for testing my software and found that it wouldn't play back stuff recorded with 8.8.1 so I'm guessing at the very least you're looking at using a win8 VM and it's version of WMC.
     
  2. Randysl

    Randysl MDL Novice

    Jul 18, 2020
    2
    0
    0
    I update from Windows 7 SP1 to Windows 10. I want to install Window Media Center. I downloaded it from WMC64 zip file

    Per the steps in the above site I

    1. Ran _TestRights.cmd as the Administrator
    2. Ran Install.cmd as the Administrator

    When running the Installer.cmd I get the below error


    Prepare...

    Install DISM packages...

    Deployment Image Servicing and Management tool
    Version: 10.0.19041.329

    Image Version: 10.0.19041.388

    Processing 1 of 1 - Adding package Microsoft-Windows-MediaCenter-Package~31bf3856ad364e35~amd64~~6.3.9600.16384
    [==========================100.0%==========================]

    Error: 0x800f081e

    The specified package is not applicable to this image.

    The DISM log file can be found at C:\WINDOWS\Logs\DISM\dism.log


    Installing package failed, reverting...

    You may reboot and try again
    refer to C:\Windows\Logs\CBS\CBS.log to find error details

    Press any key to exit.

    Any suggestions for what I need to do to get Windows Media Center installed?
     
  3. Shortyportuguese

    Shortyportuguese MDL Member

    Apr 3, 2019
    148
    39
    10
    How do you made to got the latest software of TVCenter? I have a license key that comes with my card, v6.4.9 -> Can you please give me the step by step of how to get it?
    Thanks in advance
     
  4. j.c.f.

    j.c.f. MDL Member

    Mar 1, 2016
    102
    9
    10
    Use Kevin's 8.8.4 installer (WMC-V8.8.4.zip) and use Technodevotee's fix_MSSQLLite package (fix_mssqllite.zip).
     
  5. Randysl

    Randysl MDL Novice

    Jul 18, 2020
    2
    0
    0
    I downloaded VMC-V8.8.4.Zip and extracted the files. Installed WMC successfully and then downloaded fix_mssqllite.zip. Extracted this to the same folder I extracted VMC-V8.8.4.Zip files to. I ran fix_MSSQLLite.cmd as the administrator. The command prompted and closed. I am not sure if it really installed anything. Do you have any ideas what we can try next
     
  6. j.c.f.

    j.c.f. MDL Member

    Mar 1, 2016
    102
    9
    10
    I believe that tool has be executed with the NSUDO rights that _TestRights.cmd gives you.
     
  7. technodevotee

    technodevotee MDL Senior Member

    Sep 18, 2015
    412
    71
    10
    #10168 technodevotee, Jul 19, 2020
    Last edited: Jul 19, 2020
    No, it just needs to be in the right place because it uses NSUDO, which is in the bin folder.

    Unzip it into the installer folder so that all the CMD files are in the same folder and all the BAT files are in the folder below.
     
  8. GREBERT

    GREBERT MDL Novice

    Apr 1, 2019
    49
    2
    0
    CELUI QUE TU POSSÈDE ET DÉJÀ LA DERNIÈRE VERSION DISPONIBLE IL MON DONNER LA 6.4.9.1033
     
  9. Herberton

    Herberton MDL Novice

    Apr 17, 2020
    6
    0
    0
    Hey, last night I just update my computer to, "Feature update to Windows 10, version 2004", and WMC is no longer working, I've tried with all of the "know issues" soultions which come with, technodevotee's, "WMC-V13_x64", and "WMC_Multi_Tool", and "roll_back_dlls", and it hasn't worked, and I tried uninstalling the update, and it said that it uninstalled, but it hasn't and it doesn't let me uninstall it again, anyone have a solution?

    They would be greatly appreciated.
     
  10. technodevotee

    technodevotee MDL Senior Member

    Sep 18, 2015
    412
    71
    10
    Please provide additional details of your problem - it doesn't work isn't much to go on.
     
  11. Herberton

    Herberton MDL Novice

    Apr 17, 2020
    6
    0
    0
    #10172 Herberton, Jul 24, 2020
    Last edited: Jul 24, 2020
    Hello, like what kind of information do you need?

    Well, the Tuner I'm using is "WinTV-HVR-850" model "1200", from "Hauppauge!", and I'm viewing TV through Over the Air (OTA) signal.
    The WMC installation package I used is, your "WMC-V13_x64", and when I first installed it, there was the "all tuners being in use", error, so I ran the "MsVidCtl.dll" and it fixed it, that was the only problem I had before, with the problem that I have now I tried running, "fix_MSSQLLite.cmd", "replace_dlls.cmd", and "reset_security_tokens.cmd", and I also tried uninstalling it and reinstalling it, all from the "WMC-V13_x64" package, then with the "WMC_Multi_Tool" I tried the "CpFilters.dll", and "MSSQLLite" fix again, and lastly I tried the "roll_back_dlls", and I tried all of this with them being directly in the "(C)" Drive, with a short path and no spaces, like it said in the instructions they came with.

    When I installed the windows update, which is when it stopped working, I left it running at night, and when I woke up it was still running and took like two more hours, so like 10 hours in total, and I don't know what version or update was the previous one, nor how to check it, if it's useful.

    Other video viewing programs I have installed, (incase it matters) are, "Kodi v18.6 - Leia", "VideoLAN - VLC media player 3.0.11 Vetinari", "MediaPortal 1 and 2" and, "NextPVR", I only used WMC and VLC, the other ones I installed them when I was trying to find one to do what WMC did, until I found WMC for Windows 10.

    Is there any other information that might be useful, (if this was useful at all)?

    Sorry if it's not well laid out or ordered
     
  12. technodevotee

    technodevotee MDL Senior Member

    Sep 18, 2015
    412
    71
    10
    In what way is it not working?

    Is it not starting, not finding tuners, not finding programmes, not playing tv?
     
  13. Herberton

    Herberton MDL Novice

    Apr 17, 2020
    6
    0
    0
    Oh, sorry.

    It doesn't start at all, I looked on Task Manager, and it appears for a moment with the green WMC logo in the, "Background processes" section, and then another task with the same "Windows Media Center" name appears, but without the logo, and then the logo one disapears, and it stays like that.
     
  14. technodevotee

    technodevotee MDL Senior Member

    Sep 18, 2015
    412
    71
    10
    Sounds like you need to run fix mssqllite.cmd and reboot the pc.

    I assume you uninstalled and reinstalled WMC after the upgrade?

    If you downloaded WMC a while ago, it might be worth downloading it again as there have been a few minor tweaks.
     
  15. Herberton

    Herberton MDL Novice

    Apr 17, 2020
    6
    0
    0

    Ok, thank you, I'll try it right now.

    Yes, I did uninstall and reinstall after the upgrade.
     
  16. Herberton

    Herberton MDL Novice

    Apr 17, 2020
    6
    0
    0
    Thank you!

    It's working now.
     
  17. technodevotee

    technodevotee MDL Senior Member

    Sep 18, 2015
    412
    71
    10
    This mssqllite thing started appearing back in September but it doesn't seem to have had much 'PRESS' because it has caught a few people out.
     
  18. Joni

    Joni MDL Novice

    May 28, 2009
    26
    2
    0
    #10179 Joni, Jul 29, 2020
    Last edited: Jul 29, 2020
    Thank you. Just updated from 1803 to 2004 to see if it works and I had this same problem.
     
  19. Joni

    Joni MDL Novice

    May 28, 2009
    26
    2
    0
    #10180 Joni, Jul 29, 2020
    Last edited: Jul 29, 2020
    Edit: Nm, found the channels now.