[DISCUSSION] Patch WMC to run on Windows 10 final & possible alternatives

Discussion in 'Windows 10' started by ricktendo64, May 8, 2015.

  1. omenchild

    omenchild MDL Novice

    Aug 23, 2021
    2
    0
    0
    please give workinf links to patches for xbox360 extender
     
  2. technodevotee

    technodevotee MDL Senior Member

    Sep 18, 2015
    475
    87
    10
  3. omenchild

    omenchild MDL Novice

    Aug 23, 2021
    2
    0
    0
  4. dafob

    dafob MDL Novice

    Feb 10, 2008
    33
    42
    0
    Stupid me should've read the Workarounds.txt file. It clearly states that Decoder errors may be fixed by downloading and installing the LAV filters. Sure enough, after installing the LAV filters live TV works again on my Win11 install!
     
  5. lburgguy

    lburgguy MDL Novice

    Nov 14, 2019
    4
    1
    0
    Greetings all! So quick question: I've been running version 6.3.9600.16384 for a few months now with great success. All of a sudden, I get ZERO signal strength and no ability to view a certain channel and its sub-channels in WMC. I see that I have perfect signal strength using my TV input as I have the cable split into two signals - one to the tuner card, one to the tv. It was such an abrupt problem and rescanning the channels a few times never "found" the missing channels although they were there all along. Is it possible PlayReady has something to do with this? A network enabling this for certain shows? Other than this, I can't figure my problem out at all. Now, this morning, I am once again receiving the channels in WMC but like I said, the signal did not go anywhere as it had great signal strength coming out of the splitter to the tv. I made NO changes to anything hardware or software or cable-wise to precipitate this problem. Thanks, I'm hoping someone can help me figure this out.
     
  6. j.c.f.

    j.c.f. MDL Member

    Mar 1, 2016
    113
    9
    10
    Anyone else tried 21H2 yet? Just applied it to the sacrificial laptop and because it's a half update I figured I wouldn't have to remove WMC and sure enough it wasn't removed however WMC just exits. Figured it was because that machine was using 8.8.4 so it needed the fix_sqlite but that didn't change anything so I'm like OK, pull out the big guns so I copied 8.8.5 to it, uninstalled the old WMC and reinstalled but same O lack of running. I may have gotten it's knickers in a twist by not restarting it like a religious mofo between each step so that avenue remains to be explored but if something else is brewing it'd be nice to know if someone else has been there done that.
     
  7. rhahgleuhargh

    rhahgleuhargh MDL Member

    Feb 9, 2015
    136
    41
    10
    #10409 rhahgleuhargh, Nov 27, 2021
    Last edited: Nov 27, 2021
    @j.c.f.
    No problem here with 21H2 and 8.8.5, updated from 21H1 via Windows Feature Update without need of uninstall/reinstall (I only do this for a complete upgrade from an older Windows version). I didn't test all features of WMC since I only use it for watching Live Digital TV.
    NB : I didn't test with a clean install.
     
  8. j.c.f.

    j.c.f. MDL Member

    Mar 1, 2016
    113
    9
    10
    Thanks. Weird, this morning when I used resetsettings WMC did indeed run on that machine, I restored some older settings from the last major win10 upgrade and it's all hunky dory. Guess trying to save settings after a minor win10 upgrade corrupts the things somehow so you should always save settings before the update.
     
  9. DavidXP

    DavidXP MDL Novice

    Jul 4, 2020
    3
    0
    0
    I am a long time user of WMC in New Zealand (since XP days) and I still run a windows 7 machine to support this. However, it is getting old and would be good to update to win10. I have tried to install WMC 8.8.5 package on a win10 machine, and while it installs without problems, nothing happens when I start WMC. That is, no error message or anything else. Workarounds.txt suggests running the reset script which I have done. I have tried it all using administrator privileges, re-booting etc, but have never got it to start.
    Does anyone have suggestions or can provide a fuller explanation of why WMC does not start?

    Thanks
    David

    Edition Windows 10 Pro
    Version 21H1
    Installed on ‎04/‎07/‎2020
    OS build19043.1348
    Experience Windows Feature Experience Pack 120.2212.3920.0
    WMC V8.8.5
    Hauppauge WinTV-quadHD
     
  10. kensiko36

    kensiko36 MDL Novice

    Jul 22, 2017
    14
    1
    0
    It probably crashed, you can have a look at the event viewer, it could give a hint on the solution
     
  11. technodevotee

    technodevotee MDL Senior Member

    Sep 18, 2015
    475
    87
    10
    It is not clear from your post exactly what you tried with administrator privileges.

    Have you tried running the WMC shortcut as administrator?

    I've had to do that a few times on a new installation.
     
  12. DavidXP

    DavidXP MDL Novice

    Jul 4, 2020
    3
    0
    0
    I used administrator priv for the install, for resetSettings.cmd, and to run the WMC shortcut.

    Having checked the events viewer, the following looks like the most relevant error. Some sort of SqlLite error, but beyond my area of knowledge.

    Thanks for any help.

    Cheers
    David.

    +
    System
    -
    Provider
    [ Name] .NET Runtime
    - EventID 1026
    [ Qualifiers] 0
    Version 0
    Level 2
    Task 0
    Opcode 0
    Keywords 0x80000000000000
    - TimeCreated
    [ SystemTime] 2021-12-08T09:59:48.2551553Z
    EventRecordID 120927
    Correlation
    -
    Execution
    [ ProcessID] 0
    [ ThreadID] 0
    Channel Application
    Computer ELL
    Security
    -
    EventData
    Application: ehshell.exe Framework Version: v4.0.30319 Description: The process was terminated due to an unhandled exception. Exception Info: System.InvalidOperationException at MediaCenter.Store.SqlLite.SqlLiteErr.LogAndThrowException(Int32, System.String, System.Object[]) at MediaCenter.Store.SqlLite.ObjectStore.Open(System.String) at MediaCenter.Store.SqlLite.ObjectStoreManager.Open(System.String, Boolean) at Microsoft.MediaCenter.Store.ObjectStore.Open(System.String, System.String, System.String, System.Reflection.Assembly, Boolean) Exception Info: System.InvalidOperationException at Microsoft.MediaCenter.Store.ObjectStore.Open(System.String, System.String, System.String, System.Reflection.Assembly, Boolean) at Microsoft.MediaCenter.Store.ObjectStore.Open(System.String, System.String, System.String, Boolean) at Microsoft.MediaCenter.Store.ObjectStore.AddObjectStoreReference() at Microsoft.MediaCenter.Store.ObjectStore.get_DefaultSingleton() at ServiceBus.UIFramework.UserControlPoint.Launch(System.String)
     
  13. acer-5100

    acer-5100 MDL Addicted

    Dec 8, 2018
    674
    444
    30

    Nothing happens = corrupt data in \programdata\microsoft\eHome (the old config from win7)
    Just launch the wmc recovery task to cleanup it
     
  14. Kévin Chalet

    Kévin Chalet MDL Junior Member

    Apr 11, 2019
    54
    59
    0
    This sounds a lot like the removal of the MSSQL APIs from recent Windows 10 builds the 8.8.5 installer tried to address. Can you try to manually apply RestoreSqlCe.reg - you can find it in the the bin folder of the installer - and restore the 4 sql* DLL present in bin\MediaCenter\Windows\System32 to see if it helps?
     
  15. DavidXP

    DavidXP MDL Novice

    Jul 4, 2020
    3
    0
    0
    Thanks all for your suggestions. Kévin's answer did the trick. I manually applied RestoreSqlCe.reg then copied the four sql* DLL files to %SystemRoot%\System32\ and it all works. Now I just need to dredge my memory of a decade ago and set up EPGCollector again to get the MHEG5 program guide.

    Cheers
    David
     
  16. mashakos

    mashakos MDL Novice

    Sep 10, 2015
    1
    0
    0
    #10418 mashakos, Dec 24, 2021
    Last edited: Dec 25, 2021
    WMC seek bar with video files (mkv,mp4,wmv) is non functioning on my rig. Win10 1809
    EDIT: Where can I find the latest version? All the links in the main page are dead. I am on 8.8.5 now
    Upon a whole lot of trial and error testing I discovered that if I:
    - Play a video
    - Stop it
    - Play it again

    The playback bar can be dragged with the mouse, lay time is no longer 0:00 and I can seek / rewind / ff. The seek bar doesn't track playback time, it sort of stays frozen where it is. You can drag it to skip through a video but it no longer "plays" or tracks current playback time.

    Only repeating the above steps once makes the seek bar semi functional for the duration I have WMC running. Once I close it and open it again the issue returns
     
  17. technodevotee

    technodevotee MDL Senior Member

    Sep 18, 2015
    475
    87
    10
    8.8.5 is the current version

    no idea about the issue you have though - sorry
     
  18. test10

    test10 MDL Novice

    Apr 13, 2015
    17
    5
    0
    The file playback issues you describe are long standing issues that have existed since WMC was introduced in Windows XP Pro.