Driver bug.

Discussion in 'Windows 10' started by Insanegamer1996, Nov 16, 2020.

  1. Insanegamer1996

    Insanegamer1996 MDL Junior Member

    Oct 22, 2019
    96
    4
    0
    Why is there part of my chipset drivers that claim there is no driver installed even tho there is a driver installed? I just found out by checking general tab in each chipset driver. For example: A143 (this device is working properly), A114 (this device is working properly), A121 (there are no drivers for this device), A123 (there is no driver for this device), A131 (there is no driver for this device), 1911 (there is no driver for this device).


    Is this visual bug or something is broken even tho when checking driver tab it is there ?
     
  2. kaljukass

    kaljukass MDL Guru

    Nov 26, 2012
    2,303
    811
    90
    The biggest mistake is that no one understands anything if they only read some A123, A143, and so on.
    First, specify what these strange codes mean, which computer and which version it is, and which driver has the problem. You can also add a screenshot of your Device Manger's yellow-marked devices.
    Some of them may be not available if You uses search, but they are available on computer producer site. Some devices may be preinstalled to some computers, but after clean install it may lost and You need to reinstall it manually etc.
    On some computers really works most of generic drivers, but some need their own drivers made by this device producer or by the used computer producer.
    So, if You need help, give more correct info.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Insanegamer1996

    Insanegamer1996 MDL Junior Member

    Oct 22, 2019
    96
    4
    0
    Photo uploaded. Just 2 chipset drivers report proper work. Rest says there is no driver installed even tho there is driver.
     

    Attached Files:

  4. Carlos Detweiller

    Carlos Detweiller MDL Spinning Tortoise

    Dec 21, 2012
    4,145
    4,002
    150
    If there are no errors (yellow or red), this is mostly normal. Not every device actually requires a driver to function. Especially system devices are often controlled by the BIOS or UEFI firmware.

    The Intel devices you mention in the picture are only sub-devices or sub-features of the main Intel one. As long as the main Intel device (the graphics card) has the proper driver installed, the sub-devices just use that same driver (or don't require any).

    As a rule of thumb: If a device does not request a driver it will work as-is. Missing drivers are clearly requested or installed automatically.
     
  5. pm67310

    pm67310 MDL Senior Member

    Sep 6, 2011
    340
    119
    10
    No error your computer works correctly
     
  6. Insanegamer1996

    Insanegamer1996 MDL Junior Member

    Oct 22, 2019
    96
    4
    0
    There is no errors but a visual bug that should not be there. Either device is working and have driver or not. There should not be situation where device is working but reports that is has no driver.
     
  7. kaljukass

    kaljukass MDL Guru

    Nov 26, 2012
    2,303
    811
    90
    • Please show us where you have this problem.
    • Nothing else can be said until have seen it.
    • Personally, I have never seen such a situation.
    • Also show us the message you see. Put a picture of it here.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. Insanegamer1996

    Insanegamer1996 MDL Junior Member

    Oct 22, 2019
    96
    4
    0
    Its literally 3 posts above and hanging there for 2 days.
     
  9. kaljukass

    kaljukass MDL Guru

    Nov 26, 2012
    2,303
    811
    90
    I can't find any problems there, nor are there any error messages - at least I can't find. Maybe I'm blind.
    I hope those people help who have better eyesight.
    Or are you just bored and want someone to talk to you something?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. Insanegamer1996

    Insanegamer1996 MDL Junior Member

    Oct 22, 2019
    96
    4
    0
    You must be kidding. The window shows the state of device. Even tho the drivers are installed only 2/6 report proper work which is "This device works properly" which in polish means "to urzedzenie dziala poprawnie" and 4/6 report "there is no driver installed for this device" in polish "brak zainstalowanych sterownikow dla tego urzadzenia" even tho there are drivers.
     
  11. Mr.X

    Mr.X MDL Guru

    Jul 14, 2013
    7,067
    14,695
    240
    This f is trying to bring attention. Just that. He's a internet troll.

    :tooth:
     
  12. MS_User

    MS_User MDL Guru

    Nov 30, 2014
    3,848
    844
    120
    how about posting a bigger clearer pic and one thats in english:rolleyes:
     
  13. Mr.X

    Mr.X MDL Guru

    Jul 14, 2013
    7,067
    14,695
    240