Dude, this System Restore!

Discussion in 'Windows 8' started by sunesio, Sep 15, 2013.

  1. sunesio

    sunesio MDL Novice

    Aug 31, 2013
    30
    7
    0
    #1 sunesio, Sep 15, 2013
    Last edited: Sep 15, 2013
    I turn it off and after some time it gets enabled again.
    I hate it when Windows wants to dictate me that i need that s**t.
    I miss the days without any "security options" so that i could do whatever i want without
    notices, accepting uac bulls**t, run as admin, even run notepad as admin to edit host file, it just
    goes in the wrong way and now please don't tell me that it makes my windows way more secure.
    Okay, sorry, i'm not actually here for a rant but it was appropriate. :D

    Any method to turn System Restore off completely?
    I could disable the Volume Shadow Copy service, but that feels kind of dirty.
     
  2. sunesio

    sunesio MDL Novice

    Aug 31, 2013
    30
    7
    0
    Ofc, that's the way. I think it could have something to do with either windowsupdates (after installing) or another function somewhere in windows, like if it has been opened, windows sends a command to enable it again for whatever reasons.
    Maybe a bug, i don't know and i wasn't to be able to find the other exact window which is responsible for this behavior.
     
  3. abbodi1406

    abbodi1406 MDL KB0000001

    Feb 19, 2011
    7,863
    25,842
    240
    #4 abbodi1406, Sep 15, 2013
    Last edited by a moderator: Apr 20, 2017
    -Registry:
    Code:
    Windows Registry Editor Version 5.00
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\SystemRestore]
    "RPSessionInterval"=dword:00000000
    "SRInitDone"=dword:00000001
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\SystemRestore\Setup_Last]
    "Unattend_DisableSR"=dword:00000001
    
    
    -TaskScheduler:
    run in elevated cmd:
    Code:
    SCHTASKS /Change /TN Microsoft\Windows\SystemRestore\SR /DISABLE
    -GroupPolicy:
    Code:
    Run: gpedit.msc
    goto:
    Computer Configuration> Administrative Templates > System > System Restore
    At right pane, double-click "Turn off Configuration".
    Select "Enabled".
    Double-click "Turn off System Restore".
    Select "Enabled"
     
  4. WinDev

    WinDev MDL Expert

    Jul 6, 2013
    1,170
    1,007
    60
    Try restore a system on one date, then try turn off System Restore.
     
  5. Espionage724

    Espionage724 MDL Addicted

    Nov 7, 2009
    902
    255
    30
    I disable it from System Properties, and then disable the Volume Shadow Copy service. I assume this disables System Restores from being created since I can't even access the settings page for it anymore without error...

    Still though, it's pretty annoying. I know in Windows 7, once I disabled it, it remained disabled. Windows 8 on the other hand, it just seemingly randomly re-enables itself...
     
  6. Enigma256

    Enigma256 MDL Senior Member

    Jan 17, 2011
    354
    300
    10
    #7 Enigma256, Sep 17, 2013
    Last edited: Sep 17, 2013
    Don't use a bludgeon when a scalpel will do: There is only ONE thing that you need to do:

    Set "Turn off System Restore" in the Group Policy (gpedit.msc). That's all you need to do.

    No other registry changes. No need to set "Turn off configuration". No need to bother with Shadow Volume Copy. Everything else is superfluous.

    This will prevent the creation of any restore points, and even if it still might say "On" in the system properties, SR will be off if you set this.
     
  7. Mr Jinje

    Mr Jinje MDL Expert

    Aug 19, 2009
    1,773
    1,086
    60
    #9 Mr Jinje, Sep 17, 2013
    Last edited by a moderator: Apr 20, 2017