DVD Drive in Windows 8 Disappeared after installation

Discussion in 'Windows 8' started by calpol, Dec 4, 2012.

  1. calpol

    calpol MDL Junior Member

    Dec 5, 2009
    98
    5
    0
    Hi all,

    I have a problem with my DVD Drive.
    My problem is that I just re-installed Windows 8 and found out a problem with DVD Drive. My DVD Drive has disappeared after the first 2 restart after a fresh installation. How can I fix this problem and have my DVD drive show again please.

    Thank for your help and concerns.
     
  2. acyuta

    acyuta MDL Expert

    Mar 8, 2010
    1,629
    367
    60
    Try unplugging the two dvd cables-power and sata, and then replugging.
    Most of the time that works.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. ace2

    ace2 Guest

    #3 ace2, Dec 4, 2012
    Last edited by a moderator: Dec 4, 2012
    DVD Drive fix

    COPY

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\atapi\Controller0]
    "EnumDevice1"=dword:00000001


    INTO New Text Document & Save As Drive.reg & Merge ace2.;)
     
  4. anarchist9027

    anarchist9027 MDL Expert

    Oct 30, 2010
    1,320
    667
    60
    Does is show up in device manager? It should be under DVD/CD-ROM drives. If so, right click on it and click uninstall. Then re-scan for new devices.
     
  5. PointZero

    PointZero MDL Member

    Oct 5, 2011
    1,090
    3,033
    60
    I experienced this also. The drive worked fine after a fresh Win8 install but then disappeared after a couple reboots. ace2's reg entry fixed it for me (thank you ace2 for posting that).

    More symptoms of the problem: you'll probably notice the "drive activity" light on your system is continually lit. You won't see the DVD drive listed in Device Manager until you go to View->Show hidden devices, then it will be shown (but won't function). I tried uninstalling it in Device Manager, thinking it would be properly detected upon reboot, but no- it was gone permanently after uninstalling and required reinstall of Win8 (to then experience same issue again). Swapping out to a different DVD drive after the problem occurred didn't help either. I just had the drive unplugged until I saw this thread.

    calpol, I see ricktendo64 just posted about a new servicing stack update. I'm curious- could you try installing that update to see if it fixes the problem for you? If it doesn't fix it, use ace2's reg entry fix.
     
  6. calpol

    calpol MDL Junior Member

    Dec 5, 2009
    98
    5
    0
    Thanks a lot your help. It works well now :mml: