Enabling Auto-Power on AC Loss by default in custom AMI BIOS on custom board

Discussion in 'BIOS Mods' started by bgaller, Jan 2, 2014.

  1. bgaller

    bgaller MDL Novice

    Jan 2, 2014
    2
    0
    0
    Hi all, I have a custom board that I had made about 4 years ago (about 2000pcs), and now that the on-board batteries are getting older and failing, the boards will *not* auto-power on. This is becoming a large issue for me, and I was wondering if someone could take a look at the BIOS and simply make "auto-power on AC loss" default behavior in the BIOS so even with a failed battery, it will boot automatically. I've opened the BIOS up on AMIBCP, but there is no auto-power option under Setup Configuration. However, if I click the BIOS Strings tab, I do see "AC Power Loss" listed there with a token of 0x0011. Unfortunately I'm not well versed with the inner workings of BIOS software so I have no idea where to go from here. Any assistance would be GREATLY appreciated, thank you!
     
  2. Tito

    Tito Super Mod / Adviser
    Staff Member

    Nov 30, 2009
    17,214
    14,776
    340
    Isn't it better to just replace the batteries??

    :eek:
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. bgaller

    bgaller MDL Novice

    Jan 2, 2014
    2
    0
    0
    Hi Tito, thank you for the reply. Unfortunately, these are spread around the world and replacing batteries is simply not possible. I am willing to pay someone to get this done, and I *do* have the source code if required. Any help is GREATLY appreciated, thank you!