Expert needed - cannot update Bios of Thinkpad X61

Discussion in 'BIOS Mods' started by mickey_R, Jan 8, 2011.

  1. mickey_R

    mickey_R Guest

    I need help of you experts here. I tried to update the Bios of my X61s with the originial files from lenovo hp. First I used teh offical windows procedure with winuptp.exe (windows xp). Here I got following error massage: Bios image file cannot be found. Second I booted from USB-Stick with the files from the *iso-Image (original from lenovo). No success. Error: "The system program file was not found on the cd.".Third I tried winphlash to update with the fl1-File: Error code: "Part ID of System Bios and new Image File are different. The system platform my be different from the Image file". Proceed -> Yes, than another Error massage: "Bios update failed. The current device is not supported in the interface".
    It seems I used the wrong Bios-Files but im sure I downloaded the correct Version. If I try to "update" a backuped bios-file from the running bios, I got the masssage above (The current device is not supported in the interface...)
    Thanks for any ideas.
  2. mickey_R

    mickey_R Guest

    Additional information: It's a X61s DEMO-Pool Thinkpad with Bios 1.0