Faulty EFI keeps windows 8 recovery from loading

Discussion in 'Windows 8' started by Doodler, Jun 4, 2013.

  1. Doodler

    Doodler MDL Novice

    Jun 4, 2013
    2
    0
    0
    Hi guys, hope you can help.
    I had a dual boot system (8/ubuntu 10.12) but my win8 got messed up. Wanted to do a fresh install from my recovery usb (I made the day I got the computer) but it won't load in UEFI mode. In CMS mode the recovery stops and tells me to go into UEFI. The error given is "disk error. gpt7 cannot be found"

    After days of tring fixes I tried to do a format and clean install. Still the same problem.

    If I enter through UEFI shell, I can go into the USB and start the bootx64.uefi, but I get the error once again.
    I can use a windows 7 recovery disk (not a full install though) to format my drive to gpt and create the partitions, but it doen't effect the USB not working. (Yes I checked it for being faulty already)

    Don't know what to do at this point.

    -Doodler
     
  2. agent268

    agent268 MDL Junior Member

    Feb 20, 2012
    83
    24
    0
    You should be able to use DISM to manually reimage this bad boy using the WIM or SWMs on that USB recovery flash drive.
     
  3. Doodler

    Doodler MDL Novice

    Jun 4, 2013
    2
    0
    0
    Update: It's alive!

    I had saved my boot folder from my ubuntu install. I tried manually every *.efi file in the folders. There was a bkpbootx64.efi that started up the rescue USB. For anyone who has a similar problem, check to see if you have a backup bootx64 in your /uefi/boot folder.

    Thanks for the idea agent268. I'm curious to know if that would have worked, but I'm not that curious :D
    I couldn't access the usb (from cmd) when loading up the windows 7 recovery cd, so I couldn't get to the image anyway. Maybe I could have tried it on a win7 virtual machine in an ubuntu install? (couldn't install windows xp but ubuntu worked fine. )
     
  4. Flipp3r

    Flipp3r MDL Expert

    Feb 11, 2009
    1,518
    651
    60
    Maybe your usbkey was plugged into a usb3.0 port? Win7/winpe3/winre3 need usb drivers installed..

    Just a thought...
     
  5. Humphrey

    Humphrey MDL Expert

    Dec 13, 2011
    1,458
    981
    60
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...