For those for whom none of the loaders don't work....

Discussion in 'Windows 7' started by Maguro, Aug 2, 2009.

  1. Maguro

    Maguro MDL Novice

    Aug 2, 2009
    2
    0
    0
    It's been interesting reading all the reponses and questions here!

    A big thanks to Orbit30 and Hazar for going out of their way for providing the tools and support for many of us to get W7 activated.

    The forum is a bit tricky also because the softmod route and hardmod route are not so clearly separated. Most people, I think would prefer the softmod route, no patching of BIOS is needed and the grldr is used to fake the correct bios in memory after which the activation works..

    With this post I'd like to ask other users about their experience and tests on what they have done with the loader that didn't work as I am seeing that there are a growing number of people including myself for whom the tool does not work...

    So let me start of with sharing my own experience... I first installed W7 32B in a virtualbox environment and ran the first run of Hazar's loader and was activated! Hurrah!!!

    With that, I decided to install it on my Shuttle SN41G2 V3 (1Gb, XP3200+ AMD cpu, about 6/7 years old). This machine has been running MCE2005 for years and very smooth too.

    W7 Install just fine. After installing I am even updating some drivers and everything seems to work fine.

    Next up is Hazar's original loader, after installing, the system reboots and..... keeps rebooting.. After the CD check (with or without W7 disc in) the system just reboots... No loading screen... nada...

    After many attempts of deleting parittions/reloading I found that going into repair mode and choosing the command prompt and typing

    bootsect /nt60 c:

    would bring me back to normal...

    Interestingly enough, when in the command prompt, the C: drive is the 100Mb reserved partition! The d: drive is the Win drive which was the C drive when actually booted in W7 and the E drive is the CD rom. The command prompt runs of the X drive, which I think is a ram drive..

    Anyways, after this I can boot back into W7 again.

    I then find the instructions to do things manually, used WinRAR to extract the loader

    #1. replace tokens.dat and pkeyconfig.xrm-ms if you installed any frankenstein build stuff
    (not sure what this 'frankenstein build' is... and replace with what?)
    2. attrib C:\grldr -h -s -r ( if exists rename to grldr.bak )
    3. copy grldr, bootinst.exe and Cert.xrm-ms to C:\
    4. attrib C:\grldr +h +s +r
    5. bootinst.exe /nt60 C:
    Says it succeeded but also shows 'Access denied', hazar in a post says it's ok.
    6. slmgr.vbs -ipk *****************************
    OK, get confirmation screen
    7. slmgr.vbs -ilc "Cert.xrm-ms"
    OK, get confirmation screen
    8. del C:\Cert.xrm-ms
    ok
    9. restart

    And.... reboots!!!!

    bootsect /nt60 c: routine to bring me back..

    Chinese loader/combined loader with Orbits etc all do pretty much the same...-> continuous reboots...

    Something with the bootloader must be iffy..



    So maybe NOT go the softmod route but the hardmod route?

    In doing so, I am trying to asses what BIOS I have and look it up on the shuttle website... An Award BIOS apparently but also Phoenix... of 2005, no newer one is available, nor I think will ever since this box is DA-ed.

    Then trying to find this magical SLIC number which needs to be 2.1

    RW-Everything. -> there is no SLIC table in the output ACPI lists
    SLIC DUMP -> Can't find SLIC info
    Everest -> NO SLIC info..

    My BIOS is that old, that it hasn't ANY slic info?

    Could that be the root cause for the loader not working? My hunch would be that even if my BIOS was written on punchcards in Farsi from the early 1900 the loader should work? The whole idea is to bypass the BIOS alltogether


    Some people mention multiple partitions...

    I had 2 partitions on a SATA drive to start with (15gb/300gb) and after installing I ended up with 3 (reserverd 100mb, 15gb, 300)

    For the heck of it I installed on an IDE drive (20gb) and wiped it for the install, same problem...



    From moment one, I had I Virus protecion and BIOS protection in the BIOS... same problem...

    Unfortunatelly, the actual grldr loader has some options (by hitting c while booting) but those have been disabled... saw a request from someone to bring those back but hazar said no...


    As of yet, no activated W7 yet....

    Any other people care to share their findings? Maybe hazar/orbit look at these posts and decide to perfect their loaders based on our findings...

    Thanks
     
  2. Maguro

    Maguro MDL Novice

    Aug 2, 2009
    2
    0
    0
    #2 Maguro, Aug 2, 2009
    Last edited by a moderator: May 23, 2017
    (OP)
    Solving my own issue...

    My thought was that not having a SLIC table at all caused the issues of the constant rebooting after applying Hazar/Chinese/Orbit loaders but thats's not the case!!!

    There are more users without SLIC table:

    http://forums.mydigitallife.net/posts/82266
    http://forums.mydigitallife.net/posts/82004
    http://forums.mydigitallife.net/posts/82194
    http://forums.mydigitallife.net/posts/82842

    It's all down to AN OLDER VERSION OF GRUB LOADER (GRLDR) USED BY HAZAR/ORBIT

    Master Yen noted that grub could hang your compu:

    http://forums.mydigitallife.net/posts/82224

    But when it works it shows a message:

    http://forums.mydigitallife.net/posts/82990

    which will hopefully disappaer with newer grub

    http://forums.mydigitallife.net/posts/83000

    So I tried the 7.0.1a version of WOW7 and that works!!!

    So install W7 as usuall and assign a letter (I chose R) to the 100Mb system partion.

    Extract the 7.0.1a files and copy the 7.0.1a files to the root of R: (so you have grldr and menu.lst in r:\ and the other files in r:\wow7

    Open up a command prompt (I opened as administrator)

    run install_cert.bat, wait and OK the message that it was successfull
    run install_key.bat, wait and OK the message that it was successfull
    run install_wow.bat

    reboot!

    After the reboot I removed the R drive letter, making the sys part hidden again and it worked OK

    You need to leave it installed though:

    http://forums.mydigitallife.net/posts/82039


    Thanks and good luck...