Front usb ports weren't detected by windows 8 pro until rebooted

Discussion in 'Windows 8' started by Zagai, Mar 4, 2013.

  1. Zagai

    Zagai MDL Novice

    Nov 12, 2012
    19
    1
    0
    :)Need to rebooted everytime after I had started windows 8 Pro. Could you please someone experts help me that what happended on my Wins 8 pro. Thank you in advance.:)
     
  2. ZooKi1

    ZooKi1 MDL Novice

    Apr 6, 2010
    8
    1
    0
    do you reinstall windows 8?
     
  3. pisthai

    pisthai Imperfect Human

    Jul 29, 2009
    6,729
    1,954
    210
    Never had or heard from such problem, with exception of contact problem which were solved using a special Contact Cleaner like Kontakt 61.

    But a question: at which stage that problem happen? with an device connected while starting the computer or connecting a device while the computer is running? If later, I would change the USB connectors with their cable inside the computer after testing the device with an different cable. I hardly believe its a Windows 8 problem.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. anarchist9027

    anarchist9027 MDL Expert

    Oct 30, 2010
    1,320
    667
    60
    Do you have the proper drivers installed :eek:
     
  5. pisthai

    pisthai Imperfect Human

    Jul 29, 2009
    6,729
    1,954
    210
    As default the drivers for the "normal" front USB are build in Windows 8, exception maybe the USB 3.0 drivers. But a check in Device Manager will show if there is a Driver problem.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. Zagai

    Zagai MDL Novice

    Nov 12, 2012
    19
    1
    0
    #6 Zagai, Mar 4, 2013
    Last edited: Mar 4, 2013
    (OP)
    I am still using Win 8 pro onward although i have to restart again and again. I didn't waste my time to reinstall it again
     
  7. Zagai

    Zagai MDL Novice

    Nov 12, 2012
    19
    1
    0
    :)Both of how to solved this issues had tried periodically either before or after every starting had just repeated to start windows 8 its work fine. I thought all original drivers from DVD iso.file likely good and have already checked from device manager.
     
  8. pisthai

    pisthai Imperfect Human

    Jul 29, 2009
    6,729
    1,954
    210
    The Front USB are 2.0 or 3.0?

    With device connected while start computer, Windows "see" the Device? Yes or No?

    Did you had changed the USB Connector and Cable of Front USB? Yes or No?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. Zagai

    Zagai MDL Novice

    Nov 12, 2012
    19
    1
    0
    1: MB can only use USB 2.0.I realized, Especial in the early morning for first use my computer Windows didn't "see" my USB flash drive 2.0 at the front panel even if had plugged in it or not
    2: I have already changed The Front panel usb for new one and have tried to pluged usb flash drive in but it still can not work well
    It could be possible to reinstalled OS again.
     
  10. pisthai

    pisthai Imperfect Human

    Jul 29, 2009
    6,729
    1,954
    210
    Just curious: Check the BIOS is the latest available one. If not, I would suggest to update the BIOS first. Many machines having problems with older BIOS's!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  11. Zagai

    Zagai MDL Novice

    Nov 12, 2012
    19
    1
    0
    :) Agreed according to that,But I don't know How to update the latest available BIOS of Intel MB . I have MB Intel DH55PJ socket 1156. I used to successfully updated the old BIOS of my ASUS P7H55-M for new one and it had worked fine. I have never tried to updated the Intel MB' BIOS. Any link? ;)
     
  12. pisthai

    pisthai Imperfect Human

    Jul 29, 2009
    6,729
    1,954
    210
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  13. Mayplay

    Mayplay MDL Novice

    Mar 6, 2013
    1
    2
    0
    Hey!

    I may have something for you, I had a similar problem with my USB port, my USB 3 ports were detected as USB 2 after a normal boot.

    But after a normal restart from Windows... here was the magic, my usb ports were now detected as USB 3. I had no way to make it work without a reboot.

    After two weeks of search I finally remembered that Windows 8 come with a new feature called Hybrid Boot, made a little search how to disable it, and there I was, my problem was fixed !

    What I can understand of it, when you do a normal shutdown, the kernel puts itself in hibernation, but not your user session, so when you boot up, the kernel is just loaded back, scan for new hardware and that's it, but it seems to f*ckup with detecting correctly USB ports.

    Do a little search on it, you'll find plenty of sites explaining it !

    In order to disable it, just do the following step :
    - Control Panel
    - Power Options
    - Select "Choose what the power buttons do" (on the left)
    - At the top, click on "Change settings that are currently unavailable"
    - Uncheck "Turn on fast startup (recommanded)"


    I hope it will solves your problem !
     
  14. Zagai

    Zagai MDL Novice

    Nov 12, 2012
    19
    1
    0
    :) Superlative, You great, I can solve a tiny problem easily and have already updated BIOS for newest one simultaneously.:worthy:
     
  15. neofita

    neofita MDL Junior Member

    Nov 27, 2013
    53
    44
    0
    my friend, you're a genius ... they were months that I fight with this problem ... no one had been able to help me ... thanks again!