Fujitsu-Siemens Amilo A 1667G with the P50CA

Discussion in 'BIOS Mods' started by dimaries, Oct 20, 2009.

  1. dimaries

    dimaries MDL Novice

    Oct 20, 2009
    I am representing a group of Fujitsu-Siemens Amilo A 1667G with the P50CA mainboard owners. Many of us have bought Windows 7 to install to our notebooks, and many are thinking of buying them.
    The problem is, that after the BIOS upgrade to version 1.07, and Windows 7 installation, the AMD Turion 64 MT-37 Processor does not gain his full frequency. Windows 7 recognize the processor speed at only 800 MHz and do not scale the speed up to 2.0 GHz. I have tried everything with the power management settings, but the processor clock stays in 800 MHz.
    I have contacted with other users with the same notebook that have exactly the same problem under Windows 7. So, we came to the conclusion that this fact has something to do with the processor power throttling from the BIOS.
    Is there anything that we can do to deaL with this issue?
  2. Fotoderoodt

    Fotoderoodt MDL Novice

    Nov 3, 2009
    Bios update isue windows 7

    Sorry I do not understand the problem, as far my information goes it is a 800 mhz processor... So how can you say 2000???

    Processor AMD Turion 64 ML-37
    Processor ID AuthenticAMD Family 15 Model 36 Stepping 2
    Processor Frequency 800 MHz Processors 1
    Cores 1 Threads
    L1 Instruction Cache 0.00 B L1 Data Cache 64.0 KB
    L2 Cache 1.00 MB L3 Cache 0.00 B
    Memory 2.00 GB 333 MHz FSB 200 MHz

    Where did you get the bios update>?
  3. sirix

    sirix MDL Novice

    Aug 5, 2009
    It's a Notebook, the Turion CPU also is a Notebook CPU, when Powersaving is on CPU get throttled to 800 Mhz. ;)

    @Topic I'm also a A1667G Owner, i think that there is no hope the we will ever get a fixed Bios. (same Problem was at Windows Vista after SP1).

    A possible fix is to use the Windows XP driver (amdk8.sys), but this solution sucks.
  4. Darth_nVader

    Darth_nVader MDL Novice

    Nov 17, 2009
    Is the Multiplier locked at it's lowest level?

    Has anyone tried RMClock to see if it can be changed?

    If you can gather more info, maybe a fix or work around can be found.

    I'm assuming it's some trouble with Cool n' Quiet.