Graphics card problems

Discussion in 'PC Hardware' started by Captainlady, Mar 16, 2014.

  1. Captainlady

    Captainlady MDL Novice

    Aug 16, 2013
    10
    1
    0
    #1 Captainlady, Mar 16, 2014
    Last edited: Mar 16, 2014
    Hi,

    Can any one help me solve this problem, My graphics card-MSI R9 270x isnt giving a signal to my monitors.
    The fans are spinning, but no signal, PLUS my usbs are not working either and this despite having a 750w psu.

    Any help is appreciated.
     
  2. Windows user

    Windows user MDL Senior Member

    Sep 11, 2012
    445
    101
    10
    Most probably a motherboard problem bro, get it checked in a local computer shop....faulty graphics card has nothing to do with non-functional USB
     
  3. Captainlady

    Captainlady MDL Novice

    Aug 16, 2013
    10
    1
    0
    Damn, I figured as much:( i spoke to the help desk people who sold me the computer- and he said it was most likely my software! so re-installed, and really nothing changed. Ive even tried uninstalling the drivers to the graphics card im using at the moment in case it was that.
     
  4. Leslie_Coffelt

    Leslie_Coffelt MDL Member

    Feb 6, 2014
    135
    37
    10
    The folks who sold you the computer - are they reputable, is the computer under warranty?

    Is this a new video card? Check to verify it is fully seated. (Has it ever worked?)

    Does the motherboard have integrated video? If so, check the bios settings. Some bios also let you selectively enable USB ports. Did these problems (video+usb) happen at the same time? If so, then I too would suspect a motherboard failure.
     
  5. Captainlady

    Captainlady MDL Novice

    Aug 16, 2013
    10
    1
    0
    #5 Captainlady, Mar 17, 2014
    Last edited: Mar 17, 2014
    (OP)
    It did work to start with, then it went to sleep and from then on, wont work.. I got a new Psu and this has changed nothing. I checked the bios as best I can- Im not that skilled when it comes to the bios so Im sure its all working. The card was bought from a seperate store online that has a bad return policy, I have to send back to the manufacturer if faulty which i think is crazy! They didnt sell it to me, the store did so they are the ones who should replace it!
    The computer is under warrenty, Ive got 3 years parts etc, and life time free support so thats that covered.
    Ive reset the bios, Ive tried to find programs thatll check for issues with the bios or the MB itself but Im not really getting anywhere with this.
    I just want to my awesome Graphics card working again :(
    Could it be an issue with my software?
    I really dont have a clue anymore.
     
  6. manu198045

    manu198045 MDL Member

    Aug 24, 2010
    114
    40
    10
    Dear Hotpot0964,

    Captainlady has mentioned about the usb ports on his motherboard, not the usb drive. :D

    @Captainlady it seems your motherboard is faulty, get it replaced as you still have warranty.

    Regards,

    Manu
     
  7. Captainlady

    Captainlady MDL Novice

    Aug 16, 2013
    10
    1
    0
    Thanks guys, talked to the support people today... They reckon its the card, and we talked everything through- honestly,I think its the graphics card as everything else is fine, the usb dont work when i boot up with the graphics card in,otherwise they are fine.
    Oh well,
     
  8. manu198045

    manu198045 MDL Member

    Aug 24, 2010
    114
    40
    10
    Dear Captainlady,

    After replacing your graphics card, if everything works well please do post the results so that whoever faces the same problem can easily understand that the problem lies with graphic card. It will be help for others who search for such issues.:)

    Regards,

    Manu