GTX 550TI Dead ????

Discussion in 'PC Hardware' started by riajulzanna, Sep 20, 2015.

  1. riajulzanna

    riajulzanna MDL Junior Member

    Nov 16, 2013
    51
    5
    0
    My Gpu Fan is Spinning but No Display :weep:

    It happened suddenly...I'm doing some online work then all of a sudden the monitor display got black but PC was running..then I just turned off the PC and restart it back but no DISPLAY(Nothing in Monitor).
    No I'm running the PC by on-board graphics(HD 4000)

    N.B- I have opened the GPU but no any sign of burn or any Capacitor leakage :g:



    Spec:
    Nvidia GTX 550 TI
    Thermaltek TR2 450W
    G Skill 16GB DDR3
    Asus B85 MG with a G3258

    Any Suggestion will be gladly accepted... :tea:
     
  2. LatinMcG

    LatinMcG Bios Borker

    Feb 27, 2011
    5,264
    1,422
    180
    likely memory or chip needs reflow.. clean that fan often from now on if it works after reflow.
     
  3. Hadron-Curious

    Hadron-Curious MDL Guru

    Jul 4, 2014
    3,377
    459
    120
    I always go against GPU reflow because the problem will definitely reoccur after few weeks or months. It is advisable to simply get an new mobo whenever you can, if it is integrated.

    Have you checked the RAM?
     
  4. QuantumBug

    QuantumBug MDL Developer

    Mar 7, 2012
    1,473
    1,292
    60
    So you say your ATI HD4000 is working or not?

    If so it's likely your 550Ti seems your PSU is actually a good brand... Yet I wouldn't rule it out.

    Were you doing GPU intensive work when the issue occurred or just editing documents, etc?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. riajulzanna

    riajulzanna MDL Junior Member

    Nov 16, 2013
    51
    5
    0
    I'm running my PC in On-board graphics(Intel 4000) without any problem...The Only prblm is in tht GPU :(
     
  6. riajulzanna

    riajulzanna MDL Junior Member

    Nov 16, 2013
    51
    5
    0
    It's not ATI, It's Intel HD 4000 On board built in Display Graphics.
    It occured while I'm doing some normal internet browsing....No any sign of burn or any burn smell from it...Indeed it's a 3 Years old GPU,may be its time is over :eek:
     
  7. riajulzanna

    riajulzanna MDL Junior Member

    Nov 16, 2013
    51
    5
    0
    You are right ;) but the process is kinda risky :D & I don't have any Hot Gun.